How to import audio without thumbnail?


#1

Hello! I’ve stumbled upon a small challenge…

I have audio files that are exported from Auphonic, including a thumbnail.
Then I have a project in Shotcut with a video track in the background displaying a podcast cover image and a video track on top that generates the soundwave of the audio file. This was working great when the audio files had no thumbnails.

However, when I now import the new audio files that include a thumbnail, this thumbnail is displayed and covers the actual cover image I want to use from the other track.

I can’t deactive video on this track / audio file because I want to generate the soundwave. (right?)

What’s the trick to get rid of the audio thumbnail?

The only workaround I’ve been able to come up with is to open the audio file in Audacity and create a new export without thumbnail, then import this new file in the Shotcut project. It’s kind of tedious… I suspect there’s an easier way of removing the thumbnail within Shotcut directly, is there? Perhaps by excluding it on import somehow? Or removing it in the file? Any ideas?

Thanks in advance!


#2

You can deactivate the video. The audio will play.

Put the audio on an audio track.


#3

Hi Sauron, thanks for the tipps! But unfortuantely they miss the point, which was: I need the audio in a video track to be able to create a soundwave, right? And in that case, I can’t deactivate the video or the soundwave no longer displays.


#4

You didn’t say what format your media file is in. If it is MP3 you can delete the thumbnail with a tag editor such as https://www.mp3tag.de/en/


#5

The sound wave displays with the video deactivated.
.image


#6

Hey, thanks for this tip! Will try it!
And yes, it’s an mp3!


#7

I tried it again, but on my system the soundwave does not show in the preview if I deactivate video. On your screenshot video seems to be activated (I mean the little eye symbol to the left)


#8

You probably have show audio waveforms disabled. Right click track header to check it.

image


#9

Show Audio Waveforms is enabled - and I see them when the video ‘eye’ symbol is activated. I don’t see them when I deactivate the ‘eye’. But that makes sense, since the waveforms are part of the visual, or not?


#10

I just did a test and when I click the “eye” it romoves the picture of the thumbnail from the preview window (as you would expect), but the waveform is still visible on the track. i.e. the waveform visualisation on the track shows regardless of whether the “eye” is open or closed.


#11

@Elusien is correct.

If you add an audiofile with artwork to the timeline the artwork will display, the audio will play.
If you mute the track the audio waveform will disappear but the artwork will still play in the viewer.
If you hide the track the artwork will not display in the viewer, the waveform will still show.

20%20PM%20001

20%20PM

19%20PM


#12

I just realised: are we talking about the same waveform? I meant the filter on the track to display the soundwave in the final video, not the waveform in admin … sorry if that was unclear in my initial question!


#13

Select the clip, then in the Properties, Video tab, set Track = None


#14

That’s done the trick! Yaaaay!! Thanks a lot! I thought there had to be an easy way … :slight_smile: