How to get rid of Interlace artifacts in output video

I’m using the default export option without any changes but this leaves interlaced artifacts in the output .mp4 video. What setting should I choose to get rid of the interlaced artifacts? My input videos are a combination of Interlaced and Progressive videos.

Two things:

  1. Interlaced video clips in the project must show Properties > Video > Scan mode > Interlaced (sometimes files lack proper metadata and you can override it). The field order here is also important.
  2. Export > Advanced > Video > Scan mode must be Progressive. This option defaults based on Video Mode, which may or may not depend on #1.

If you still have a problem connecting these points, you can try using Properties > Convert > Advanced > Deinterlace on your interlaced clips showing the artifacts. When the convert job completes successfully, Shotcut automatically replaces the clip in your project with the result.

1 Like

In most cases, if you have set your Video Mode to a progressive format, deinterlacing will happen automatically. If your video mode is “Automatic” and you happened to open an interlaced clip first, then your video mode might be interlaced. I recommend to set the video mode explicitly to exactly the mode you want to output.

As @shotcut mentioned, deinterlacing might be skipped if the interlacing is not detected in your source clip. This is rare. But if it happens, you can override it in the clip properties.

The scan mode for Interlaced videos is already Interlaced under Properties and Progressive under Export. If I select Properties > Convert > Advanced > Deinterlace it opens a dialogue to save the clip as mp4. I have many clips, do I need to convert all of them one by one?

Scan mode is Progressive while exporting and the video is correctly being detected as Interlaced under properties.

Then you might have interlace this is difficult to remove, possibly for your level of scrutiny. You can try the different Deinterlace options in export to see which works best for you. Beyond that, I think you have exhausted my help on this.

I have many clips, do I need to convert all of them one by one?

Try one and see. If you decide to go this route, use View > Resources… to batch convert.

If you want to share a sample clip on a public file share site, I am willing to try it.