How to animate a PNG picture (varying its size and position) over a short video

I have a PNG picture and a short (about 5 seconds long) video. The video is an animation of a humanoid figure with red glowing eyes, but without pupils. I basically want to use the PNG picture as the humanoid figure’s pupils, that is, the PNG should always be positioned in the middle of each eye in the video that I want to create. Also, the PNG should be scaled with respect to the size of the eyes in the video at each point in time.

I don’t care about rotation, i.e., the pupils do not need to be correctly displayed with respect to 3D perspective.

I guess there’s a filter that I should use for overlaying the picture over the video, and maybe another filter to change the picture’s size? Do such filters exist?

EDIT: also, my picture is a square, I’d like to crop it into a circle when displaying it on the video, I’m sure there’s a way to do that in Shotcut.

Hi @nsajko
If the PNG is just two dots (the pupils) on a transparent background, you don’t need a filter to overlay it over the video. Just put PNG on a track above the track where you put the video. If the background of the PNG is not transparent, you’ll have to add the Blend filter and choose the blend mode that corresponds to your image.

To resize and position the PNG : Size, Position & Rotate filter.

1 Like

Crop a square into a square ?

Yes. The Crop: Circle filter

1 Like

When I insert my picture into a track above my video, the picture transforms into a 4 hours long video. Is there a way to make this video of the picture automatically the same length as my video that is about 5 seconds long?

1 Like

There’s a problem: this filter has nice GUI helpers for adjusting size, position, and rotation by dragging on the video display (there’s a rectangle for size and position and a bar for rotation). Is there a way to disable those, or at least make them fully transparent?

My problem is that I scale the picture to be really small (pupil size), but these helpers stay the same size, so I can’t see my image on the video because of it being totally obscured by the helper rectangle and helper bar.

You can disable them temporarily, but you have to reenable them to continu edit.

Also, zooming the view in the preview window might help.


This topic was automatically closed after 90 days. New replies are no longer allowed.