Help, please. Video progressively out of sync

Hi guys, I’m new to the boards and I have very little experience using the program.
I started using it last year just to cut some clips here and there nothing too difficult. I have managed to learn a few things watching youtube tutorials but now I need to do more complex tasks and I’m not getting good results.

I have downloaded a few cam clips but some of them have really bad audio and I’m trying to fix them.
Some of these clips begin on sync but after a couple of minutes the sound starts to go ahead of the video. Strange thing is video and audio are the same lenght.

This is tricky problem. I have already tried some fixes without any luck. Please, can you help me.

1 Like

Welcome to the Forum.

There are many threads on this subject; many people have experienced this (and I am one).
It always comes down to the same thing: Variable Frame Rate (VFR) original video material.

The solution is always the same: Convert the video to Constant Frame Rate (CFR) as the FIRST step of the video project.

Shotcut provides as tool for this (the Convert button), or you can use a custom codec to get the speed/quality/size compromise that best fits your needs.

1 Like

Also Try Settings - Synchronisation

image

Thanks for your help guys. I’ll try your suggestions when I have a little time and then report back.

If you still can’t get the sync right, I use DAW Reaper software that allows you to stretch and shorten the audio track and at the same time display the video for reference.
Sometimes the mismatch is not linear and that’s when I use this method outside of Shotcut for audio only.
I recently posted a screenshot about an audio sync on a dub that didn’t match the original sound.

I tried what you said but it didn’t fix the problem. I tell you what I did.
First I created a new project, then opened the clip. I searched for the convert button but I didn’t find it so I read on other topics that I should convert to edit friendly. I think it’s the same so I did that. Afterwards I put my converted file in the timeline. Finally I exported from timeline as H264 baseline profile. I got a good quality video clip but the progressive audio out of sync is still there.
Should I have checked “use hardware encoder” box?
Is it possible that my clip is not variable frame? I used formatfactory info and it tells me it’s constant…
https://textuploader.com/tsftw

Video offset in Player sync is set the same as PaulusMaximus shows.

As for DAW Reaper I don’t have that installed and I don’t know about it but I’ll give it a try eventually.

Thanks all of you for your help.

I’ve had many situations like this and the way to solve it is to adjust the speed of the video to match the audio. You don’t need to use another program. You can do it all in Shotcut. So bring your clip into the timeline then right click to bring up the menu to detach the audio. After that click on the video and go to the Properties tab. There start playing around with the numbers of the Speed parameter until you see it match with the audio. One of the great things about Shotcut is that it gives you a lot of control for speed so in almost all cases I’ve been able to get it to match.

Well, in your case I am not sure if it’s specifically the video or audio but the same thing can be done with audio if that is where the issue is.

By the way, can you go to the Properties tab of your video clips and tell us what it says for Frame Rate in the Video tab?

1 Like

Two ways to get there.

  • With the clip om the Timeline, and Selected, go the the Properties window. The Convert button should be there.
  • Double-click on the clip in the Playlist. (this will open the clip in Source). Go to the Properties window, the Convert button should be there.

If the Convert button is NOT there, you probably have an old version of Shotcut.
If that is the case, upgrade to 21.03.21

How is the audio “bad”?

I ask because sometimes files have bad audio synchronization encoded in them due to bad packet timestamps. Shotcut can not fix files that already have bad synchronization. And even “Convert to edit friendly” does not fix bad synchronization or timestamps.

Maybe this is your situation?

1 Like

I really can’t explain the problem in a more technical way as I don’t have necessary knowledge. In some of those cams video and audio start on sync but after a little while playing the audio starts to go ahead a little bit. At the end of the video it’s very noticeable. This is the worst of my problems.
Other cams have very low audio but are on sync and others have too much ambient noise and the voices are difficult to hear but first I would like to fix out of sync ones, I can’t stand that.
I’ll continue with your suggestions when I have more spare time. Thank you guys.

Hello. I just want to let you know what happened.

This two weeks I was testing out some of the suggestions you made with several of my cam videos. In my case aparently the problem was not variable bit rate. What really helped to solve my problem was what DRM said. So I change the speed a little bit until it I got pleased with the result. It was trial and error with a few cams so I took much time. The results are not an excellent a/v synchro but it’s much better now. Best of all is that I learnt a lot about using Shotcut. Thank you very much.

4 Likes