HELP : Export failed with exit code 3

I am sorry but this is the first time we use shotcut. How can I parametryze the “in” and “out” to export ?

Have a look at this post to see how to do it. "Export selection" for rendering multiple clips per project

I know it might take some time to narrow down the problem, but each time you halve the amount exported you halve the time, so you should be able to get there without it taking all day.

Bon chance and I hope you get it sorted soon.

I tried to do that but each time I click on “Copy timeline to source”, Shotcut crash.

Oh! in that case it sounds as if you are going to have to do it the hard way. I would do the following: make a copy of the MLT project file. Call it say '‘A.mlt’. Open A, then:

  • position yourself to a point about half-way, make a note of the track (HH:MM:SS;tk) and split the viedo there.
  • delete everything to the right of the split, then export the remaining (first half).

If that exports OK open A, position to the point about halfway (HH:MM:SS;tk), split it and delete everything to the left and then save A. and repeat the process. If the export failed, then open A, position, split and delete eberything to the right.

Make a hardcopy note of where the splits were made so if anything goes wrong you know where to make the splits again.

is it possible to make a multiple selection to do that ?
If not I will have to delete manualy one by one all photos and videos each time.

Ah, I forgot that you said you had lots of clips.

My only other suggestion then would be to try disabling filters in the same manner. i.e. disable roughly the first half of the set of filters see if export works. If so, check that enabling these and disabling the last half causes the problem. Then again set about disabling half of the set that causes problems… In that case it is almost certainly to do with a “bad” filter, so do the halving in a similar manner unltil you find which one it is.

do i need to do clip by clip for the filters ? is there a solution to do that on multiple selection ?

I’m sorry, I’m not being very helpful am I? So far as I know you can’t do it on multiple selections and would have to do it on individual clips and since, as you pointed out, you have a very large number of these my proposal isn’t really an option.

The fact that you can’t copy the timeline to source without Shotcut crashing is also worrying.

You could try importing the project as a clip and exporting that. That might work:

  1. Open Shotcut.
  2. File->Open MLT XML as Clip
  3. Drag the start and end points in the Player pane to the part you want to export
  4. Export as normal (or try exporting the whole clip without modifying the endpoints).

Before doing this I’d reboot your system and make sure not to have anything else running at the same time.

unfortunately nothing fix this issue at moment.
When we extract the 1st test 48min it is ok, then we tried the last version 53 min (new clip + new filters but same as others in the 1st part) we had the error code FAILED wWITH EXIT CODE 3.
I don’t know how we can fix this issue.

OK, now try to export the last 25 minutes. If that fails, the problem is in the last 25 mins of the video, if not it is in the part 48 mins to 48 + (53-25) = 73 mins. Let us say it is in the last 25 mins. So now try to export the last 10 mins, if that fails try to export the last 5 mins and so-on until you get narrow it down to a very small value that will not export. That is where your problem probably lies.

What you do then depends on what your video is about. You may be able to delete that very small part of the clip without it affecting the video. You may be able to replace it with a new part that tries to fill-in the gap …

N.B. make sure you have a copy of the original MLT file.

Hello,

I tried to re start from the 1st export 48min. I had the new clips it is ok. Than I had some filtrer and transitions but exactly the same I used in the 48 first min.
I tried to export and FAILED:

plugin_mgr_get_object_file_plugins: error opening shared object file ‘C:\Program Files\WindowsApps\63764Meltytech.Shotcut_20.2.17.0_x64__n3ep7ff047466\lib\ladspa/AUTHORS’: “C:\Program Files\WindowsApps\63764Meltytech.Shotcut_20.2.17.0_x64__n3ep7ff047466\lib\ladspa\AUTHORS”: Le module sp�cifi� est introuvable.

plugin_mgr_get_object_file_plugins: error opening shared object file ‘C:\Program Files\WindowsApps\63764Meltytech.Shotcut_20.2.17.0_x64__n3ep7ff047466\lib\ladspa/COPYING’: “C:\Program Files\WindowsApps\63764Meltytech.Shotcut_20.2.17.0_x64__n3ep7ff047466\lib\ladspa\COPYING”: Le module sp�cifi� est introuvable.

plugin_mgr_get_object_file_plugins: error opening shared object file ‘C:\Program Files\WindowsApps\63764Meltytech.Shotcut_20.2.17.0_x64__n3ep7ff047466\lib\ladspa/readme.txt’: “C:\Program Files\WindowsApps\63764Meltytech.Shotcut_20.2.17.0_x64__n3ep7ff047466\lib\ladspa\readme.txt”:

[h264 @ 0000000009eb8f40] Reinit context to 1280x720, pix_fmt: yuv420p

[h264 @ 0000000009ebe280] Reinit context to 1280x720, pix_fmt: yuv420p

[mov,mp4,m4a,3gp,3g2,mj2 @ 0000000009ec2240] Value 1.000000 for parameter ‘seekable’ out of range [-1 - 0]

[h264 @ 0000000027e3b7c0] Reinit context to 1280x720, pix_fmt: yuv420p

[producer avformat] audio: total_streams 1 max_stream 1 total_channels 2 max_channels 2

[AVIOContext @ 00000000009508c0] Statistics: 1428202 bytes read, 2 seeks

[AVIOContext @ 000000002a241e00] Statistics: 1428202 bytes read, 2 seeks

[AVIOContext @ 0000000000951d00] Statistics: 1428202 bytes read, 2 seeks

[h264 @ 000000000094ee80] Reinit context to 1280x720, pix_fmt: yuv420p

[h264 @ 000000002a37cb40] Reinit context to 1280x720, pix_fmt: yuv420p

[mov,mp4,m4a,3gp,3g2,mj2 @ 000000002a382800] Value 1.000000 for parameter ‘seekable’ out of range [-1 - 0]

[h264 @ 000000002a37e300] Reinit context to 1280x720, pix_fmt: yuv420p

[producer avformat] audio: total_streams 1 max_stream 1 total_channels 2 max_channels 2

[AVIOContext @ 00000000009508c0] Statistics: 1428202 bytes read, 2 seeks

[AVIOContext @ 000000002a382e00] Statistics: 1428202 bytes read, 2 seeks

[AVIOContext @ 0000000000951d00] Statistics: 1428202 bytes read, 2 seeks

[h264 @ 0000000009ebf5c0] Reinit context to 1280x720, pix_fmt: yuv420p

[h264 @ 000000001363b340] Reinit context to 1280x720, pix_fmt: yuv420p

[mov,mp4,m4a,3gp,3g2,mj2 @ 0000000013641000] Value 1.000000 for parameter ‘seekable’ out of range [-1 - 0]

[h264 @ 000000001363c140] Reinit context to 1280x720, pix_fmt: yuv420p

[producer avformat] audio: total_streams 1 max_stream 1 total_channels 2 max_channels 2

[AVIOContext @ 0000000009eb5600] Statistics: 1428202 bytes read, 2 seeks

[AVIOContext @ 0000000009eb5780] Statistics: 1428202 bytes read, 2 seeks

[AVIOContext @ 0000000000950180] Statistics: 1428202 bytes read, 2 seeks

[h264 @ 0000000009ebb580] Reinit context to 1280x720, pix_fmt: yuv420p

[h264 @ 000000001863b7c0] Reinit context to 1280x720, pix_fmt: yuv420p

[mov,mp4,m4a,3gp,3g2,mj2 @ 0000000018582740] Value 1.000000 for parameter ‘seekable’ out of range [-1 - 0]

[h264 @ 000000001863c5c0] Reinit context to 1280x720, pix_fmt: yuv420p

[producer avformat] audio: total_streams 1 max_stream 1 total_channels 2 max_channels 2

[AVIOContext @ 00000000277ffec0] Statistics: 1428202 bytes read, 2 seeks

[AVIOContext @ 00000000277ff080] Statistics: 1428202 bytes read, 2 seeks

[AVIOContext @ 00000000277ff700] Statistics: 1428202 bytes read, 2 seeks

[h264 @ 0000000009ebc1c0] Reinit context to 1280x720, pix_fmt: yuv420p

[h264 @ 00000000187be140] Reinit context to 1280x720, pix_fmt: yuv420p

[mov,mp4,m4a,3gp,3g2,mj2 @ 00000000187c1800] Value 1.000000 for parameter ‘seekable’ out of range [-1 - 0]

[h264 @ 00000000187c22c0] Reinit context to 1280x720, pix_fmt: yuv420p

[producer avformat] audio: total_streams 1 max_stream 1 total_channels 2 max_channels 2

[AVIOContext @ 00000000277ff440] Statistics: 1428202 bytes read, 2 seeks

[AVIOContext @ 00000000277ff5c0] Statistics: 1428202 bytes read, 2 seeks

[AVIOContext @ 00000000277ffc40] Statistics: 1428202 bytes read, 2 seeks

[mov,mp4,m4a,3gp,3g2,mj2 @ 00000000294f6340] Value 1.0000

(qmelt.exe:11568): GLib-WARNING **: GError set over the top of a previous GError or uninitialized memory.

This indicates a bug in someone’s code. You must ensure an error is NULL before it’s set.

The overwriting error message was: Couldn’t load bitmap

(qmelt.exe:11568): GLib-WARNING **: GError set over the top of a previous GError or uninitialized memory.

This indicates a bug in someone’s code. You must ensure an error is NULL before it’s set.

The overwriting error message was: Couldn’t load bitmap

00 for parameter ‘seekable’ out of range [-1 - 0]

[producer avformat] audio: total_streams 1 max_stream 1 total_channels 1 max_channels 1

[AVIOContext @ 000000002a0ffec0] Statistics: 353047 bytes read, 2 seeks

[AVIOContext @ 000000002a0ff080] Statistics: 353047 bytes read, 2 seeks

[AVIOContext @ 000000002a0ff840] Statistics: 353047 bytes read, 2 seeks

[mov,mp4,m4a,3gp,3g2,mj2 @ 0000000029deffc0] Value 1.000000 for parameter ‘seekable’ out of range [-1 - 0]

[producer avformat] audio: total_streams 1 max_stream 1 total_channels 1 max_channels 1

[AVIOContext @ 0000000013affd80] Statistics: 277937 bytes read, 2 seeks

[AVIOContext @ 0000000013affb00] Statistics: 277937 bytes read, 2 seeks

[AVIOContext @ 0000000013aff1c0] Statistics: 277937 bytes read, 2 seeks

[mov,mp4,m4a,3gp,3g2,mj2 @ 0000000029df6340] Value 1.000000 for parameter ‘seekable’ out of range [-1 - 0]

[producer avformat] audio: total_streams 1 max_stream 1 total_channels 1 max_channels 1

[AVIOContext @ 00000000277ff080] Statistics: 277937 bytes read, 2 seeks

[AVIOContext @ 00000000277ff980] Statistics: 277937 bytes read, 2 seeks

[AVIOContext @ 00000000277ff440] Statistics: 277937 bytes read, 2 seeks

[mov,mp4,m4a,3gp,3g2,mj2 @ 00000000473c88c0] Value 1.000000 for parameter ‘seekable’ out of range [-1 - 0]

[producer avformat] audio: total_streams 1 max_stream 1 total_channels 1 max_channels 1

[AVIOContext @ 00000000196dd080] Statistics: 483909 bytes read, 2 seeks

[AVIOContext @ 00000000196ddd80] Statistics: 483909 bytes read, 2 seeks

[AVIOContext @ 00000000196dd1c0] Statistics: 483909 bytes read, 2 seeks

[mov,mp4,m4a,3gp,3g2,mj2 @ 0000000049ad98c0] Value 1.000000 for parameter ‘seekable’ out of range [-1 - 0]

[producer avformat] audio: total_streams 1 max_stream 1 total_channels 1 max_channels 1

[AVIOContext @ 000000002acff300] Statistics: 418867 bytes read, 2 seeks

[AVIOContext @ 000000002acff840] Statistics: 418867 bytes read, 2 seeks

[AVIOContext @ 000000002acff700] Statistics: 418867 bytes read, 2 seeks

[h264 @ 0000000067dfdb00] Reinit context to 3840x2160, pix_fmt: yuvj420p

[h264 @ 0000000067dfbb80] Reinit context to 3840x2160, pix_fmt: yuvj420p

[mov,mp4,m4a,3gp,3g2,mj2 @ 00000000694c5d00] Value 1.000000 for parameter ‘seekable’ out of range [-1 - 0]

[h264 @ 00000000693f5f80] Reinit context to 3840x2160, pix_fmt: yuvj420p

[producer avformat] audio: total_streams 1 max_stream 1 total_channels 2 max_channels 2

[AVIOContext @ 000000002a0ff840] Statistics: 1418140 bytes read, 4 seeks

[AVIOContext @ 000000002a0ff980] Statistics: 1418140 bytes read, 4 seeks

[AVIOContext @ 000000002a0ff1c0] Statistics: 1418140 bytes read, 4 seeks

[h264 @ 00000000693f1b00] Reinit context to 3840x2160, pix_fmt: yuvj420p

[h264 @ 00000000693f0000] Reinit context to 3840x2160, pix_fmt: yuvj420p

[mov,mp4,m4a,3gp,3g2,mj2 @ 00000000694d0280] Value 1.000000 for parameter ‘seekable’ out of range [-1 - 0]

[h264 @ 00000000694c8680] Reinit context to 3840x2160, pix_fmt: yuvj420p

[producer avformat] audio: total_streams 1 max_stream 1 total_channels 2 max_channels 2

[AVIOContext @ 000000002acf6440] Statistics: 1418140 bytes read, 4 seeks

[AVIOContext @ 000000002acf6080] Statistics: 1418140 bytes read, 4 seeks

[AVIOContext @ 000000002acf6ec0] Statistics: 1418140 bytes read, 4 seeks

[AVIOContext @ 00000000180ffac0] Statistics: 1807680 bytes read, 0 seeks

[AVIOContext @ 00000000180ff940] Statistics: 1807680 bytes read, 0 seeks

[AVIOContext @ 00000000180ff580] Statistics: 2005694 bytes read, 0 seeks

[AVIOContext @ 00000000180ff940] Statistics: 2005694 bytes read, 0 seeks

[AVIOContext @ 00000000180ffd40] Statistics: 2091898 bytes read, 0 seeks

[AVIOContext @ 00000000180fe700] Statistics: 2091898 bytes read, 0 seeks

[AVIOContext @ 00000000180fe440] Statistics: 1785093 bytes read, 0 seeks

[AVIOContext @ 00000000180ff180] Statistics: 1785093 bytes read, 0 seeks

Failed with exit code 3

is it possible that we have to much clips ? we have 538 clips.

If you can create a ZIP file with the project (clips + MLT file + any other files, such as Text:HTML filters) in it and post it here I could download it and see if I can get it to export it on my system.

I can try to do that if the zip is not to heavy. However these are personal videos and photos.
Is it possible to send directly in order to not dowload that on a public website ? or to lock the message ?

If you click on my “avatar” at the top of this post then you can send me a private message that will not be seen by anyone else. I’ll use yours to send you my e-mail address and you can use that if you feel happier doing it that way. Just click on your avatar it the top right of the forum to see it.

If the file is not too large you may be able to e-mail it. Otherwise you could try to put it on your dropbox/Google Drive/OneDrive or whatever and let me know where to pick it up from.

I promise I will not be studying the photos etc. I really just want to try a few experiments to see if I can sort out your problem.

I am triyng to send you the files but they are to heavy for one drive even when I zip them it represent 9 GO.
I will try to search another way to send you the files.

This has been resolved. It was probably a (lack of sufficient) memory problem.

The OP sent me his project - a very large number of files totaling over 10GB of space. I managed to get Shotcut to export it on my Windows 10 desktop that has an SSD, but only 8GB of memory. At several points it got very close to hitting the memory limit.

I started Shotcut and opened the MLT file and then ran the export. I did this immediately after a reboot and made sure that no other applications were running. It got very close (85%) to using the maximum amount of physical memory. At one time I had to minimise Shotcut itself to give the “qmellt.exe” process a bit more memory to play with.

Another thing to do (mentioned by me elsewhere) on tight memory issues is to encode outside Shotcut:

  1. in Shotcut, start an export job and stop it
  2. right-click the job and view XML
  3. save XML with .mlt or .xml extension (It now includes a <consumer> element that contains the export parameters including file name.)
  4. close Shotcut
  5. open a command line window
  6. run like /path/to/qmelt /path/to/xml from step 3 (how this is done exactly depends on OS)

I figured it out! It was the fact that I was overclocking my CPU!!! All I had to do was reduce my overclock settings. Thank you though.

Did you intend to reply to