Hebrew Translation

The problem is shown here (I’ve even uninstalled Shotcut then re-installed it ticking the box to "remove Shotcut parameters from the registry):

Shotcut version 18.09.16

|OS Name|Microsoft Windows 10 Pro|
|Version|10.0.17134 Build 17134|
|OS Manufacturer|Microsoft Corporation|
|System Model|Surface Pro 4|
|System Type|x64-based PC|
|System SKU|Surface_Pro_4|
|Processor|Intel(R) Core(TM) i5-6300U CPU @ 2.40GHz, 2496 Mhz, 2 Core(s), 4 Logical Processor(s)|
|BIOS Version/Date|Microsoft Corporation 108.1926.769, 06/12/2017|
|SMBIOS Version|3.1|
|Embedded Controller Version|255.255|
|Hardware Abstraction Layer|Version = "10.0.17134.285"|
|Installed Physical Memory (RAM)|4.00 GB|
|Total Physical Memory|3.93 GB|
|Available Physical Memory|695 MB|
|Total Virtual Memory|13.9 GB|
|Available Virtual Memory|5.05 GB|
|Page File Space|10.0 GB|

How can you claim the problem is not related to using a Surface Pro when you tested on a Surface Pro?!

I had also tested it on an Acer Revo RL80, with the same result (R to L script doesn’t work in the preview pane), but at the moment that system doesn’t have an internet connection so I couldn’t cut-and-paste the relevant screenshot and sysinfo into the reply.

Shotcut 18.10.01 Windows 10 Pro HP Prodesk PC.

I installed the Persian language pack (R to L script) and typed Persian into the text box. Also typed English into a second text box. Both display in the preview/source player pane and export perfectly well.

Persian.mlt (4.8 KB)

Persian.zip (15.7 KB)

I tested it as well using Hebrew and was unable to reproduce it. I did not copy and paste text from anywhere. I switched the Windows keyboard input mode to Hebrew and typed some with the keys. I even saved a project and reloaded it. Strange

Having read this I installed the Hebrew pack, but still no joy. The relevant part of the MLT file seems fine (see below) - as you would expect when it generates a correct video on export. I just can’t think what is different between your systems and mine to cause the preview pane problem!

  <producer id="producer0" title="Anonymous Submission" in="00:00:00.000" out="00:04:59.980">
    <property name="length">00:05:00:00</property>
    <property name="eof">pause</property>
    <property name="resource">#00000000</property>
    <property name="aspect_ratio">1</property>
    <property name="mlt_service">color</property>
    <property name="shotcut:caption">transparent</property>
    <property name="shotcut:detail">transparent</property>
    <property name="ignore_points">0</property>
    <property name="global_feed">1</property>
    <property name="xml">was here</property>
    <property name="seekable">1</property>
    <filter id="filter0" out="00:00:06.740">
      <property name="argument">A العَرَبِيَّة Arabic
U چھوٹی يے Urdu
K 片仮名 Kanji
H עִבְרִית Hebrew
A Հայոց գրեր Armenian
K 한글 Korean
T ཁམས་ Tibetan
C русский язык Cyrillic</property>
      <property name="geometry">0 0 1920 1080 1</property>
      <property name="family">Verdana</property>
      <property name="size">135</property>
      <property name="weight">500</property>
      <property name="style">normal</property>
      <property name="fgcolour">#ffffffff</property>
      <property name="bgcolour">#00000000</property>
      <property name="olcolour">#ff000000</property>
      <property name="pad">0</property>
      <property name="halign">center</property>
      <property name="valign">bottom</property>
      <property name="outline">0</property>
      <property name="mlt_service">dynamictext</property>
      <property name="shotcut:filter">dynamicText</property>
      <property name="shotcut:usePointSize">0</property>
      <property name="shotcut:animIn">00:00:00.000</property>
      <property name="shotcut:animOut">00:00:00.000</property>

Even weirder - I also downloaded your MLT into Shotcut on my system and although the MLT definitely contains the Persian text (I can see it in a text editor) it doesn’t show on the preview pane, NEITHER does it show in the input window of the Text filter!!

Did not install any fonts.
From the MLT provided by @sauron, just moved the text box to the left a bit.

This might be the issue:

On my computer, all of these fonts are installed via Windows 10.

  • Dengxian, Dengxian Bold
  • Estrangelo Edessa
  • Khmer UI, Khmer UI Bold
  • Lao UI, Lao UI Bold
  • Leelawadee, Leelawadee Bold
  • Lucida Sans Unicode
  • Microsoft MHei, Microsoft MHei Bold
  • Microsoft NeoGothic, Microsoft NeoGothic Bold
  • Microsoft Uighur
  • Segoe WP, Segoe WP Light, Segoe WP SemiLight, Segoe WP Semibold, Segoe WP Bold, Segoe WP Black
  • Segoe WP Emoji
  • Tahoma, Tahoma Bold
  • Urdu Typesetting, Urdu Typesetting Bold
  • Yu Gothic Bold

Per the listed article above:

Enabling optional font features without changing language settings:

If you don’t know the specific language, or if know the language of the text that is displaying incorrectly but don’t want to add that language into your user profile, you can install any optional font feature without enabling any additional languages.

From the Start menu, open Settings.
Select System.
Select Apps & features.
Select Manage optional features.
Select Add a feature.
Select any optional font feature from the list.

The Text filter defaults to Verdana on Windows. Maybe if that is not available, it falls back to something that is not working well. Did you try a different font?

I’ve tried Arial, “Aharoni” and “Noto Sans Hebrew”, each of which support Hebrew glyphs (Arial supports Arabic too), but the result is still the same.

Even the more obscure Armenian typeface works fine, while the more widely-used Arabic glyphs don’t, which is why I am convinced it is an RTL language issue.

Also, the weird thing is that even though the characters don’t show in the preview pane they show up fine in the exported video,

Thanks for the info. I have tried the procedures recommended on the webpage you kindly sent, but to no avail. One of the fonts that was loaded for Hebrew was Aharoni and I changed the font of the Text Filter to that, but it still just output spaces for Hebrew characters.

Here is my screenshot

EnglishHebrew2.zip (1.5 KB)

I’m in Israel if it’s matters
fonts.zip (746.3 KB)

I am in Israel as well.
I have been away for a week in the UK and did not have access.
I still believe after what Neil has shown that the problem must be with the Surface Pro4.
@asik1 what computer are you using?
Everyone else seems to be able to see the RTL writing and I used Aharoni font in my video.
Until this problem is truly resolved I guess I will continue to export to check how it looks as I did with the first video.
If anyone comes up with a solution/repair other than me getting a different computer, I will be much obliged.
Thank you

Monique, I’m using DIY desktop i5-6600, 8G ram on Asus H170 MB.

You could use a program like Gimp to make a transparent background text image then import it into Shotcut.

In GIMP 2.10.4, Transparent background, just added white for the screen capture. Exported to png.

Imported PNG into Shotcut 18.10.08

Monique, as I replied to Dan, I also have the problem when using Shotcut on an Acer RL80 Windows 10 system. So it’s not just the Surface Pro. I’ve tried re-installing Shotcut and doing various other experiments, but can’t make it work on either of these systems.

Elusien, something strange with your Hebrew, its with nikud . Do you have it natively when you type? I do not, I have to use extra code to get nikud on any software. Just a guess .

I don’t know Hebrew and do not have a Hebrew keyboard (physical or logical), I just thought this issue was interesting so tried various things out. I got the Hebrew text by cutting it from Wikipedia and pasting it into Shotcut.

The thing is, when I paste it it shows up correctly in the area I am typing, it shows up correctly in the MLT file, it shows up correctly in the exported video. The only place it does not show correctly is in the video preview pane, which is the same as Monique sees. Weird eh?

I went the extra yard and pulled out the only W10 I have , on the mini Z83 PC, it’s the minimum W10 I could tweaked with no updates. As my Shotcut is portable I paste it on a DOK.
And the results are here

By selecting Hebrew as the writing system the fonts list shrinks to just 14.
*It was annoying to have to re select that for every text filter added, it would be nice to be able to save a preset fo that .Z83-W10-HEB-TEST.mlt (5.6 KB)

I just fed your MLT into Shotcut and besides a JPEG not being available, none of the TEXT FILTERS showed any Hebrew in the Preview frame, only in the area where the text filter was displayed and on the final exported video. I am totally at a loss to explain this, as everything works fine for Left-To-Right scripts but not for Right-To-Left scripts, including Hebrew, Arabic and Urdu.