Float ui elements?

i was looking at how i might make shotcut work more comfortably with my multi-display environment and came across a forum question that implied that ui elements like the timeline could be floated or ‘pop-out’. the question was about how to reintegrate the floating timeline after it had been popped out but there was no mention of how the pop-out was achieved in the first place. i can’t seem to find any info on this anywhere but would very much like to try it as it would make my exploring much more comfortable. how do i float a ui element like the timeline or playlist or filters?

thanks,
babag

Click this.

image

OH! i actually tried that a bunch of times but the element didn’t move at all when i did so. because of that i never realized that it had become separated from the main ui! duh.

thanks!
babag

hmm. i floated most of the elements as a test and that went ok. the exception is the timeline. whenever i try to float the timeline shotcut simply crashes.

It works for me. This is due to an OpenGL compatibility issue on your system. See

You can also float and unfloat by double-clicking the title bar of the panel (anywhere left of the button @sauron showed you). I find this more convenient while the button is a little more obvious.

hmm, again. just tried switching to ‘software’ display mode and still get crashing on floating the timeline. tried via the button as well as double-clicking the title bar as suggested. crashed in both cases. running on kubuntu, btw. 18.04 lts

thanks,
babag

Sorry to hear that. I just tested Shotcut v19.10 (our build - portable, appimage, or snap - not flatpak or distro package) on Ubuntu 18.04 with GNOME Shell, and it works for me on AMD OpenGL or Software Mesa.
Update: just tested flatpak, and it works for me as well on AMD or Mesa. (The flatpak build uses Qt 5.12 whereas our builds use Qt 5.9.)

Shotcut 19.10 portable on Fedora 30 with KDE works as well. OpenGL and Mesa.

nvidia here. gtx 760. might that be the issue? blackmagic recommends nvidia, unfortunately. the really odd thing is that all of the other ui elements undock just fine.