Filters won't apply to clips

Which in turn makes it a ‘source viewer’ item. What I understood the OP to be assuming was that you can just select a playlist item and apply a filter to it without opening it into a viewer first.

Both @Steve_Ledger and @sauron are correct and wrong. :slight_smile:
Single-clicking a playlist item does not open it; you have to double-click to open it in Source player. You can add filters to whatever is in Source player (no matter where it came from - Explorer, Timeline, Playlist, File Open). However, to update the playlist item, you must update it. Unlike Timeline, Playlist does not auto-update.
Instead of updating the playlist item, you can alternatively, add it to the playlist again. You can have different sub-clips (trimming) and/or variations (filters) of a file in the Playlist.

Exactly, thanks for further clarifying my point with more detail.

So what I’m doing is taking a 1920x1080 picture, and uploading as a clip. I put about 10 seconds of the picture clip in the time line. I select the clip and add the filter. The filter opens, and I can play with all the setting, but the preview doesn’t show any change at all.
I’m running Shotcut 18.05.03 on Windows 8.1, if that matters.

Which filter (some needs videos clips) ?
GPU activated ?

No, GPU isn’t activated. I’m going for a Size and Positioning filter, but I’ve test multiple on different clips, and the clips that are still images are the only ones I’ve had this happen on.

I’m running Shotcut 18.05.03

This is a bad version that has been deleted from downloads and replaced with v18.05.08, but even that is considered unstable due to introduction of major new features.

The Timeline play head must be over the clip/image you are changing for it to show. Upon adding a clip or image to the timeline, the playhead is positioned to the frame after the end of the clip to facilitate certain editing workflows of adding additional content to timeline. If you double-click to select a timeline clip, then it seeks to the first frame of the clip.

I noticed too yesterday than on a still image, the videos effect like old films did not have any effect.
I have to dig into it again… Maybe that’s normal

All the old film filters applied to an image are working fine here.
W10 SC 18.05.08

Will try again maybe I had and issue refreshing the timeline…

Regarding the behaviour of filters, I recently came to realize that the filters execute in the order they appear in the filters window. For example, if a Fade Out video filter appears first and then a Text filter, the Text will not fade out but the clip will fade out. Moving the Fade Out filter to appear last will fade out the Text.

Since this topic was about filters, I wanted to share my lesson learned.

How are you applying those filters to your clip? Screenshot please.

Here are the 2 scenarios I described. In the first scenario, the text doesn’t fade. In the second scenario, the text fades with the clip.



Thanks, sorry I wasn’t clearer. How you are applying them to the clip in the timeline.

Reason I ask is that generally text is best applied in a separate track.

Sorry about that, Steve. Both filters are applied to the V1 Video track.

From this forum, I am learning that the preferred approach is to add text to an opaque clip in a different V track. As I am using ShotCut more, I can see the benefit because it doesn’t require Splitting the clip to add text to a short duration of content (caveat is that the text in V2 will not move with the video in V1 if clips in V1 are added/deleted/lengthened/shortened…or is there a way to tie them together?). My current project has lots of splits (for text) and I can now see it would be easier to manage the text on separate tracks…learning is one of great benefits of this forum.

My excuse for my current project is that I was well into it before I learned about adding the opaque clip to another track. For future projects, I will try managing multiple Video tracks for Text.

I think my lesson learned still stands, that the filters execute in the order they appear; perhaps a developer could confirm. For example, if I added text to an opaque clip in another track (V2) and want the text in V2 to fade with the video in V1, I am extrapolating that the order in which I apply the Fade and Text filters to the clip in V2 will likely affect how the filters will function (Text before Fade vs. Fade before Text).

So I’m still having the exact same problem, even with 18.05.08
Here’s a screenshot to verify I’m not just being dumb. You’ll see the Background.png clip selected, and the filters tab is on Background.png with a Size and Position filter. I have the size/position window moved and resized, but the clip itself isn’t in the window. And yes, I tried all three size modes, and all of the vertical/horizontal fits. I’ve tried it with other clips from png files. All the same. The filter won’t apply to the clip. And I have normal video clips (not from png files) and filters work just fine on them. Any other ideas?

Sounds silly, and it’s a proven bug, click or double click on the check mark for the filter. I just duplicated what you have here also with 18.05.08, but I had to double click the check mark a few times to get it to do this.

Here is a link to a post explaining how it happens:

Sometimes removing then reapplying the filter will make it work.

Splitting to confine filters to certain regions of time is no longer required as of v18.05, which includes filter trimming! (but beware of the bugs in v18.05, next version is really shaping up from all the feedback)

yes, of course they do. How else should or could they be applied? :slight_smile: Also, you can drag-n-drop the filter rows in the list of filters to reorder them.

That bug was fixed. @lastx013 might be facing a different bug. See the first bug and my reply here:

The bug applies when you are working with any filter that has simple keyframes and you adjust the parameters when the play head is not between the first and last frames (i.e. somewhere in the middle as I mentioned above). If you do not think this is the same bug, then please provide steps.

Thanks Dan (@shotcut) , for confirming how the filters are applied. My intention was just to share what I discovered since I didn’t think the order-dependence of the filters was explicitly documented. I think the current design of how the filters are applied is fine; I wasn’t challenging the design, I just didn’t know they were order-dependent until I discovered it myself.

I have been reading about the bugs in the new versions, so I am staying with 18.03.06 for now.

I have a lot more reading/watching to do to fully understand how to properly use the new features. I watched part of the latest Shotcut video, but found it confusing so I have to watch it again later.

I look forward to learning how to properly use the new features.