FIlters (Text, crop:rectangle) disappeared


I already had some minor bugs with shotcut but i always found the solution on this forum or on the internet … but not this time.

I am using Shotcut 21.04.13 on windows 10.

Description of the bug :
Everything was working. I made an export (as usual) of a project i was working on. I opened the video and some text were missing and some clips were not croped (i am not sure of this word “crop” in english sorry).

So i checked my project on Shotcut and found that some filters disappeared from some clips. On one clip there were 2 text filters that disappeared. On another clip there was a crop:rectangle filter that disappeard.

capture showing were the filters disappeared from

Also : A picture (format : png) is not read anymore : the image is blank instead of showing the image.

To be sure : i tried to open an old project that have the same clips (the ones with text and the one with an image) :and the filters also disappeared from that clip also !

What i did :
I found 2 posts to help me :

The say that gpu rendering might be on. But i checked the regedit (thanks to another post) and under “player” gpu is set to false.
And i never activate gpu rendering myself, i didn’t know it was possible to do the render from the gpu

I also tried to uninstall/reinstall 2 times (the second time i also deleted the shotcut directory under %localAppData%\Local\Meltytech) and nothing changed

There was also a post saying to look for “movit” in the mlt file to delete those lines, but there is no “movit” line in my mlt.

Conclusion :
Right now i thing it is related to the gpu, but the gpu key in regedit is set to false… so i am lost.

Thanks for any help !

Are there any error messages shown in the log file? view=>Application Log

Can you reproduce this with a new project, and provide detailed minimal steps for someone else to duplicate?

You say “2 text filters” but don’t indicate if they were on a color clip (as shown in your screenshot).

Many here are willing to help solve the issue, but with such minimal information just not much go on to duplicate the bug you are experiencing.

Was the entire project all done with version 21.04.13? Or did you start the project from a prior version?

This is a known problem with that BETA version that was fixed and updated the next day on the beta download page. The updated version is 21.04.14. Also you should report problems with beta in the beta thread

Thanks for the Help Elusien.

There are indeed 4 errors (i lounked for the word “error” in the mlt file):

[Info ] plugin_mgr_get_object_file_plugins: error opening shared object file ‘C:\Program Files\Shotcut\lib\ladspa/AUTHORS’: “C:\Program Files\Shotcut\lib\ladspa\AUTHORS”: Le module sp?cifi? est introuvable.

[Info ] plugin_mgr_get_object_file_plugins: error opening shared object file ‘C:\Program Files\Shotcut\lib\ladspa/COPYING’: “C:\Program Files\Shotcut\lib\ladspa\COPYING”: Le module sp?cifi? est introuvable.

[Info ] plugin_mgr_get_object_file_plugins: error opening shared object file ‘C:\Program Files\Shotcut\lib\ladspa/readme.txt’: “C:\Program Files\Shotcut\lib\ladspa\readme.txt”:

[Debug ] LeapNetworkListener::onError Leap Motion WebSocket error: “Connection refused”

I will try the solution from by shotcut (4th post) and come back if i still experience problem.


Thanks Hudson for the help.

The text filters were indeed on a color clip.

I will try the solution provided by shotcut and comeback if i still experience problem.

Thank you for the help Shotcut,

I didn’t know it was a beta version because shotcut is provided by my company (So i used a software center to install/reinstall it).
I don’t know why they put a beta version on the software center.

I just have a few questions left :

  1. in the download page the current version is 21.03.21. This version (and others version on this page in the futur) are not beta version, am i correct ?

  2. is there any way to know directly in the software that the version we have is a beta version ? I ask that to put my question in the right post the next time if needed.

I think it would be great to have it somewhere on the about page (“21.04.13beta” instead of “21.04.13” for instance ?) :

  1. from where can we download beta versions ? I searched on the shotcut website but didn’t find it. Is it in the forum only ? (i found a post that link to github for another version : V20.02 BETA is now available to test). So this is my hypothesis : when you have a beta version : you make a forum post that link to github. is it correct ?


The errors you listed are “normal” and are not an issue. Let us know if the other actions work or not.

Yes i will tell you, i am on it

Some news :

My it department put the 21.03.21 version. So i was able to install it (instead of 21.04.13).
They told me the beta was installed because the versionning doesn’t mention that it is beta. honnestly i don’t know what that means nor if it is relevant to you.

Good news :
Filters are working again if i do a new project on shotcut. I can now use text:simple and crop:rectangle again.

"bad news" :
when i tried to open my project (let’s call it save13.mlt, that was saved with 21.04.13), shotcut told me it had to repair it :

I click yes. The project opens. But the filters are still missing :

This mlt was saved with 21.04.13 (before i noticed the bugs) but it was originaly created with an older version version than 21.04.13. And i do multiple save of my mlt files. So i can come back to an older version of my mlt file (let’s call it save7.mlt, it was saved with 21.02.27 according to the mlt file) and there i have the filters :

Question :
From the save7 (that has the filters i made) to the save13 (that doesn’t have the filters) i have worked on the project. So if i start again from save7 i will have lot’s of work to do again. And if i start from save13 i will also have work to do to correct the missing filters (right now i don’t know which method will be shorter).

Is there any “not to complicated way” to import the work done on save13 in save7 ? or do the opposite : import correct filters from save7 in save13 ?
Perhaps by copying part of the mlt file ?

I hope you understand this question, i am not sure if it is clear.


The simplest method is to click on each filter, and save it as a preset. The presets can be backed up as well. Read this to learn the locations of each filter’s preset location: Preset Locations: Filters


Thank you Hudson555x, this method really helps me to correct the save13 with the presets from the save7.

And thank you again to all the people that helped me.

The download page for this beta clearly says so

In the case they are receiving a notification from GitHub about a new release, this release is categorized as “Pre-release”

The beta thread I already mentioned clearly explains the project compatibility issue.

The download page for this beta clearly says so

In the case they are receiving a notification from GitHub about a new release, this release is categorized as “Pre-release”

I don’t know how they proceed. They just said it was automatic. But i am just the messenger here, I can’t even be sure to report here correctly what they told me…Maybe i misunderstood what they said, maybe it is their way of getting the versions, maybe…

The beta thread I already mentioned clearly explains the project compatibility issue.

I looked in this thread before asking my question and didn’t find someting to helped me. I saw the project compatibility issue but not the way of “solving” it like hudson said. So i missed the info, sorry.

Thanks again for your help.

As version for M1 ARM64 on MacOS is there, anybody trying to port to Windows 10 ARM64 (Sueface Pro X, Gallaxy etc.)?