Filters glitch and stop having an effect


#1


the kind of videos I am doing right now require heavy use of frame by frame moving around of images using either rotate of size and position filters. Both of these filters eventually stop working at random as seen in the image provided (the image “delete” is meant to be in the select box thing) I have exported a video with this problem and it still shows with the exported video.
Help please, this started showing up since the latest update and I dlcannot afford the data to download the old version, which had it’s own problems as well.


#2

FYI: You can have multiple versions of Shotcut installed, no need to remove previous version when updating. Always good to keep the last stable version you were happy with when trying the latest and embarking on an important editing session…


#3

I will remember that for next time, thanks.


#4

I do not know how to reproduce this problem.

You can learn to use what works for you in Shotcut and avoid what does not. It seems you may be asking it to do more than it can handle.


#5

I have had my shotcut handle things way more powerful than this before.
To reproduce this get a video on one layer, and on the second video layer have an image with a size an position filter. Cut that image file into frame by frame sizes and change that size and position each frame.
It should glitch, doing the same if you use rotate instead of size and position as well.


#6

Took me a while to figure what the OP was talking about. Looking at the sole screenshot, it sort of looked like the wrong clip was selected for the filter. A full screenshot would have been a lot more helpful.

Looks like after the 1st filter, the size filter does not respond.

I was able to duplicate the issue, or make my own issue.
I just used Size & Position filter. 18.06.02
https://youtu.be/Y0zIxeC8O1U
size position filter.mlt (14.0 KB)


#7

But an image has no ‘frames’. It’s a still shot which can’t be cut into multiple frames.
Why not just copy and paste the image as many times as you need then use the S&P filter as you go? (Saving after each step)


#8

Yeah sorry for the terrible screenshot, I do not trust my computer to not use all my phones data do I wrote the problem on my phone and took a picture using my phone.
So at least I now know I am not just going insane with the issue, it and be reproduced.


#9

Thank you @Steve_Ledger. As you know I’m a noob too. :slight_smile: I was just attempting to figure out what the OP was trying to explain.

I did exactly as you stated, but I predefined each still image to be 2 seconds, then put the image into the V2 track one by one, applied the filter, and it worked, for me.
size position filter2.mlt (8.0 KB) 18.06.02

@loomhigh Here is an alternative that should help you. Made a short clip of the picture.

  • New Project
  • Open File, your PNG or JPG, etc… picture
  • Drag picture to timeline, adjust the length of desired clip in timeline. (I did 20 seconds)
  • Export Profile preset: H.264 High Profile, Video Tab: 60 fps
  • Codec Tab: Quality 100%
  • Export to desired file name

Now make all of the cuts you desire and apply filters as you wish. This worked fine for me. The preview playback is a bit choppy for me, but the export is fine as you can see here.
https://youtu.be/czXS23zLa7w
size position filter3.mlt (27.2 KB) 18.06.02

Note: Wile the preview is a bit choppy for me, this issue has been discussed and resolved many times in this forum, I just choose not to make the changes outlined for smooth preview.


#10

Ahh interesting solution, I will give it a go next time to see if it works.


#11

Okay I tried it but I am coming across another glitch that was on the previous version where applying certain filters to all the cuts causes shotcut to simply crash. For example I used chroma key simple for my images (now in video form) and do the regular cutting and position adjustment, but if I play it back shotcut simply closes itself.


#12

At least for me, it’s really difficult to follow what you’re talking about. If you’re having a crash issue, it’s best to explain in full detail what specific filter, adjustments within the filter, Shotcut version number you are having issues with. Full screen shots, saved mlt file (Just drag and drop into this window) are also extremely helpful. You can apply filters to clips, entire tracks, and to the master. I have no idea where you placed any filters, nor in which version you placed filters.

So here is a checklist of information that will help others and devs find a solution.
Shotcut version number, and was it downloaded from https://shotcut.org/download/ ?
Computer specifications, including Operating System.
Running Anti-Virus/Malware software? Yes/No
Running Shotcut as Administrator? Yes/No (unless you specifically set it to run as admin, it’s no)
Shotcut settings: GPU Effects On/Off? Display method, Video Mode
DirectX version: https://support.microsoft.com/en-us/help/15061/windows-which-version-directx
Source file types. Export file format desired.


#13

okay, these are my computers stats
Interl® Core™ i7-6500U CPU @ 2.5GHz 2.59GHz
RAM: 8GB
system type: 64-bit operating system, x64-based processor.
computer%20stats

I have downloaded and installed both version 18.06.02 and 18.05.08. GPU effects are on and I am admin of my computer, I have no antivirus software. If I followed your instructions correctly my DirectX version is 12.

Version 18.06.02 has the issue with the size and position filter that you reproduced successfully, but version 18.05.08 does not, so we can pretend for now that that issue doesn’t exist.
Both Versions 18.05.08 and 18.06.02 have the issue of crashing whenever there are filters on multiple selections (IDK what they are technically called but I hope you know what I mean)

in this instance I was using the “rotate” filter but I also remember this happening with some other filters too.

I have provided some specific files to help provide more information than I can with my, shotty, description.

the edit file and the log of the file being processed (the end shows the error “Failed with exit code -1073741819”)
log and edit file.zip (9.0 KB)

here is a short video showing what happens when you try to playback the filtered part in shotcut (it crashed just as it reached the part of the video where the rotate filter is present) you should also be able to see a little bit of information on the video mode.
problem.zip (1.0 MB)

I hope I provided enough information here. This has happened every time a tried to do this project and similar projects. I have changed image formats and restarted it new in case it was a problem with the edit file itself. I have tried it with GPU setting off but that just makes things slower and changes not much else.


#14

krieg - Repaired.mlt (205.8 KB)
From your “log and edit file.zip” file.
C:\Users\loomhigh223555\Pictures\Camera Roll/I AM ded.png
C:\Users\loomhigh223555\Pictures\Camera Roll/eyes.png
C:\Users\loomhigh223555\Pictures\Camera Roll/dash blanket.png
C:\Users\loomhigh223555\Pictures\Camera Roll/eye.png
C:\Users\loomhigh223555\Pictures\Camera Roll/hair.png
C:\Users\loomhigh223555\Pictures\Camera Roll/Jat back harm tatt.png
C:\Users\loomhigh223555\Pictures\Camera Roll/jat tatt waist.png
C:\Users\loomhigh223555\Pictures\Camera Roll/black
C:/Users/loomhigh223555/Downloads/Borderlands 2 - Krieg_ A Meat Bicycle Built for Two.mp4

Mixtures of Backslash\ and Slash/ in file address’s.
Not quite sure how this happened.
Since only the borderlands video showed, and nothing else,
I would bet it’s the improper use of the Backslash \ .
I’m not sure how Shotcut would handle this.

All of my mlt files contain just the Slash /.


#15

Weird. Any way this can be solved?


#16

I noticed the mlt file says “Repaired”. Did you add the Repaired to the file name?
I’m suspecting you moved files from one directory/drive to another, and you got the repair window to ask you where the files are at.


#17

The repaired was added by the application, but that’s not the reason it’s acting up, I have tried it multiple times with new mlt files and besides, the problem began before it added repaired. I actually think it added repaired after it it crashed from one of the attempts at adding filters.


#18

It does not matter.


#19

You know what does matter? Kinda bummed about the project.


#20

If you’re using Windows 8 or 10 then you have AV by default (Windows Defender).
I can’t see any mention of you trying the project with GPU Effects turned off? Remember, they are ‘Experimental’ and there are no guarantees given or implied with free software.
Sure it sucks when you commit and spend time, but that’s just how it is sometimes. You learn what works for you and discard what doesn’t.