Filters Choppy Video

Hi, I have a quick question. After I apply a filter, like contrast for example, my video becomes very choppy and the audio becomes choppy as well. Anyone know what’s going on here? Thanks in advance

Okay I think my video play speed has slowed down after I did the filters so I think that’s why it seems choppy. Why would it do that? I exported the video and it plays fine

You need a more powerful computer if you want real-time playback when filters are applied.
You could also try transcoding to ProRes for editing.

Also, check out this post from sismeiro
How to "proxy" edit with Shotcut

Thanks. My laptop has 4gb of ram and 2.16 ghz quad core processor you don’t think that’s enough? Also, My laptop is almost new.

Yes, well even entry level laptops can be purchased new. New doesn’t mean powerful unfortunately.
4 cores are common to many CPU families from entry level to higher end. Both Intel and AMD make 4-core CPUs for laptops.
You also really need a good GPU, the more powerful the better.
At least 8 GB of RAM is needed for HD (1080p) though adding transitions, color grading and other filters will mean choppy playback from the timeline.

I have a 6 core CPU with 16Gb of RAM and a dedicated GPU with 2Gb of DDR5 VRAM, Shotcut gets choppy even on my system when filters are applied.

You can uncheck the applied filters for playback, then recheck them for export.

Okay makes sense. Thanks

Why does my windows movie Maker runs fine and shortcut don’t?

Is WMM the same as Shotcut?

No, but why? What’s the difference?

Similar to the difference between Windows Paint Brush and GIMP.

I can even run those programs without problems I don’t know if my last windows update mess up my computer

Does your computer satisfy ShotCut’s min requirements?

1 Like

I got an i7 980x, 6 cores, 3.33 ghz
a gtx 1060 fual 3gb
24gbs of ram
and windows 10
the video gets to about 3-5 fps when i add any video filter

It depends on the filter and resolution. The addition of a feature called “proxies” later in 2019 will help. In the meantime, if you turn OFF Settings > Realtime then it turns on frame-based multi-threaded rendering, which improves the performance of video effects. However, with that off, it does not do any video frame-dropping to try to keep the audio continuous. You may experience a slow playback with choppy audio. You can try it out yourself and decide which mode you like better.

This topic was automatically closed after 90 days. New replies are no longer allowed.