Filter setting and clips all over the place

Hi all. Im using Shotcut ver 21.06.29 (Win10). For the last 2 days i kept on redoing my edits. My filter setting for no reason set to max (eg in White Balance) and my clips including audio kind of shifted to right for min 20 second and some shifted for almost a minute. I have this habit saving the file every 2-3 minutes but when i close Shotcut and open my file, the whole thing not in order.
At first maybe my pc ran out of memory but that’s not the problem (even turned off my anti virus and background running apps). Please advise thank you.

It’s unstable release, try to use 21.03.21 for your work. I think that might solve the problem.

can that ver import the file?

Perhaps No, I think you might make 2 backups of that project and then try to import the first backup in version 21.03.21, if it works, then totally fine. If it didn’t, you need to edit the video again.

Thank you for the answer. As your suggestion to load 21.03.21, i’m facing the same problem from 21.06.29 which is a keyframe was in the clip. I never add any keyframe in most of the clip. I’ve have remove all traces of previous Shotcut including the registry. I even “Run as admin” before installing Shotcut. It’s odd to see keyframes in the clips.

This is filter trimming, and hit happens in the keyframes window, even if the filter has no keyframe capabilities.

I tried to reproduce your issue, so far I have not been successful.

What is your Video Mode? (Click on Output, then Properties)
What is your video clip properties? (Click on the clip, then Properties)
What settings for white balance are you trying to use?

Hi there Hudson555x.
Sorry for the wrong term. Yes you’re right it’s filter trimming. The odd thing is why does it effects my white balance and i didn’t set the green slider.The rest of the clips doen’t have that filter trimming in the keyframes.
Video mode is set on 720p 23.98fps.
White balance just a minimal adjustment.

The second image is next to the clip posted. As you can see, the green slider is all the way to the left.

Have you opened the audio tab which is left to the metadata tab to check out what is the setting there set to, maybe you have set the wrong sync settings?
(because,You were also asking that your audio is shifted 20 secs for 1 min)

It appears to be an issue with mixed frame rates.
Not sure what you recorded the video with, but if it’s from a cell phone, it’s highly possible it’s recorded with a variable frame rate. Shotcut doesn’t always detect it.

Media Info will detect if your source clips (not the proxy clips) are variable frame rate.

Shotcut does offer a Covert to Edit-friendly to help with frame rate issues.

Is this what you mean?

Yes, if the audio is starts late than move the sync slider to the left until it gets correct, or vice versa if it starts earlier.

Clips after the clip posted is the same frame rates and surprisingly those clips also contain the shifted green slider. I do recorded the clips at the same frame rate in the setting of the camera app.

Do i need to click convert for every clips or there’s a batch process?

Even though my android phone tells me I’m recording with 30fps, it lies to me.
And Shotcut does detect this file as something I may need to convert over to Edit Friendly.

I do not believe there is a batch process. I just tried it, and it doesn’t give me a batch option to convert. You want to have all of the same FPS for your project and the video clips. Odd frame rates may throw off video/audio sync, and cause weird filter issues. Mis-matched project video mode FPS to video clips FPS may also cause issues with video/audio sync and filters.

When I tested the white balance filter, I was using a 60fps clip with a 60fps video mode.

Make sense. Thank you for your time @Hudson555x and @Ar_D. Looks like i have to edit the whole thing again.
One more thing @Hudson555x , what setting should i use in the Edit-friendly? Correct me if i’m wrong, i should set the Edit-friendly first then set the video mode?

1 Like

You need to test out the options for yourself to see what works best for you.
Start out with the middle option.

I did just that, and it converts it to a solid 30.00000 FPS, which is excellent for video editing.

But when I did choose the middle option, it does give a bigger file size.
Went from a 5mb file to a 64mb in file size.

Once you have all all converted to 30fps, then set your video mode to a 30FPS one. There are many to pick from. Settings → Video Mode.

Thank you, will do that.

Sorry to bother you. Just a quick question, why does the playhead not at the very end of the clip? I’m using ver 21.03.21.

Either the Video Mode has an odd FPS such as your screenshot 24.252223 instead of 24.00000, or your clip has the same type of FPS. Such as 24.252223 frames = 1 second. If it doesn’t reach the next iteration, it will stop short of the next frame to the video mode.

It’s best to have the Video Mode and all clips with the same FPS.

yes, you’re right about the frame rate. How can i edit the frame rate? i used the method you gave, but it came out with different frame rate.