Faster, better? computer, but Shotcut interface more laggy

Briefly: a new computer that should be faster instead has a laggy, unusable Shotcut interface. How best to troubleshoot?

Our Shotcut editing had outgrown our oldish laptops, so I bought an Intel NUC8i7BEH running Windows 10 Pro about a month ago. (Specs below)

We mostly ran on the NUC via TeamViewer or RDP, and it was great. No more crashes, more responsive interface, and exports that were 4x or so faster than on the laptop.

Hoping for even better price/performance, I put together a Ryzen 5 3600 computer from all new parts - see list below, running Windows 10 Pro (unactivated) and Shotcut 20.04.12.

Exports seem to run about as fast as they did on the NUC.

But the interface is close to unusable. We’re getting much more laggy, high latency behavior, either running right off the computer or via TeamViewer. The blue cursor loading is our new companion. For instance, when making the tracks shorter, or when resizing the preview window, at least 50% of the time.

I’d be grateful for tips to figure out whether:

  1. the new computer is just underspecced
  2. there’s an underlying hardware/software problem
  3. Shotcut settings and prefs don’t match the underlying hardware/software


OLD (worked wonderfully):

Intel Quad-Core i7-8559U
16GB DDR4,
256GB SSD, WiFi, Bluetooth, Thunderbolt 3, 4k Support, Dual Monitor Capable, Windows 10 Pro (16GB Ram + 256GB SSD)

NEW (laggy):

CPU: AMD Ryzen 5 3600 3.6 GHz 6-Core Processor
Motherboard: Asus ROG Crosshair VII Hero ATX AM4 Motherboard
Memory: Team T-FORCE VULCAN Z 16 GB (2 x 8 GB) DDR4-3000 CL16 Memory
Storage: Kingston A400 480 GB 2.5" Solid State Drive
Video Card: ASRock Radeon RX 570 4 GB Phantom Gaming D Video Card

Try the different options in Display Method.

Thanks for the quick response.

I switched Display Method to OpenGL and restarted, reloaded the mlt file and resized tracks. Still get the loading cirlcle, and “Shotcut not responding”

Switched Display Method to DirectX, and it was slightly worse, the including the “gray overlay” over the whole screen.

This topic was automatically closed after 90 days. New replies are no longer allowed.