"Failed to open."


#1

I’ve been loving this Program Since I downloaded it and it was working great i put 16 hours and a lot of effort
into my project but… one morning I wanted to work on it and when I tried opening the file and it says failed to open i’m am very upset about this and I really need some help it seems one other person has the same exact problem as me but no one has helped him/her either and that really bugs me now can you please please please help me I really want some good software and i know that’s what your here for and to help your customers. reply ASAP


#2

Failed to open what? The .mlt project file or one of your source videos?

Free and Open Source software doesn’t have customers, only users :wink:


#3

I got the same failue message. And i cannot use Shotcut anymore, i.e. I cannot start it, being newly intalled without any project.
I think it is caused by the before done update to the most recent macOS. Any idea?


#4

I checked the details of the exception Shotcut runs in on macOS 10.12.4. It is “Illegal instruction: 4”.
I think, Shotcut may need to be just re-compiled considering the changes in recent macOS.
Looking forward…


#5

My “failed to open” issue is gone, Thank You meltytech team!


#6

I have the same problem. Its so annoying. I havent updated my shotcut and it still says failed to open. File is still not empty, 144KB size. I got a “Lost files, do you want to recover them?” or smtn like that and i answered yes. Tried to reinstall and still it wont work


#7

Either the mlt file got moved, or moved the source files away from the mlt file.

Open the saved mlt file and look for the following examples in the lines of code.
Best to open the file with Notepad++

Line21: <property name="resource">2018 sdv test 1.mp4</property>
Line45: <property name="resource">Logos/Logo Screen EP 41.png</property>

Or just drag the file in here, like this. test57.mlt (4.4 KB)


#8

I got this failed to open message as well. Can you please explain how to solve this? I would like to recover the file if possible.
image


#9

@scrapmetalmade unfortunately that user never reported how the issue was solved.

What version of Shotcut are you using?
Which operating system?


#10

Windows 10, latest version of shotcut.
image
image

I was able to open the mlt file with notepad++. I made a copy and changed a few of the resource files to just the file name rather than the path.
From this:
image
To this:
image
When I did this shotcut prompted me to find the files. I directed shotcut to the files successfully (green check marks) but then I got the same failed to open error message.


#11

To clarify I did not change every source file, just a few. I can try changing every source file later if someone thinks that would help. There are a lot of files though so this will take some time.


#12

Ok so I found this is my application log:
image
Here are those rows:
image
image


#13

Solved!

First I tried changing the source file path associated with the error rows. This did not work so I just deleted the whole section of code associated with the error rows. See highlighted rows below.


I may have lost some info, I haven’t dug through all of the mlt file yet but it looks mostly complete. I hope this helps someone. I am very happy that I saved myself probably another 6 hrs.


"Failed to open (project name).mlt"
#14

I wouldn’t want anyone to think that this is some slight error that only needed manual tinkering like you did because now I am convinced that this is a bug that was introduced recently to Shotcut. Not only did you come in to report this but another person started a thread like yesterday about the same thing and this is after me getting the “Failed to Open” message in Shotcut 3 times ever since I downloaded the newest version (18.08.11). That has never happened to me before and the fact that it has happened 3 times in just a few days of downloading this version makes me convinced that it is a new bug.

This bug worries me because somehow Shotcut is corrupting mlt files and not letting you open them again which means you can’t work on a project. The first two times that it happened it was on minor things so it wasn’t a big deal but the 3rd time it was on a long project that I have been working on for some time. It did this but luckily (since I don’t ever really do this) I had saved an earlier mlt file of the project. Had I not had that accidental older mlt I made, about a month’s work would’ve been gone. I still had to redo the things I was doing that was saved on the newer mlt file though.

I was thinking about making a bug report on it but the thing is I honestly have no idea what causes this bug to corrupt mlt files. It has happened 3 times to me in a short time on three different projects so I have no idea but the fact that this is happening with several people on this forum since the release of 18.08.11 means there is something going on. I just don’t know how to go about honing in on what’s triggering it. I do remember on the long project that Shotcut was getting buggy with me moving around some clips that I created a transition for (one of the clips just disappeared for no reason) and I closed Shotcut and when I went to reopen it it just said “Failed To Open” and wouldn’t start the project again.

I hope this can be investigated and fixed for the September release.


#15

Good find! I have seen a problem like this years ago with metadata embedded in the media files, and there was a fix for it. In this case, this is bad text data is coming from the text box in the Properties panel of Shotcut. I will have to add some filtering there now to prevent this problem. Instead of deleting the whole <producer>...</producer> block, you could have simply deleted the lines with the offending characters. Thank you for finding it and reporting it.

Hmm, that worries me. Did you view the log or open these .mlt files to look for a similar problem? I will review all the changes from 18.08.01 to 18.08.11 to see if there is a possible reason, but it will be easier to find steps to reproduce.


My save is gone
#16

I found the the bug and am preparing another version (18.08.14) to release to fix it since it is a major regression.


#17

Hi Grobi,
I think I’m having the same issue as you- Shotcut keeps displaying the phrase ‘failed to open…’ (with my file name) and I’ve tried deleting and re-installing the programme. I’m aware there is another update available which may or may not fix the problem but I can’t download the update off of the Fosshub website. Please could you tell me how you resolved the issue or any advice really- the project’s quite important as it’s part of exam coursework.
Thanks
Lola


#18

Hi,
I’m aware it’s been a while since this conversation has been active and there have been several updates since but I’ve been getting the same ‘failed to open…(file name)’ as others. I’ve tried deleting and re-installing the programme but am unable to download the latest version (19.01.27). I’m not sure if I’m just clicking on it wrong but I’d really appreciate advice on how I might recover my file (if possible!)
Thanks
Lola


#19

I’m having the same issue. A .mlt file I saved using version 18.12 won’t open now. I get the same “Failed to open…” message. I just downloaded version 19.01 and it will not open the file either. Very frustrating. Hours of work lost if I can’t open this file!


#20

I can’t even open the file in TextEdit (mac version of Notepad++). Going to look for something to throw or punch…:rage: