My save is gone


#1

I’ve been editing for about 5 hours today and I inserted a video file into shotcut and when I dragged it into the timeline the video wouldn’t show. This has happened before so I just restarted shotcut but accidentally pressed save on exiting and now when I open my mlt file nothing shows up. Is there any way to recover my previous save :sob:


#2

Also I tried to use previous restore but nothing shows up :confused:


#3

It might be a good time to start saving to more than one file for a project. You have your main.mlt file then mainv1.mlt as your backup save file.


#4

When you try to open that mlt file does Shotcut say that it failed to open the file? It should say it right next to the “Source” and “Project” tabs right under the video screen. It’s at the same place where it will ask you to check if you have the latest version of Shotcut.


#5

Oh yeah it says that. What could be causing this?


#6

I forget to also ask, what version of Shotcut are you using?


#7

I’m using version 18.08.11


#8

Please upload your .mlt file here.


#9

win.mlt (84.6 KB)


#10

From the Application Log, same as this other issue.

[Error ] [producer_xml] parse fatal: PCDATA invalid Char value 3 row: 732 col: 43

I deleted that line, and now it loads. Here you go.
win.mlt (84.6 KB)


#11

thanks this will save me a lot of time XD


#12

I have confirmed that this is a critical bug in v18.08.11, found it, and working on a fix. There will have to be yet another version tomorrow and 18.08.11 removed. The problem appears when you select a clip that has a speed adjustment and whose Properties > Comments field is blank. Comments is getting populated with garbage characters.


#13

Is it at all related to this?


#14

No, it is related to a change to indicate the project is modified when you enter a comment in Properties. :frowning: