Fade filters aren't applied to the output file


This is the first time I ever used Shotcut, so I may be doing something wrong, but I can’t make the fade filters work. I am working on a Windows 10 64 bits laptop. I selected a part of a .ts file, added the 4 fade filters, left the default durations (1 second), I even checked in the preview with alt+right and alt+left that I saw the fades, but when I exported, the result had no filters applied. I tried mpeg-4-ASP and H.264 Main Profile with the same result. Am I doing something wrong or is this a bug?

I noticed somewhere that Shotcut used xml to store the project data. So on a hunch I saved the mlt and looked inside. I recognized my source name as well as the filters. All I saw which could have been a problem was that the path included accented characters and that the file name included spaces. So I moved the source to somewhere else, removed the spaces from the name and tried again. Nice try, but same results.

Did you by any chance had an input video with 190 fps, but exported 24 fps? I once did a try like this and the export created and lost that many frames that it looked like I hadn’t added any effects, when exported 190 fps as the source videos were then everything was as modified in timeline.
Of course you could have a real problem/bug.

@veiksa thanks for your answer.
Source: 25 fps
Output (that’s in the "Export tab, right?): 25,000 fps.

I now see I didn’t say what I was trying to do: extract from a .ts video a sequence with video and audio fade in and fade out.

I notice something else: I can’t set the limits precisely at the points I want. Or rather, I can set them, but the results don’t change unless I move them by at least a few seconds. As if there were discrete set points (key frames?) where export could start and end. Could the .ts format be the source of my problem. Maybe I should first convert my .ts to a more easily editable format?

I also notice I didn’t say which version of Shotcut I was using: 16.09.01

I found a workaround: open the source .ts, select the part to export, export as mp4, close the source, open the generated mp4, add the fade filters, export again.

Which makes me think that Shotcut has a problem with my .ts file and that this is a bug.