Exporting issues in latest version

This is a problem I’d noticed (and reported) before, but since it couldn’t be resolved I continued to use Shotcut 18. Problem is I now need to use animations, which I can’t do with that older version.

So I tried version 22 again (even upgraded to the very latest, 22.06.23) but still am having the exact same issue.

For reference, this was my previous report:

I can add some new information to this based on this new video, as it has different content (I’ll include my mlt below): this time I have four video tracks. V1 is the only one with an actual video. V2 has a jpg template I use to position my text (I hide it once my text is done). V3 is the jpeg I want to animate, so it has keyframes. And finally V4 has a transparent background with the text.

Now, when I export, two things happen: 1) only V1 ends up in the video; 2) it ends up much smaller than it should be (ie it doesn’t fill the screen, so you have a large black border all around it–see screenshot).

Also, the exported file is only 3 MB, when it should be at least 30 (previous and similar videos have been in the 30-60 MB range).

R-Everlife_Cov.mlt (28.8 KB)

This is a screenshot of how my video looks in VLC. It should be taking up the entire screen and not have that black border all around.

These are my export settings (which are identical to those in v18–I double checked, except I tested here with 100% quality, originally it was at 60, but increasing this didn’t help):

And, finally, my log file after exporting:

log2.txt (3.3 KB)

Let me know if I forgot anything!

PS. Something I didn’t think to mention last time and almost forgot now, is that I’m using the portable version of Shotcut 22, vs the installed version of v18. I doubt that would have an influence, but I thought I should mention it, just in case…

One of the problems is likely due to trying to open a project from 4 years ago into the latest version of a fast growing software project. We do try to maintain compatibility, but that is not perfect. That plus there are some better ways to do things now. For the video not filling the frame you need to increase the Scale in the Rotate filter. That filter had some important visual quality fixes that broke the compatibility. But in version 22, remove the Rotate filter and use Properties > Rotation instead to correct orientation. That is better quality and much faster. Your text clips on V4 are using black color with a Chroma Key filter, but that is the wrong approach. For each text clip, remove the Chroma Key filter and choose Properties > Preset > transparent. When I do these things and export I get all video tracks filling the frame:

Thanks! That helped, though it’s still coming out messed up. I followed your instructions, but:

  1. the text is still not showing in the exported video;
  2. the animation (V3), instead of starting from the middle and growing slowly to take the full screen, just suddenly shoots by from top to bottom, sliding against the right edge??

So here’s something I don’t get. The preview window does not reflect what ends up in the exported video. If the preview window had shown a smaller image, I would have known to scale it more. But it looked good in there.

Likewise, my animation runs exactly as expected in the preview, and yet when I export, it doesn’t do what it’s supposed to!

Here’s the updated version.

R-Everlife_Cov.mlt (26.1 KB)

And the log file:

log.txt (4.3 KB)

On a side note, I’m also noticing that 22.06.23 no longer shows track names… is this a bug? I only get three dots. If I click on them, the names reappear, but soon as I click out, it goes back to the dots.


Your project is so tiny just start over using the advice given. I’m not going to help more.

It’s a small file, sure, but it still took me two hours to make. But thanks anyway.

Look, I know it’s a free tool, and I realize you must be swamped with work and have little time to spare for support, so I appreciate your help, I really do, but could you at least address the preview window issue? That seems like a pretty major bug to me.

It’s one of the reasons why I reverted back to v18, as v18’s preview was reliable. How can I fix an issue, after all, if the preview window itself doesn’t detect it?

I remade your project using version 22.06.23
Used all of your existing filter specifications and keyframes.
All you need to insert is your small image used on V3
Four track.mlt (21.0 KB)

The video text is different than what the project MLT uploaded is. The uploaded MLT has your original words.
Exported with just default settings. Did not enter into Export → Advanced.

Video Link: Four track

Thanks. The animation is still off in that video.

I managed to fix it though. Had to delete the keyframe AND the jpeg. I re-added it and redid the keyframe and only then did it work the way it was supposed to.

Same with the text. Ended up adding a new video track and re-doing all the scenes, copy-pasting only the text.

So it all works now. Just wish the preview would have actually matched the exported video, would have saved me a lot of time and hair pulling.

Thank you both for your help.

This topic was automatically closed after 90 days. New replies are no longer allowed.