Export only renders ONE video track instead of two

Hey guys! It’s been a while since I’d used Shotcut. I’m getting back into it and made a bunch of videos over the weekend. I’m now trying to edit them all.

The first one went through fine, great.

After that, though, I thought maybe I should upgrade to the latest version (I was still using 18.01.02).

After the install, I go in to edit video #2… And this time, all goes well until the export.

So, just to clarify, this is using version 22.03.30.

The video looks fine in Shotcut, but when I play the exported video, it only has the main video track, but it’s missing the second one (with the background). Audio tracks were unaffected.

The video track was not hidden, so I can’t figure out why it did this.

I tried installing this version of Shotcut on a more recent laptop, but the result was identical.

I thought maybe I could open my .mlt file with the older version of Shotcut and export it from there, but it made that version crash (I’m guessing the .mlt file is not backward compatible? though I didn’t use any new filter or anything).

So anyway. I’ll provide screenshots and the log file after the export, maybe someone can figure out what’s going on here?

The first screenshot shows what the project looks like in Shotcut before I hit the export button.

The second screenshot is what the video looks like after the export!

What am I missing?


log.txt (5.4 KB)

Did you extend the Background (V1) jpg file the whole length of the clip on the Video (V2)

Did you apply any Keyframes or Trim the Chromakey filter?

Yes, I extended the background image the full length of the video–I’m not sure why it’s showing that duration. The image below shows the beginning and end of my timeline side by side. You can see here that the video tracks are the same length.

I’m not sure what you mean by keyframes, as for the chromakey filter I didn’t even know it could be trimmed lol.

Here are the filters I’ve used on the main video track:

  • Chroma Key: Simple
  • Alpha Channel: Adjust

On the background image:

  • Size, Position & Rotate

Perhaps upload your MLT (Project file). Just drag and drop in here.
That way we can look at all of the filter settings at once.
Your media files will not be needed.

It looks to me as if you exported “From: Source”, rather than “From: Timeline”.

I’m not sure what that means… What I did is that I made a copy of the first video’s MLT, renamed it to the new video file. Once opened, I deleted the elements I no longer needed, dragged the new elements into the playlist, then from the playlist inserted them into my timeline.

NOTE: Since I needed to get the video out today, I installed the older version of Shotcut on the new computer and went through exactly the same steps, and the export worked. All settings were identical.

I’d still like to find a solution to this, of course, as I’d rather use the latest version.

I’ll do even better. I’m including two MLT’s:

TTS-02.mlt = The project that doesn’t export correctly in the latest version of Shotcut.
TTS-02b.mlt = The re-edited project (everything identical) that exports fine in the older version of Shotcut.

Hopefully that will help…

TTS-02.mlt (15.9 KB)
TTS-02b.mlt (25.1 KB)

It appears your background image zoom is way too small on both files.

Then why does it look OK in the preview window? Isn’t that supposed to be reliable?

And if there’s the same problem in both files, then why does it export as expected with the second file when using the old version of Shotcut? Does that older version handle it differently in some way?

This is all very confusing :o

I’m not sure either.
Using your settings in TTS-02.mlt this is showing where that small image is positioned.
I’m not sure how you get it to show in your original screenshot.

If it was over your main video it would only show 9 pixels by 3 pixels.

Perhaps the more experienced people in the forum can find a solution.

I used the same video mode, same size for the video you have, but used a PNG image instead.
Found what I think is the original image, but a much larger size than what you may have.

Chroma Key Simple on V2
Crop: Source - Center option on V1

Exported with default settings, and shown with VLC

Image that I made up used on V2:

MLT file used for this example: 720x1280 test.mlt (5.2 KB)

See the image:

Yep, that’s the same image–though I got mine from pixabay. I grabbed the biggest version (2800x1445).

That said, you say you used a PNG version–you think that would make a difference? And how did you get that? I only see jpeg’s on both pixabay and maxpixel. Did you convert the jpeg yourself?

Ah, that. Yeah, it’s set to “Timeline.” Which is the default anyway :wink:

I’m starting to wonder if it’s not a problem with my export settings. Although that’d still be weird, since I’m using the exact same settings I was using in the older version…

UPDATE: Hmm. I just noticed in those screenshots that the GOP switched back to 150 frames and B frames to 0. I’d changed that to 15 and 2 respectively, to match what was in my V1 settings. I’ve exported with both 150/0 and 15/2 with no difference in the result, though…

This topic was automatically closed after 90 days. New replies are no longer allowed.