Exporting in custom resolution bugs the video

What is your operating system? Windows 10

What is your Shotcut version (see Help > About Shotcut)? Is it 32-bit? 23.05.07 AKA Latest, 64-bit

Can you repeat the problem? If so, what are the steps?
No matter what resolution or aspect ratio used, if I try using a custom one through using “Settings → Video Mode → Custom → Add…” it results in a bugged video that cannot be watched.
These are the video mode settings I was using for the following video:
“Resolution: 1920x1080
Aspect Ratio: 16:9
Frames/sec: 30,000000
Scan mode: Progressive
Colorspace: ITU-R BT.709”

I am not even sure if the video will work when uploading it here.

I have no custom settings in the export menu and I need to use an actual custom resolution which is not in the default resolutions for a video I want to export. I did not have this issue with older versions of Shotcut.

You have to set you project setting to the video mode you want to your result to be and leave the export setting alone, so what you see while editing, is what you get when exporting. Else you will not get the results you expect

What? I understand exactly how video modes work. I made a custom video mode for a video I then edited after selecting the video mode. The issue I have is that custom video modes make the whole video unwatchable; the video gets stuck on the first frame/ on a black screen. The aspect ratio and resolutions I use for the video I intended to use them on are 1920x1000 48:25 (I got the aspect ratio from an online aspect ratio calculator.) Even when typing in a regular common resolution and aspect ratio like 1920x1080 16:9 in the custom video mode, the video remains unwatchable.
Again, the issue is not that the result is not what I expected, the issue is that the result is a bugged video which does not work.

I have no problem creating a 1920x1000 custom video mode, add some footage and export the video and it plays fine in VLC

Same for me. There must be some other difference that we are missing. Maybe there is something unique about the source media that we can not see.

@BeepBap, would it be possible to post a zip file of a bare minimum project and source files that demonstrate the problem?

Yes, I can do that. The forum allows for only 8MB of upload so I had to put the zip file into drive. Here’s the drive link: Shotcut custom resolution bug.zip - Google Drive
The zip file contains 2 MP4 files and an MLT file, the MP4 files being the source media and the exported version of the source media. The MLT file is the project which has a custom resolution selected; 1920x1000 and a 48:25 aspect ratio (unsure if this will show up or be selected when you open the project).

The issue I have after exporting with a custom resolution does not seem to be dependant on the video I use. To prove this I have used a different video in this example than the video I used in the first message of this thread. I have also tried re-installing Shotcut; that didn’t work. I hope this is what you were asking for me to provide.

Thank you for providing the example media.

Looking at your exported file, I see that it reports a very high and strange framerate:

That strange frame rate is almost certainly causing your problem.

So I opened your provided project file and followed these steps:

  1. Open “custom resolution bug.mlt”
  2. Click on “Export File”
  3. Click save with the default file name “custom resolution bug.mp4”.
  4. Wait for the export job to finish
  5. Open the exported file
  6. Observe that the file plays perfectly and the frame rate is 60fps

So not the question becomes: why does the frame rate get messed up when you export it, but not when I export it?

Are you absolutely sure you are not changing any settings in the “Advanced” section of the export panel?

Does your export panel look exactly like this (including disable hardware encoder)?

Oh wow I had actually no idea about the framerate, windows media player shows 60 frames/second when checking the properties.
My issue has been resolved! It was the hardware encoder being enabled, which I thought I had disabled, since when I checked if my settings were the same as the image TimLau had sent in his second message, they were the same. Or so I thought.
Exported the video without using the hardware encoder and the video works as it should. Thank you both brian and TimLau for your help :>

This topic was automatically closed after 89 days. New replies are no longer allowed.