Export fails on every project

I recently installed the last 23.x.x version of Shotcut. Today I tried to quickly trim down a YT short. It failed to export on the 23 version so I got the 24 version a couple hours ago, but to no avail. This was the first project I attempted on the new versions. It failed numerous times, despite fiddling with the settings. I read through post after post and tried my best to figure out what’s going on, but I’m stumped. So I opened some projects that I’d done on the old version I had before (21.x.x can’t recall exactly) which were successful when I did them originally. They failed to export on the new version as well. Another curious thing is that the failure timestamp is always 1 frame before the end. All with the same generic error code of 1073741819.

Were Back Error.txt (4.0 KB)

Nurse Error.txt (286.6 KB)

Nurse was a previous project, We’re Back is the current.

Any assistance is greatly appreciated. I feel like it’s something really simple that I’m missing and should already know the answer to. I’ve been working on this for hours.

Are you trying to export with AMF hardware encoding? Try unchecking the “Use hardware encoding” box on the export panel and try again.


I’ve tried it with hardware encoder on and off both. It made no difference.

Did you try playing the export output?

Lines at the end of each log suggest it completed writing the file, but sometimes the export process fails when it is closing and doing some cleanup:

[mp4 @ 00000257232ea800] Starting second pass: moving the moov atom to the beginning of the file
[AVIOContext @ 0000025738164a40] Statistics: 320084449 bytes read, 0 seeks
[aac @ 00000257230bdcc0] Qavg: 63173.441
[AVIOContext @ 00000257233906c0] Statistics: 640346311 bytes written, 18 seeks, 2455 writeouts

Both of the logs that you posted had hardware encoding on. Can you post a log from an export with hardware encoding off?

Some other things to try:

  • Reboot your computer

  • Turn off parallel processing in the advanced export settings

  • Disable “dual pass encoding” (or use Quality Based VBR)


  • Load our most trusted export preset: “YouTube” and DO NOT CHANGE ANY ADVANCED SETTINGS

This is a common error code with a wide variety of causes. There are many ideas in the forum archives on this topic:

…I did not try to play a file. I took the “Export Failed” at face value. That said, I just opened the most recent and it worked fine, aside from a single random audio pop that wasn’t present in the original recording. So, I guess this issue is a non-issue and I’m getting false failure flags.

I have a same issue with Shotcut version 24.02.29
Fortunately, I kept the previous version of Shotcut version 22.
It looks like the hardware decoder is not being detected and is probably related to multiple video cards.
last time, a similar problem was solved by enabling the video output duplication mode.
But this time, when the new version tries to find the decoder, it says “nothing found”, although version 22 defines the h264* decoder

Probably ATI Radeon HD 3450 is too old now (released 2007). If Intel QSV is not working then either it is too old or your system is not setup to support that. The software moves along, and support for old hardware will be often be dropped by the vendor’s libraries as new features are added. So, if you want to stay on old hardware, don’t update the software,

This topic was automatically closed after 90 days. New replies are no longer allowed.