Export failed when using hardware encoding

I wanted to try to configure the hardware encoding.
OS- Windows 10
ATI Radon HD 3450 video card
There is also a built-in Intel HD video card
When in the encoding settings I try to determine the available hardware codecs then Shotcut defines h264_qsv as available.
Then I import the video and try to save it with the “default” settings, but the process fails immediately.
The journal has the following information:

[h264_qsv @ 0000013dc754ab40] Encoder: input is system memory surface
[h264 @ 0000013dc794c640] Reinit context to 464x848, pix_fmt: yuv420p
[h264 @ 0000013dc7b9c840] Reinit context to 464x848, pix_fmt: yuv420p
[h264 @ 0000013dc7a45580] Reinit context to 464x848, pix_fmt: yuv420p
[producer format] audio: total_streams 1 max_stream 1 total_channels 2 max_channels 2
[AVIOContext @ 0000013dc7867480] Statistics: 131072 bytes read, 1 seeks
[chain avformat-novalidate] D: /GoogleDrive/Videos/0-02-05-093799ffdf8cfe42c8f8b3d0cecdddd39ad61519fb53d8b778436e5d5184ca95_4e64133d425ba4d1.mp4
    checking VFR: pkt.duration 34
[filter swresample] 2 (stereo) s16 44100Hz -> 2 (stereo) s16 48000Hz
[h264 @ 0000013dcc0cdb00] Reinit context to 464x848, pix_fmt: yuv420p
[h264_qsv @ 0000013dc754ab40] Error initializing an internal MFX session: unsupported (-3)
Failed with exit code -1073741819
Failed with exit code -1073741819 

also into all event log info:

[Debug  ] <MainWindow::open> "D:/GoogleDrive/Videos/0-02-05-093799ffdf8cfe42c8f8b3d0cecdddd39ad61519fb53d8b778436e5d5184ca95_4e64133d425ba4d1.mp4" 
[Debug  ] <MLT> [producer avformat] audio: total_streams 1 max_stream 1 total_channels 2 max_channels 2
[Debug  ] <MLT> [producer avformat] "D:/GoogleDrive/Videos/0-02-05-093799ffdf8cfe42c8f8b3d0cecdddd39ad61519fb53d8b778436e5d5184ca95_4e64133d425ba4d1.mp4" checking VFR: pkt.duration 34
[Debug  ] <Mlt::Controller::setPreviewScale> 464 x 848 
[Debug  ] <MLT> [producer avformat] audio: total_streams 1 max_stream 1 total_channels 2 max_channels 2
[Debug  ] <MainWindow::setAudioChannels> 2 
[Debug  ] <Mlt::Controller::setAudioChannels> 2 
[Debug  ] <MLT> [producer avformat-novalidate] "D:/GoogleDrive/Videos/0-02-05-093799ffdf8cfe42c8f8b3d0cecdddd39ad61519fb53d8b778436e5d5184ca95_4e64133d425ba4d1.mp4" checking VFR: pkt.duration 34
[Debug  ] <VideoVectorScopeWidget::profileChanged> 601 
[Info   ] <MainWindow::open> "D:/GoogleDrive/Videos/0-02-05-093799ffdf8cfe42c8f8b3d0cecdddd39ad61519fb53d8b778436e5d5184ca95_4e64133d425ba4d1.mp4" 
[Info   ] <MLT> [filter swresample] 2(stereo) s16 44100Hz -> 2(stereo) s16 48000Hz
[Info   ] <MLT> [consumer sdl2_audio] Audio Opened: driver=directsound channels=2 frequency=48000
[Debug  ] <MltXmlChecker::check> begin 
[Debug  ] <MltXmlChecker::check> QVector("Shotcut", "version", "22.01.30") 
[Info   ] <MltXmlChecker::check> decimal point '.' 
[Debug  ] <MltXmlChecker::check> "C:/Users/Pan/AppData/Local/Temp/shotcut-spgUeC.mlt" 
[Debug  ] <MltXmlChecker::check> end "" 
[Debug  ] <EncodeDock::on_encodeButton_clicked> 194858811392 bytes available on "Data500" 
[Debug  ] <MeltJob::start> "D:/my_video/Shotcut/melt -verbose -progress2 -abort xml:C%3A%2FUsers%2FPan%2FAppData%2FLocal%2FTemp%2Fshotcut-mxWemk.mlt" 
[Info   ] <EncodeJob::onFinished> job failed with -1073741819 
[Info   ] <AbstractJob::onFinished> job failed with -1073741819 
[Info   ] <Util::isMemoryLow> available RAM =  6769008 KB

Sounds like this error:


According to the accepted soltuion, the generic Microsoft display device driver does not provide access to QuickSync. The Intel HD Graphics driver has to be installed.

Another possible reason could be the non-standard resolution:

Just as a test, try encoding something that’s 1920x1080 instead of 464x848 to see if it even works. QSV sometimes bonks on low or non-standard resolutions.

1 Like

Several reports of this error seem to be related to having dual monitors attached, try using only 1 monitor, if this in fact is your case.

Please let us know if your problem gets solved.

1 Like

I came across information that this may be due to two connected monitors, and yes - this is my case.
Well, after I physically disconnected one monitor’s cable, I tried to export - and, surprisingly, it worked.
However, physically disconnecting the monitor cable seemed inconvenient.
So my second experiment was to change the settings, I tried Duplicate Desktop mode (instead of Expand Desktop mode) - and the export was also successful and very fast.


Thank you for letting us know. Several times we suggest a possible solution and never hear back from the original poster whether or not it worked.

I’m glad you were able to get the export sorted out.

1 Like

This topic was automatically closed after 90 days. New replies are no longer allowed.