Export Advice!

Hello! This is going to be a lot shorter of a question since I might just be exporting things wrong. So, the video I’ve been working on is in a 5:4 (maybe 4:3?) aspect ratio in itself, but it was recorded in a 16:9 ratio due to just some inexperienced recording. I’m trying to edit it in Shotcut so that it fits into the proper aspect ratio, and then export it to youtube. I’m glad to see it exports properly into the right ratio, but it ends up having this ring of black bars all around it. As we speak, I’m going through a lot of trial and error, but I’d like to know what I might be able to do to solve this. Thanks in advance!
Here’s how the image looks in youtube. They grays at the side are just to show that its in a proper ratio.

You can change a clip’s aspect ratio in Properties.

So there are some things in your question that need further clarification I think, and then we can possibly make some progress.

That sentence does not compute. Since it is somewhat unclear and I may be misunderstanding (not for the first time), instead of guessing I will just ask some questions:

  1. Your current Shotcut project (the one you are trying to bring this video into). What is the video mode set to?
    Video Mode
  2. What are the specs of this new inexperienced recording in terms of resolution and frames per second (is it 1920x1080 at 30 frames per second, for example)?
  3. Can you upload a screenshot of your entire Shotcut window, including the preview section and the timeline) with the video in question selected on the timeline.
  4. Can you please link to a video you have exported that isn’t giving you the expected results, and perhaps clarify what you want to happen based on that video (I know you have black bars, or what appear to be black bars). You could even modify a screenshot to show us what you want the exported video to look like. Or even better, if you have an example of what you want to achieve (even by another user), link to that also.

Apologies for not being specific! I thought it would be a lot easier of a problem. To clear up some things,

  1. The Aspect Ratio is indeed 5:4, sorry for making it confusing. 4:3 just looked similar enough that I thought it was, but after some trial and error I found out it was simply 5:4.
  2. The Video Mode is set to HD 1080p 60 fps
  3. The Recording Settings are in OBS, and they’re standard. 1920x1080 at 48 FPS. Of course, this leads to a 16:9 aspect ratio. Both Base & Output are at this resolution.
  4. Unfortunately at this point, I had removed that video for space reasons. But I can easily replicate what I was trying to do using a different test clip. I know the aspect ratio is quite crazy, but I can assure you I typed in 5:4, and that is what was put out.
  5. Due to the lack of ability to send multiple images (apparently,) the best I can do is put both into one image. The image itself shows the Shotcut window and the settings that I used to test things out, while the bright pink square shows the ratio I do want. Just an entire removal of the black bars surrounding it.

I hope this helps!

From what I can understand, you want the actual gameplay to be the video with no borders.
I don’t know the actual inside dimensions of your gameplay video.

I created an example image.

  • The first step is to create a custom video mode.

Open the video in Shotcut and apply the Crop: Source filter. Then make adjustments to crop out all of the black border.

Before & after screenshots applying the Crop: Source filter.

No need to enter into Export → Advanced.
Choose an Export preset then Export.


This has done the trick! Thank you very very much for the guidance! My only hope now is that it doesn’t look too fuzzy due to the zoom in that happens, but I suppose beggars can’t be choosers.

Thanks again!

1 Like

This topic was automatically closed after 90 days. New replies are no longer allowed.