Desperate for ChromeBook/Linux install help

Hi everyone,

I’m totally new to linux, with the exception of installing OpenShot, which I am less than thrilled with. I stumbled upon ShotCut via Entrepreneur magazine and decided to give it a shot. I downloaded the AppImage file via the Shotcut website, but I can not get it to install at all. I have gotten “Not found” and “Permission denied.” Is there something I am missing? PLEASE HELP.

Thanks, everyone!


Can you verify your OS and hardware? AppImage is a linux file for installing shotcut, have you tried using the portable TAR file?

Thanks for the response. I am totally new to coding and linux, so the fact I was even able to open anything is phenomenal lol. I am running a chromebook with the latest linux beta. I was able to successfully run OpenShot, but I can’t figure out how to update it and my video is choppy as hell.

The Shotcut I got was the AppImage, but have zero experience with the TAR stuff so I didn’t want to screw anything up

AppImage files need to be marked as Executable in order to run. There is nothing to extract or install. That’s the beauty of AppImage. Depending on your window manager, it should be possible to right-click and view properties and enable Executable. Then double-click the icon to run it.

Standby. I’m going to feel like a total idiot

whew, I don’t feel as much of an idiot as I thought. I am not able to even get the view properties. If it helps, I am running a chromebook

That does make a profound difference. See:

Ugh, I am at a loss. This is the page I used originally and still nothing. Even with the latest release from Shotcut. This makes me desperately wish I would have paid attention in computer class in high school.

Any idea how I go about using the TAR file?

You said you’re on a chromebook, what model? Some run arm and would mean the prebuilt versions of shotcut wouldn’t work.

As for the tar you just need to extract it and then run it

Thanks bud. I’m still trying everything I can think of and find, and still no luck. I am running a new HP 14 Chromebook. I tried finding the model number from my Amazon account, because I am now realizing just how technological illiterate I am, but all I found were the specs. 180 degree swivel, AMD Dual Core A4-9120 Processor, 4 Gb of SDRAM, 32 Gig eMMC storage, Chrome OS. Hope this helps.


Those are the important specs, the A4-9120 is an X86-64 processor and if you’re in linux mode should work, are you sure if your linux build is 32 or 64 bit however? 4gb of ram is slim for running shotcut either way but if it defaulted to a 32bit os and you’re using the 64 bit installer could be (part of) the problem

This topic was automatically closed after 90 days. New replies are no longer allowed.