Deinterlacing results in ghosting

Is the field order correct? Does it look better if switched to Top Field First?

There seems to be an awful lot of movement for 1/50th second between the two fields.

What is the Video Mode (timeline frame rate)? 60i, 60p, or 30p?

30p I think

So the problem here is that your source clip is interlaced. And you have set your Video mode to an interlaced format (probably using “Automatic”). But you are trying to use the export settings to force it to progressive. This is not the correct way to convert from interlaced to progressive. If you want a progressive output, you need to use a progressive Video Mode. Additionally, if you use a progressive video mode, the preview player will apply deinterlacing to the source clip.

First, use a Video Mode that matches your desired output format. Shotcut does not have one built in that matches the export parameters that you showed. But you can make a custom video mode:

In the Add Custom Video Mode dialog, give it a name and set the parameters to what you want in the output. I think this matches what you are looking for:

image

Make sure your new custom video mode is selected in the menu.

Open the video and make any edits that you want to make. When you are ready to export your video, do not make any changes in the advanced export settings. Everything will be set appropriately from your Video Mode.

Look, no ghosting:

A correct starting Video Mode is very important for resolution, aspect ratio, and frame rate but not scan mode.

if you use a progressive video mode, the preview player will apply deinterlacing to the source clip.

True, but so do also interlaced video modes when Settings > Player > Progressive is on, which it is by default.

Maybe the poster’s problem is in the version of Shotcut they are using.

Here is my example. I used the current release version with Settings > Video Mode = Automatic, and all I did was change Export > Video > Scan mode = Progressive:

Shotcut_00_00_00_300
Shotcut_00_00_00_300p

Nope. Still ghosting

Can you tell us what version you are using? I did my testing with 24.04.28. If you are using an older version, can you try upgrading? If you are using 24.04.28, then maybe there is some other difference that we did not guess yet. You could share a .mlt project file that we could open to see if the clue is in there.