Crash/freeze after adding a Text: Rich filter

Hi all,

This is my first post on this forum and I’m a beginner with Shotcut.

I experienced this bug already with the previous version, but it happens with the new one as well (21.08.29). What am I missing?


Please state your operating system.
I never experienced this problem. Maybe it just does not work on your system for whatever reason like maybe the GPU or its driver:

Sorry for not specifying my hard/software.

OS is Windows 10 Pro 64bit, the GPU is an Intel UHD Graphics 630, so no extra graphic hardware. The CPU is is a i7-8700 and 32GB of RAM


I was thinking about a way to enable some kind of debug output, allowing to find the culprit of this bug, since I think my configuration is pretty standard.

Is there a way to produce such output?

If you mean an application log…

You can go to View and click on Application Log…
Save it as a text file that you will then be able drag into a comment here on the forum.

That is good advice. However, if Shotcut crashes and you reopen it to get an application log, a new log will be created. After a crash, DO NOT OPEN SHOTCUT and follow these steps:

  1. In the Explorer location bar, enter “%LOCALAPPDATA%” and press Enter.
  2. Then look for Meltytech\Shotcut\shotcut-log.txt.
  3. Upload the log file so we can inspect it.
1 Like

Thanks for the info @brian. I was wondering if it was the case. Now I’ll know.

Thanks a lot for the info.

I just tried to create the freeze again, but for whatever reason it just was freezing for maybe 2 Minutes and then the “Text: Rich” filter appeared.

It’s kind of strange that it takes so long, but I didn’t see something special in the log.

I’ll keep an eye on it, since the last time I had this problem, I could easily reproduce this behavior multiple times.

Thanks, Stephan

Thanks again for your help.
Unfortunately even the Text: Rich filter doesn’t crash anymore, it’s basically useless for me, because every mouse-click freezes Shotcut for about 2 Minutes.
And because there is no crash, I also don’t see anything in the log that could help to find the culprit.

Let’s try to do a test.

  • Start a new project.
  • Open Other - Color (pick any color or leave for transparency)
    • Do not transfer to the timeline, stay in Source.
  • Select Text:Rich filter
    • Set font color
    • Set font size
    • Select a font
    • Type something like “Do not freeze on me right now”

At what point does Shotcut freeze for you?

At [Select Text:Rich filter].

Thanks a lot for your help!

Are you using anti-virus software?

Only the one that is built in Win10.

What Display method are you using?
Have you tried changing display methods?

I was using DirectX (ANGLE), but tried the others: same result for all of them.
To me this kind freeze has a similar duraion than when trying to access a path that is not mounted.

In the meantime I found another solution than to use the Test: Rich filter.

Thanks anyway!


I had the same error and I was able to resolve it by launching the program with the option “Run as administrator”.

They must be something wrong with the access rights.

1 Like