Constant crashing and text boxes not showing

I’m attempting to finish some very urgent videos, however ShotCut has spat the dummy and is constantly crashing on startup after I uploaded the most recent update, despite uninstalling and re-installing, and even tried installing an earlier version. I also tried installing from each hub). I also tried ticking the box and not ticking the box during the install process that suggests tick if crashing on startup.
Since the update, I noticed that the ShotCut-branded startup visual is chopped off on left and right side, only showing a middle chunk.

Also prior to crashes, I was adding text boxes, but after exporting video, they were not showing up in the final video. When I go back to check the .mlt file, in one file the text is still showing on the video - in the other file, even though text box is ticked and text is showing in the box where you type it on, only an empty text box is showing on the video. This is part of why I checked for updates.

When uninstalling and re-installing, I downloaded the Win-64 Installer. I didn’t download the option of the zipped files, as I don’t know what they are.
(I’m on Windows 10, 64-bit)

Any advice very welcome!

Hi, is that 18.08.11? (not 18.08.01)?

Tried both, and the one prior (17.05.03)

Oh, yes, tried the latest one first.

Hi, highlight your clip with the text filter, and look at the keyframe box (see photo). Has the green line (I think it’s called a tarball) been shifted to the right? I found this problem; I didn’t move the tarball but found it was moved mysteriously and erratically. Could be a bug?. I haven’t checked if this is fixed in 18.08.11 though.


If you find this (above post), sliding the green tarball to the left will make the text appear again.

If your project does not involve keyframes, I believe version 18.03 is a pretty stable version so you could try reverting to that.

Thanks, appreciate the suggestion. Once I stop it from crashing I’ll be happy to check on this and experiment - it crashes pretty quick, just not enough time to do anything useful at all - like, we’re talking a few seconds.

No problem. Just to let you know it doesn’t crash on my system. Well, not frequently, just sometimes… Good luck!

Thanks. It’s been a rare thing until this catastrophic fail - couldn’t have picked a worse time! lol…funny not funny…

You could report the crash in more detail here (maybe send a crash log?) and see if anyone can help. (Unfortunately not me - I haven’t got the technical skills to help with that type of thing…)
I noticed a few guidelines here which may be useful:

Thanks for the suggestion and the links.
Appreciated! :slight_smile:

No, it is not. “Tarball” is another zip-like archive format optionally with compression. The bars you are referring to are the filter trimming controls - green for filter-start (aka in) and red for filter-end (out).

That is a very bad sign. There is nothing in the update that could cause this. This is a sign of a possible incompatibility between Shotcut and your video card/chip. It might explain your frequent crashes. Or, possibly you were expecting to see the old splash screen and branding. Now, it is supposed to be square-ish and look like the icon (see top of this page, for example).

The words are chopped off. It’s definitely a glitch.
It only presented that way since the 2nd last update. There is no change in my PC that I’m aware of from when it was all working fine before.
Meanwhile, one of the links provided by jonray suggested testing if the issue occurs with different project files.
So I opened it and left it open for ages without opening any file, and it didn’t crash. Then I opened a file from a different project and date, and it opened, and I could play it. Then I went to close it to try opening another, and it went to ‘Not responding’ and then it crashed. Seems it just wants to keep going A.W.O.L. - anyway, somehow this sort of seems like possible progress. I will keep experimenting.
What’s weird is if I completely uninstalled, and removed previous installer files from my Download folder, and reinstall as if for the first time, it makes no sense. Nothing is different with my PC - unless there is some weird glitch going on that I don’t know about? If I was to ask my I.T. person to investigate, any ideas as to what could be checked? Can video cards/chips corrupt or die? (Windows 10)

Oops, sorry. I live and learn… Thanks for putting me straight.

Update - Suddenly had the thought (d’oh) to download Shotcut to my back up/travel laptop and so far that’s going okay, so it means I can get on with editing, and so it looks like my Dell PC has spat the dummy. There are a few other issues arising (separate from ShotCut) so it looks like it’s time to take it to the doctor. Hopefully this will sort it.
Thanks for your support. :slight_smile:

I’m having the same problems.

Splash screen:

Text is there but does not appear even in editor. Tried changing font size, color, type, text position, nothing happens.

I find out that creating a new text filter and setting everything manually to what it was in the previous filter, it will work. As these are captions that I’ve put in the entire video, I will have a long night here to fix everything.

I inserted a new text field and set it as the previous one for comparison:

Fixed it! Tried a little bit to edit the .mlt, then I understood that the problem is with a new feature, keyframes. So if I click the keyframes button (at the right side of position parameters), text will magically show up again. After that, I can remove the keyframes.

I have a screenshot showing that, but can’t upload it here because as a new user I can only reply 3 times and send a single image every reply. So, imagine it. ¯\_(ツ)_/¯

1 Like