Color Picker Malfunction

What is your operating system?

What is your Shotcut version (see Help > About Shotcut)? Is it 32-bit?
Latest, I ran the built in updater and it said I’m up to date.

Can you repeat the problem? If so, what are the steps?
(Please be specific and use the names as seen in Shotcut, preferably English. Include a screenshot or screen recording if you can. Also, you can attach logs from either View > Application Log or right-click a job and choose View Log.)
Yes, I m using video from a Paralenz Vaquita. It’s in the same format as used for YouTube. The source and export file extension are the same. When I add a white balance filter to a video segment, then use the eye dropper to pick white, the color patch turns black and the video goes completely black. If I pick colors manually for the color patch the white balance works well.

It seems to be only this file format that has issues as I opened an older project taped with a go pro knock off and things worked well.

There seems to be a related post about unbuntu’s color picker.

Does any of this sound familiar?

Apologies for the imprecision, I’m writing this in my car the next day. Hoping I can get an answer. If not I’ll post later with more precision.

When using the eye dropper drag a small rectangle instead of single click. Single click grabs one pixel that is difficult for you to pick precisely. The rectangle chooses an average of all pixels in the rectangle. Otherwise, it is impossible that this tool behavior is different based on the video format.

I tried that as well. It still went black. I’ll try on windows tonight and see if the behavior is similar.

If I need to do this manually how is that done? I saw I can manually put in a color. Assuming I can measure with another eye dropper or just guess, do I enter the color as is, or something else.

There is no easy workaround because there is inconsistency in the color dialogs on Linux depending on your desktop and build, etc. I have not reproduced the problem you describe, but I vaguely recall a reported problem on Wayland.

It’s weird the color picker next to pick neutral color does not work. But if I click the color swatch and then click the custom color. And then the color picker there it gets a color sample and the white balance seems to work.

I found the wayland reference

So what is wayland? And can I choose something via a configuration file or similar?

ahh, awesome, my workflow involved a screenshot and gimp and color picker there… this certainly will help :wink:

it’s what is under gnome/KDE to handle the window display in most modern linux. you have the option to install its predecessor (xwindows/xorg) and choose which one to use when you login.

the steps to do that depends on your distribution.

however, I have not tried on xwindows, my assumption that it’s due to wayland is a guess and the problem might be the same even if you switch.

So what is this:

So is it possible to modify shotcut to use a specific color picker?

Is the process that the color picker creates a hex color code and the color swath then balance the hex color to white balance?

Here is the code for our color eyedropper. As you can see it is simple Qt code:

You can try to make a simple Qt app that works on your system to figure out a different approach to suggest.

I’m having exactly the same problem in Windows 11, Shotcut ver. 23.05.14. No matter where in the pic I click the picker, it returns black. Same result if I select a square of color. Just doesn’t work.

1 Like

I’m having the same issue on Windows 10. No matter if I do, one click with the dropper or drag and make a bigger selection, the screen continues to turn black.

Definitely not working like how it did previously.

Weird that it works fine for me. I’m also on Windows 10

Are you using some sort of GPU settings?

GPU Effects is disabled.
Hardware encoder is ON, but that shouldn’t affect the filters I suppose.

Me neither. I think we have the same settings. We have the exact same version with the same OS, so I have no idea why my Shotcut can’t do a critical function that I use constantly in my video edits.

I figured it out and it’s the WEIRDEST thing. I’m hoping @shotcut can explain it. I have a dual monitor set up. When I move the Shotcut window on the primary monitor, the white balance filter works. Upon dragging the window into my second monitor, it does the black screen error.

Is that a driver thing? That just doesn’t make sense to me, but it’s clear to me that it won’t work on that second monitor.


Are you using the portable version of 23.05.14 or did you install it?
I have the portable.

1 Like

Glad you found a workaround :slight_smile: