Color Picker Malfunction

Same here - dual monitors. Win11 22H2

But why would it work on one screen and not another?

idontknow01

1 Like

What about starting it on the second monitor?

Whether I start on the left or right, when I drag to the right monitor the filter doesn’t work. Odd, what can that be based on?

You are repeating yourself, but I asked you for a different test. I do not know why; it is not intentional.

Let me rephrase the last statement:

Step 1: Start Shotcut on Monitor 1
Step 2: Apply White Balance - Works
Step 3: Drag Shotcut to Monitor 2
Step 4: Apply White Balance - Fails
Step 5: Close Shotcut
Step 6: Start Shotcut on Monitor 2
Step 7: Apply White Balance - Fails
Step 8: Drag Shotcut to Monitor 1
Step 9: Apply White Balance - Works

Regardless of which monitor I start with White Balance fails on monitor 2. I’ve even tried above steps with a full restart in between, and it still fails. Maybe all the folks on Windows 10 that have the same issues have the same setting as my Monitor 2. I just have to decipher the difference in settings between the 2.

OK, thanks, that helps a lot.

1 Like

Works as expected on macOS. Appears to be a bug in Qt on Windows. The workaround is to open the color dialog and use its picker.

1 Like

Hi, tested your suggestion on 23.07.29 /Win 10 and it failed. Only cure, in my case, is to action on the primary monitor.

1 Like

I am seeing a similar issue here under GNOME/Wayland (openSUSE Leap 15.4). I’m also using a multi-monitor setup, but the issue occurs also if I use just one monitor, so the proposed workaround (using the primary monitor) doesn’t help in my case. I have tested it with various Shotcut versions, both AppImage and Flatpak, from 22.12.21 until 24.04.28, always with the same result.

Luckily, switching to GNOME/X11 is a valid workaround for me.