Clip transition applies to lower layers

What is your operating system?
Windows 11

What is your Shotcut version (see Help > About Shotcut)? Is it 32-bit?
Shotcut 22.06.23

Can you repeat the problem? If so, what are the steps?
(Please be specific and use the names as seen in Shotcut, preferably English. Include a screenshot or screen recording if you can. Also, you can attach logs from either View > Application Log or right-click a job and choose View Log.)

When having at least 2 video tracks and using the cross transition between two clips from the same upper video track, the effect applies to the lower video track as well.

0. Have two empty video tracks

  1. Add a color clip on the lower track.
  2. Add two pictures/images on the upper track one after the other (the lower track must be visible on the background)
  3. Shift the photos in order to create a cross fade transition between the two.
  4. Play the video and see that the color clip on the lower track also reacts to the transition instead of staying unchanged. So the color on the background is fading away briefly.

The color clip on the lower track gets darker as the transition occurs and then it pops up again when transition ends.

The color clip should not be affected by the transition. The transitions should only cross fade the two image clips from the upper track.

Project is uploaded here: (1.8 MB)

1 Like

You should paste a screenshot of the whole Shotcut window showing the problem. Without this anyone trying to help you is working in the dark. Preferably with the transition’s properties showing.

Le comportement est tout à fait normal, le second fichier sur la piste V2 est une image jpg sans transparence. Etant placée au-dessus de la piste V1 c’est normal qu’elle la cache.
Remplacez l’image jpg par un clip transparent avec du texte (comme le premier) et vous verrez que le fond coloré de la piste V1 reste visible pendant toute la transition.

The behavior is quite normal, the second file on the V2 track is a jpg image without transparency. Being placed on top of track V1 it is normal that it hides it.
Replace the jpg image by a transparent clip with text (like the first one) and you will see that the colored background of track V1 remains visible during the whole transition.

test - Réparé.mlt (10.6 KB)

I think the issue he is reporting is that during the transition the “black bars” on the sides turn from orange (=color on V1) to black then back to orange.
I would not say the behaviour is normal, the area to the sides of the image is clrearly transparent because outside of the transition you can see orange from V1 below. The transition probably considers the entire video area as non transparent so the transparent edges (that are automatically added to fit the image into the 16x9 format) become black.
The correct transition mix can be achieved if I add a Crop: Rectangle filter to the image clip (see attached project).

mid transition:

after transition:

with crop, mid transition:

test_v2.mlt (11.0 KB)

1 Like

C’est fort possible, comme le fichier “pexels-lumn-309724.jpg” n’est pas fourni, je l’ai remplacé par une image de ma bibliothèque personnelle au même format que le projet. Je n’ai donc pas les barres noires

It is quite possible, as the file “pexels-lumn-309724.jpg” is not provided, I replaced it by an image from my personal library in the same format as the project. So I don’t have the black bars

@Namna Sorry for not including the picture. As I said in step 2, yes, the picture must NOT be the same format as the project. That’s the whole reason why I want a background color underneath. I want to make a slideshow of pictures that are 5:4 or 4:3 format, so I do not want black bars, instead I want a color background to be visible all the time.
But in this situation the color clip from the layer beneath is reacting to the transition from the V2 layer, thus fading to black as well and the poppoing up full color after the transition ends, just as @daniel47 pointed out.

The workaround with the crop suggested seems to work, but this is not a solution as implies more steps to be made for each picture.
So, as a proper fix, the transition effect must consider only the content of the video layer as bound, not the full frame when applying itself on the layer in order not to affect layers below.

Vous pouvez aussi appliquer la solution suivante.
Ajoutez une piste vidéo et placez-y la seconde image
Appliquez un fondu sortant sur le clip texte et un fondu entrant sur la photo

You can also apply the following solution.
Add a video track and place the second image on it
Fade out the text clip and fade in the photo


@Namna This seems to be ok as a workaround, although I will not use it as it requires a lot of fiddling around to tweak the fade in-out timings and picture overlapping times and would be time consuming for more than a couplle of pictures.
I would rather wait for a proper fix on the reported issue.
Thanks anyway for the suggestion!

Just updated to Shotcut 22.10.22 and now the issue is worse.

Opening the same project attached, you can now see that the transparency of the upper video track is totally lost. You cannot see the lower video layer though the upper layer.

In my case, on the upper video layer I have a static image with a smaller ratio, such as on its left and right there are black bars visible (as the image does not cover all area). In version 22.06.23, the orange color from the lower video layer was seen thought the upper layer instead of the black bars there was orange backgound. Now, in version 22.10.22, the lower layer has no effect and the black bars are always visible.

Maybe you should have tested the beta. I have now reverted the change that causes black bars in the new version, but the original issue may never be fixed. I found the problem does not occur when using PNG with alpha.

Thanks for the reply.

The original issue should also not be there in my opinion. All effects should apply to the boundry of the content, not to the full frame (in this case to the layer below). Coming from Adobe Premiere Pro, this is the expected behaviour in such cases as it is counter-intuitive to apply the effect to the lower layers if it is applied only on the current layer.

I think the fix here should be to take into account the whole content area (not whole screen) and auto-create an alpha transparency on the areas that are ouside the content area to mask out the black bars when applying the effect.
Maybe this will unlock other possibilities / mixes in the future if treated correctly.

Converting each photo individually, using another software, into a png with alpha layer is a step that requires extra time and effort and may not be applicable on every situation (i.e. if I decide to change the image position in the mix)

What do you think?

It seems that someone else found a workaround for this issue here:

Basically, just adding a Size, Position & Rotate filter to the Head of the track makes the transition work as intended, with one exception.
If the images from the track are not the same width, a short unwanted compress-strech effect occurs with the second picture, so it’s still not ideal.

Here is the workaround with the new bug (1.8 MB)

Actually, looking at other solutions mentioned, the best workaround that I can come up with is the one mentioned here:

Just adding an Alpha channel adjust filter with default settings will have the desired effect and no visible side-effects.

So, if anyone will start working on this bug, investigate the result of applying this filter vs no filter.
See this in action here: (1.8 MB)

After finding out the the Alpha channel filter makes it work right, I tested out using png files with transparency instead of jpg files for the pictures. In this case the issue is no longer seen.

It doesn’t matter what is the size of the png file, it is only important to have an alpha layer.
So, the fix for this issue should be something like treating the images with a transparency layer even if the images do not have one.

This is fixed for the next version!

1 Like

Tested in Shotcut 23.04.18 and it is solved. Thanks!