Chromakey with Blond hair

Trying to do chromakey with green background with a very blond female subject and no matter what I’ve tried I can’t get rid of that green edge without severe pixelation. Anybody had any luck? What are your settings? Also, I was able to get it a little bit using key spill and selecting the remaining green as the source, but then it messed up other parts of the screen with the other subject being interviewed. Is there a way to mask off the key spill area to just on section of screen? Here’s a clip of the video: Microsoft OneDrive - Access files anywhere. Create docs with free Office Online.

Try the following 2 filters with the parameters shown below:

  1. Chroma Key: Advanced
  2. Key Spill: Advanced

Maybe change the parameters slightly:

Result (with a bt of tweaking you might get rid of the last few shades of green):

Wow, Chroma Key is behaving very differently for me than you. First, just with Chroma Key Advanced and your settings, the ladies are super transparent. Not a good starting point but let’s continue.


Then your key spill settings turned them crazy colors. I wasn’t able to get as green as you on the key spill, because I didn’t have that shade… but it did turn them a very interesting shade of purple!

I am running version 22.12.21. Having said that, I’ve gotten pretty close to getting rid of green, but then it turns the other ladies hair blonde in some parts also.

Hair is very difficult to chroma key. I doubt there is a perfect way to do it. But after many tries and errors, I ended with this method (sorry in advance for all the steps and screen captures):

1- Removing the green screen

I added a Chroma Key: Advanced filter
The best spot I found to pick the Key color is in this general area:

The color sampled by the color picker is: #0aa35e

I then played with the settings in the Chroma Key filter and settled on these:
MzJ5H2KkEx
Note that I used the Hue-Chroma-Intensity Color space

Result so far:

2- Removing the green spills

I added a Key Spill: Advanced filter.
Key Color is the same as in the Chroma key filter
I used black for the Target color. But honestly, I get the same results with any color I tried there.

Here are my other settings:
shotcut_AWNxPqdSLp

Giving me this result:

3- Feathering the pixelated edges

I added a Alpha Channel: Adjust filter on the Blur mode to make the edges less pixelated.

Settings:
shotcut_qvPFvdBJHd

Result

4- Trying to fix the problem in the dark hair.

There are some purple reflections in the hair of the woman on the right side.

I used two filters to hide this as best as I could:
First the Levels filter. I played with the Gamma slider to add contrast. I settled with a gamma value of 0.64

Result

But now the rest of the image is too saturated. So I added a Hue/Lightness/Saturation filter and lowered the Saturation value to 60 to fix this

Result

Here’s my final result:

It’s not perfect, but this is as best as I can get without spending more than half an hour on it.

Note: Most of the time, the order of the filters is quite important. Here’s the order of the filters I used:
shotcut_vgVNM55avQ

6 Likes

By the way, if you don’t absolutely need your subjects to fill the entire screen, you could add a Size, Position & Rotate filter at the bottom of the filters list to reduce and re-position your chromakeyed clip. This will help hide the imperfections.

Result

That’s pretty good. Key Color and target color are throwing me off. I’m assuming, like you are, that Key color should be the shade of the green that’s spilling over, and for target color, I am choosing a portion of her blond hair. But that doesn’t change the green to the blond. But it does seem to change everything else! If I pick her face as the target color, with your settings above, the face color changes, but the green stays green. And this filter is seriously changing the hue of her skin. Here’s with and without key spill… why would this change her skin tone so much?

Also, I got a more expected effect by using desaturate Operation instead of De-Key. It takes my Target color and tries to replace the Key color with it. I use the “Show Mask” function to figure out what area is going to be affected the filter.

Definitely still a work in progress, but I’m getting closer.

Please be aware when using the color picker that a single click will choose the color of that imprecise pixel you clicked. Instead, you can drag a small rectangle of the area to choose the average color of the pixels in that area.

1 Like


Here are the settings I used on your clip:-
Chroma Key Advanced
Hue-Chroma Intensity selected
Hue Delta 11.5
Chroma Delta 51.4
Intensity Delta 26.6
Shape Box
Edge Normal
Slope 0
Operation Overwrite
There is some green being reflected from the backcloth which is due to the subjects being slightly too close to it. I would suggest you back and/or side light the subjects in white. You could also use a background that has green in it so that they look natural, or use blue or grey as the chroma colour.

What lighting are you using? Could you add a back light to separate the speaker from the background better?

Could you add more light to the background to even the green lighting out?


I tried out the MusicalBox added filters, and they work well.
Key Spill: Advanced settings
Target colour Black
Mask type Colour Distance
Tolerance 26.6
Slope 99.1
Hue gate 10.8
Saturation threshold 0.0
Operation 1 Adjust Luma
Amount 1 52.0
Operation 2 None

Alpha Channel: Adjust settings
Amount 2.0

2 Likes