Choppy everything. Shortcut doesn't seem to be able to handle even a tiny load

Windows 10
Latest, 64bit

Shortcut can’t seem to handle anything on my computer.
It uses 16-20% of the CPU (Ryzen9 x3900) while running the edit window.
It uses about 20% of my ram (32gig)

It uses barely any memory or CPU while editing, but it’s enough to put one music track and one filter on some video to get everything choppy as heck, the sound becomes choppy, the clip moves choppily, it’s just impossible to work.
As soon as you add a music track this happens.
It’s impossible to do quick music-beat-matching video edits this way.

Actually it’s not just music, it’s the narration as well (I record it with OBS, so it’s an mkv file too)

Please help

Is it that I use mp3s for music?
I use mkv files for the video.

What to do

See the suggestions here:

I’m sorry to say this doesn’t help me. I don’t understand anything of what you said.

I just want it to run smooth. I have a new strong computer and I don’t understand why this program can’t put one mkv file and one mp3 file together without nearly crashing.

Can you explain to me carefully what needs to be done or point me at a tutorial for people who don’t understand all that stuff yo usaid like proxying preview scaling or whatever?

Also converting files always results in a loss of quality, and I’m already using MKV files as the source. Is there any particular setting for the source recording that would make it ‘edit friendly’ already, without having to process it further?

If your file is not edit-friendly (usually variable frame-rate, or GOP settings that are not good) Shotcut may struggle to seek and the playback in the source window may “stutter and lag”.

When you convert to edit friendly you are given the option of how much or little compression you want. If you want best quality then opt for “Best Quality”.

If you want to preview scaling goto Settings -> Preview Scaling then choose one of the resolutions that is lower than that of your video. If e.g. your video is 1080p and you choose 540p then the resolution in the preview window will be reduced by a factor of 4 which will help to keep the playback smooth.

Proxy editing means (automatically) converting all your video clips to a lower resolution and Shotcut manipulating these, then when you export it replaces the lower-res videos for the full-res ones.

Then You should LEARN about proxy and about the UI menus. :wink:

Give me a break. When I put a video and an mp3 on windows movie maker it doesn’t die like this.

That said I started turning all files into ‘edit friendly’. With, obviously, no improvement whatsoever.

And neither does Shotcut. You should just use something else if you are so unsatisfied.

I can show you if you want.

One music track, one voice-over track, one video. Nothing sped up or slowed down. A few quick cuts in the video.
It dies. I can video it on my phone if u like lol.

Go ahead.

I think what the community is trying to say is that this is not normal behavior for Shotcut, even on machines that are not as well specced out as yours. You’ll probably find that if you’re respectful and are able to respond with helpful questions, many people on here are willing to help you troubleshoot your problem. Investigate the resources they give you first, though. Shotcut doesn’t work like most other video editors.

Well I can’t understand what it is.
IF so there then there is an underlying bug that we could root out?
You are aware I’m not posting to irritate you personally but because I’m having a problem.
I had a problem before, which was pointed out and fixed, namely lots of pops and crackles in audio which were fixed in this version.

Maybe it’s that I use blank-graphics mkv files for audio?
Maybe it’s that my video clips are moderately high resolution and frame rate? (1080p 80+fps)

I use OBS to capture gameplay footage which I then edit in shortcut. I use OBS to record audio as well by turning off screen, so it’s all MKV files.

I have an AMD x3900 with very fast 32gig memory and only have very fast m4 SSDs for both OS and storage.
I do not know why this is happening but I liiterally cannot edit any rapid, intensive edits.

The worst of it is when adding even a simple text filter on a video clip, it can cause the whole program to stutter to death.

Only an idea: To much cores?
(Maybe you are able, for testing, to deactivate temporary 8 cores?)