Can't load custom presets

What is your operating system?
Windows 11

What is your Shotcut version (see Help > About Shotcut)? Is it 32-bit?
22.12.21, 64bit

Can you repeat the problem? If so, what are the steps?
fresh installation of Shotcut. I placed the custom presets I usually use into the “encode” folder. they display correctly in the menu but when I click on any of them nothing loads.
tried to create some new presets. after they are saved they also don’t load

I tested this on Windows 11 and it is working for me.

Here is the location that I save the custom export preset:

Can you post on of your preset files here so I can test it on my system?

Maybe this is related to this bug report?

I think unlikely because that other report (which I reproduced) is specific to the color parameter.

sure. no problem
here they are:

they are in a correct folder as I can see them in the “custom” presets menu, and I have done this before on my previous laptop and, as far as I remember, it worked :slight_smile:

Wetransfer requires login. Upload the zip here.

Strange, it worked for me without logging

Here’s the ZIP file. (1.7 KB)

These are opening OK for me

Also working for me. Shotcut 22.12.21. Windows 11.

Can you explain what you mean by “nothing loads”? Do you click the Advanced button to see the parameters?

probably it’s best just to show you :slight_smile:
here is the video. recorded with just a handheld phone so it’s a bit blurry, but you can clearly see that nothing from the presets is loaded when i click on them

hope it helps to determine the problem :slight_smile:

oh and yeah…weetrans should work fine with no account

You need to ensure you are checking exactly what Shotcut is using when checking your files. Use Settings > App Data Directory > Show to open Explorer to the area where the version of Shotcut you are running (could be different than what you think, a lot of people have multiple and do not realize it). Then, locate the preset file and make sure it is not blank or somehow invalid format. The rest of us were testing with the files you provided unedited. I guess something on your system could be blocking Shotcut from reading those files while still allowing them to be seen in a directory listing.

I’ve tried checking where the Shotcut App Data Directory is. It’s located on the correct space and all files are there as they should be. I’ve also tried changing the ADD but it seems that where ever I place it - Shotcut for some reason can’t read the preset files, although it can always see them.
As the last resort I’ve placed the ADD on my external SDD and then they are working correctly.
I think it’s ok to presume that something is blocking Shotcut from reading the files however I can’t pinpoint as to what it might be. If I ever find out - I’ll let you know :slight_smile:

Maybe there is a permission setting on the folder or files that limits Shotcut from reading the files.

I thought so too. So I asked my Admin to login and try the same - doesn’t work. Run Shotcut with administrator rights - nope. I’ve used Shotcut (portable version) before on laptops I don’t have the admin permissions without problems btw :slight_smile: I also tried to create the ADD folder somewhere I’m sure I have the rights to access with no success. By default the ADD is in my “windows-user” folder to which I should have the full access rights. And it’s the same thing everywhere - Shotcut can see the files but not read them. I’m guessing “something” is blocking it but I don’t know what yet :slight_smile:

Maybe as a test you could try it on another computer that is not under company policies.