Can't change duration and resolution of pictures

So I’m using the newest version, and now when I click on a picture, the duration is grayed out and I can’t click on it. When I clicked on the resolution, I can highlight it to change it, but whenever I try typing a number, it just goes to the playlist tab. Can someone help?

I wrote about changing picture/slide duration in this post: Can't change duration of a slide
I just tried all of the various ways to change the length and with version 18.08.14 they all work fine.

There has been a few releases this month, and you might be running 18.08.14, but it’s helpful for others to know, especially dev’s, to know the exact version you’re running.
The newest version is: 18.08.14 at the time of this posting, and can be downloaded here:

With 18.08.14, I get the same, although I have never tried changing the resolution at this location.

The resolution is not editble. These are read-only fields. If you were able to change the resolution, it would not accomplish anything. If you need to change the apparent size, then you need to use a filter such as Size and Position, Rotate and Scale, or Crop.