Can't Add Videos to Playlist Since the Update to version 18.12.23

I have been having issues adding videos and pictures to playlist since the recent update. Does anyone know how to fix this? Thanks

What recent update? Need Shotcut version number.
Computer specifications?
Operating system?


No one else has reported a problem. There are multiple ways to add; explain the ways you have tried. Is this only for an existing project or does it also happen in a new project or clean session?

It is a new problem to me. Typically, I just drag the video file across to the play list. But now I have lost my play list. I am in the process of uninstalling and reinstalling shotcut to see if that helps.

What does that mean? Did you try clicking Playlist on the main toolbar to re-open it?

I am having loads of issues with it. The play list was normally displayed in tabs on my screen next to filters etc, then it just vanished. I have tried to uninstall and reinstall shotcut, but still getting the same issues.

As you can see on the left screen, the layout has changed. Normally, on the left hand side I have filters, playlists and properties. Now all I have is filters.

I cannot explain why your Playlist window is not there; you may have accidentally closed it or you chose something from the View > Layout menu.
What part of “clicking Playlist on the main toolbar” do you not understand?

I have now been able to get the tabs back, as you can see. But, When I open a vide (as it wont let me drag and drop any more) it does not show up in play list.

Videos are not automatically added to the Playlist unless you drag-n-drop multiple videos from Explorer into Shotcut or drag a single video from Explorer directly to the Playlist panel. Otherwise, the video opens only in the Source player until you add it to Playlist or Timeline . It is not even necessary to use Playlist in order to use the Timeline.

Thank you for your explanation. I will carry on as I normally would.

Click on the source tab, then drag from viewer window to your playlist.

In your picture, you already added a video to the timeline. Shotcut switches to the Project tab automatically when you a video/picture to the timeline.

Now it wont convert videos I have edited to MP4

Rename the file to have .mp4 on the end of the filename. Shotcut does this automatically if you are using the default export settings or a preset. However, this tells me you have ventured into the Advanced section of Export, and you obviously have very little knowledge or experience in this area and probably should not be in there. I strongly recommend you purchase this video tutorial course.

I thought that maybe I had somehow gone into the advanced settings, but I have done what I have been doing since I downloaded the software months ago. Please see screen shots to see what I am doing. It is simply not saving as an MP4 file.

Wow. I told you “.mp4” not “(space)MP4”. It is an MP4, but Windows is too stupid to understand that without “.mp4” on the end. The save dalog even suggests that by prefilling the File name with that. In your screenshot you must have cleared it. If you had bothered to open the export file in Shotcut, you would see that it is a playable file.
The automatic “.mp4” extension mechanism is failing because you are using a period in your filename but a period is also the extension separator. This is intentional to allow people to override the extension. For example, some people prefer .m4v.

If you look at the file type, it won’t let me select mp4. I named it mp4 as I have three files on there currently. I have not cleared anything, the steps I have shown you is what I always do. I have never had an issue prior to this.