Cannot scroll timeline horizontally with mouse wheel on Linux

What is your operating system?

  • Fedora Linux 37 (Workstation Edition)
  • GNOME 43.2
  • using X11

What is your Shotcut version (see Help > About Shotcut)? Is it 32-bit?

  • Shotcut 22.12.21
  • Obtained from Flathub
  • I don’t see 32 or 64 bits in the About windows so I don’t know

Can you repeat the problem? If so, what are the steps?
Cannot scroll the timeline horizontally using the mouse wheel

  • Using the mousewheel only → scrolls the timeline section vertically.
  • Ctrl+mouse wheel →Zoom
  • Shift+mouse wheel → Vertical zoom
  • Alt + mouse wheel → Vertical scroll
  • Super key (Windows key on PC keyboard or Command key on mac keyboard) → Horizontal scroll

Unfortunately, the Super key is used by GNOME to open the Dash, so every time I scroll horizontally using the Super key, my Dash opens, which is very annoying.

Is there a way to remap the modifier keyboard keys to use with the mouse wheel?

mouse wheel over the timeline scrolls horizontally

The shortcuts are in Help, actions and shortcuts, but I don’t think I have an option to change that shortcut.

I think the Qt behavior for this changed in version 5.15 on Linux (and macOS). This is fixed for the next version of Shotcut. Mouse behaviors are not modifiable unless you know how to modify some QML/JavaScript code or even can (i.e. not Flatpak, AppImage, or Mac .app) - share/shotcut/qml/views/timeline/Timeline.js in this case.

1 Like

When can we expect the next version to be released?