Cannot scroll horizontally on timeline

What is your operating system?

Manjaro Linux

What is your Shotcut version (see Help > About Shotcut)? Is it 32-bit?


Can you repeat the problem? If so, what are the steps?
(Please be specific and use the names as seen in Shotcut, preferably English. Include a screenshot or screen recording if you can. Also, you can attach logs from either View > Application Log or right-click a job and choose View Log.)

The timeline is able to scroll left and right with the mouse wheel scroll. It only scrolls up and down, like it is vertically locked. I am on Linux so I didn’t think the caveat was with my keyboard.

I was hesitant to post it here because this happens with all the versions listed above, and I know that before the latest update of my OS, it was working just fine.

I’ve tried with ALT and without ALT and it continues to only scroll up and down on the timeline. However, when I do CTRL+ALT, it does scroll anywhere at all (vertically or horizontally).

I’ve also checked the application log, and there doesn’t seem to be anything in there in regards to scrolling. Is there anywhere else I can look to figure this out?

FWIW, I also tried with the flatpak version, and the behavior persisted.

EDIT: Also, I am able to reproduce this on my X1Carbon thinkpad. Using the trackpad, I can scroll horizontally, but using a mouse, I am unable to.

Hi @andrewcz

There is a contradiction in this part:

Maybe what you meant to say is:

The timeline should be able to scroll left and right with the mouse wheel scroll. But on my computer, It only scrolls up and down, like it is vertically locked.

I don’t have a solution, but for the record, on my Windows PC, with Shotcut v21.09.20, the shortcuts works as expected

Mouse wheel = Timeline scrolls left to right
Mouse wheel + ALT = Timeline scrolls Up and Down
Mouse wheel + Ctrl = Timeline zoom +/-
Mouse wheel + Shift = Increase/decrease tracks height

I get the same behavior as @MusicalBox running on Ubuntu 21.04.

It works for me on Ubuntu 20.04 using any build including Flatpak. Outside of Flatpak are you using a build provided by us or based on our build?

@shotcut The build is here: Arch Linux - shotcut 21.08.29-1 (x86_64)

@MusicalBox yes, sorry for that mistake. That was what I intended to say.

Having additionally posted in Manjaro’s update thread, I found this from the a fellow user:

Shotcut user here, I noticed this as well. Some experimentation and I figured out that you now need to hold down the Windows key to make the mouse wheel scroll the timeline forwards & backwards.

[Stable Update] 2021-10-08 - Kernels, Mesa, Browsers, Python, UKUI, PHP, Thunderbird, Pipewire - #59 by WadeMasshardt - Stable Updates - Manjaro Linux Forum

I can confirm that by using the Windows key, I can also make the mouse whell scroll the timeline forwards and backwards.

Additionally, since one of my keyboards is programmable, I decided to assign one of the buttons to the MacOS “Command” key in firmware. This allows for the same scrolling forwards and backwards functionality.

So, at least for this specific configuration, the Windows/Command key caveat (mentioned in the docs) is required on Manjaro Linux (possibly Arch and other derivatives as well.)

1 Like

Hiya, I’m also affected by this since upgrading Ubuntu from 21.04 to 22.04 - scroll wheel is now vertical, but was horizontal before.
Using the same shotcut 220130 app image (x86_64) as prior to the upgrade.
@andrewcz’s workaround using Windows key also works for me to scroll the timeline horizontally.

1 Like

Just to throw it in here, I also see this with Kubuntu 22.04 using Shotcut 22.10.22.

Has the same issue on Linux Mint 21.1 using Shotcut 22.12.21.

I see this as well on Mint 21.1 with Shotcut 22.12.21.

I have the same issue with CachyOS (Arch Linux with KDE Plasma 5.27.4) and Shotcut 22.12.21, although pressing the “Windows”-Key while scrolling works

Updated Shotcut to 23.05.07, now it works again

1 Like