Can NOT get rid of side black bars (letterbox)

I am creating a video from a set of stills with audio overlayed to create a video to upload to Tiktok. These are stills that I created from the same background picture, they are the exact same dimensions, 1920X1080 (which is the standard for TikTok videos). I created them in GIMP, adding text and layers to the same base every time, exporting the image, then deleting the layers except for the base layer, and adding in new text/color layers for each new still. I have also manually verified that they all have the same exact dimensions.

When I export the finished video in Shotcut using no filters and default/standard settings, I get black bars on the left and right.

I have looked through these forums and have tried the following, both by themselves and together:

-Settings>video>automatic both before I even added files to the timeline and after editing but before exporting
-Size, position and rotate filter with position set at 0,0; size same as the still clips size (1920X1080); size mode set to fill, horizontal fit set to center, and vertical fit set to middle
-Crop: Rectangle filter with manually adjusting the white rectangle to match the placement of the clips in the Shotcut player (end up with the following settings: Postion 640,0; Size 640X1080)
-Under advanced export options (H.264 main profile selected) with the following video settings: resolution 1920X1080, aspect ratio 16X19, frames/sec 24, scan mode progressive, field order none, deinterlacer YADIF - temporal + spatial (best), interpolation Bilinear (good).

And I still get black bars every time - when I play the video in the Shotcut player, when I play the exported video in vlc media player, and when I try to upload the video to Tiktok. It’s driving me crazy, I’ve been working on this one single, 1-minute video for 5 days now, trying to get rid of these black bars.

I have tried sending the exported video to my phone to edit it in the app InShot, which has a setting to optimize it for Tiktok (16:9 ratio) and that does remove the bars, but it places a large watermark on the video which is unwanted.

Does Shotcut just automatically add the black bars back in when you export, or am I doing something I shouldn’t here?

For completeness, I am using Shotcut on a computer running Linux Mint Cinnamon 4.0.10.

Any help would be greatly appreciated.

The ideal resolution TikTok videos is not 1920x1080 (landscape), it is 1080x1920 (portrait). So you are taking a landscape photo, cropping it to portrait then exporting it as landscape, which is why you have black bars at the side.

See here for how to create Portrait videos (for TikTok):

I think there’s some confusion here. The base image I’m using for clips is 1080 across and 1980 tall, which is, indeed, portrait. My apologies if I made you think otherwise; I was copying off the automatically detected dimensions in Shotcut when I wrote the original post, the default which supposedly matches the dimensions of the clips in the video.

And yet, still, black bars on each side.

I just did a quick edit of just the base with the audio overlayed, and it did the same thing, except now it’s black on the top and bottom, too. Even when I go into advanced and switch the positioning of the 1080 and 1920, and the 16 and 9 (aspect ratio), in case Shotcut is being wacky and flipping them on its own.

Video and image sizes are always specified width x height, so portrait is 1080 x 1980 (9:16) and landscape is 1980 x 1029 (16:9). If Shotcut is reporting that the image is 1029 x 1980 (16:9), but the image is portrait, then it could be the jpeg image orientation flag is causing the confusion.

You need to set your video mode to portrait and not “automatic” before opening the first image. See the post I mentioned in my earlier clip, you will probably have to use the “Crop:Source” filter too (or maybe not) (again see the post)

Well here’s what finally worked: setting the video mode to “Vertical HD 30fps” (and also “Vertical HD 60fps”) under “Non Broadcast” which was your first recommendation to user High Format in the other thread you linked.

Which would logically mean that if a user selects “automatic” under video mode, which is supposed to automatically detect dimensions, Shotcut is flipping the dimensions to make it 1920X1080 even with a 1080X1920 clip/still, and adding the black bars. Either because, as you said, the jpeg orientation flag is messed up, or Shotcut is being wacky. Either way, this could be why the forums are getting so many requests for help with getting rid of the black bars. :slight_smile:

I did look at the base image properties in GIMP, this was a photo originally taken in portrait mode with my android phone camera, and the orientation shows “right-top.” (There’s not really a “portrait” setting in GIMP to my knowledge.)

Normally a JPEG image in the correct orientation (1) would be Top-Left. Right-Top is orientation number 6, Maybe this is why Shotcut is getting confused. Or maybe GIMP is not updating the info correctly. See below for an explanation “orientation”.

The orientation of the camera relative to the scene, when the image was captured - the relation of the '0th row' and '0th column' to visual position is shown as below.

Value	0th Row	    0th Column
1	    top	        left side
2	    top	        right side
3	    bottom	    right side
4	    bottom      left side
5	    left side   top
6	    right side	top
7	    right side	bottom
8	    left side	bottom

Entry #6 in the table says that the 0th row in the stored image is the right side of the captured scene, and the 0th column in the stored image is the top side of the captured scene.
Here is another description given by Adam M. Costello:

For convenience, here is what the letter F would look like if it were tagged correctly and displayed by a program that ignores the orientation tag (thus showing the stored image):

  1        2       3      4         5            6           7          8

888888  888888      88  88      8888888888  88                  88  8888888888
88          88      88  88      88  88      88  88          88  88      88  88
8888      8888    8888  8888    88          8888888888  8888888888          88
88          88      88  88
88          88  888888  888888

If you look at the file statistics (e.g. in Winows File Explorer), I presume it says the JPEG image is 1980 x 1020, i.e. Landscape mode, but the EXIF data has the “orientation flag” set to 6, saying you rotated the camera 90 degrees counter-clockwise when you took the picture (portrait mode). So I suspect Shotcut sees the 1980 x 1020 property and says “Landscape”, and so in “automatic” mode sets up a landscape project, but correctly interprets the orientation flag when it comes to manipulating and displaying the pixels.

Perhaps Shotcut’s main developer @shotcut can confirm this.

So I ran some tests this morning. I sent an image I took in portrait mode from my camera to my laptop via Gmail, did NOT open it in GIMP, but immediately did a test video, with video mode on automatic, with it in Shotcut. Then I repeated the test with an image (presumably) taken in portrait mode with an android phone found here: , specific image:

Then I repeated these tests with Shotcut while booted into Windows 10 instead of Linux Mint (I’m dual booted on this laptop).

I also opened both images in Pix (while booted into Linux Mint) to check and sure enough, the images are showing 3024X4032 and 960X1280 respectively, which are both portrait mode. Looking at the properties of both images in Pix does not give orientation data.

Every single Shotcut video creation test with video mode set to automatic ended up with black bars on the left and right of the image, and the height and width figures reversed when going into the advanced export settings: 4032X3024 and 1280X960, respectively.

After performing the above tests, I made copies of each image and opened the copies in GIMP to check the properties to see the listed orientation; the one I downloaded from android authority does not show the orientation, while the image I took with my phone shows six EXIF orientations: top-left, right-top, top-left, right-top, top-left, right-top.

This does not sound like a GIMP problem to me, or even a Linux Mint problem, but rather a Shotcut programming issue; for some reason, it’s taking an image that was shot in portrait mode with portrait mode dimensions and when the video mode is set to automatic, it’s flipping the dimensions and adding black bars.

As noted above, setting the video mode to “Vertical HD 30fps” (and also “Vertical HD 60fps”) under “Non Broadcast” seems to fix the issue, but since the “automatic” video mode seems to be the default, hopefully the Shotcut developers/programmers can address this in a future update.

I just realised that “Automatic” only works for VIDEO files not IMAGES/AUDIO files.

Shotcut states:

Next test: stitch two source videos downloaded from the same TikTok user (someone I follow)(using the downloader at, both shot in portrait mode using the same phone (and she shoots and uploads only videos shot on her phone in portrait mode), both displayed on TikTok and in vlc media full-screen/no black bars, using video mode automatic, and remember the TikTok ideal/standard resolution is 1080x1920 (portrait).

Black bars showing on the left and right in the exported finished video in the Shotcut player, vlc media player, and when I try to upload it to TikTok, and when I went into the advanced settings on export video, it showed the dimensions once again flipped to 1920x1080 (landscape).

This would be an easy test for anyone to reproduce, btw.

Again, this seems to be a Shotcut programming issue, and it’s affecting videos created from video-only source files as well as videos created from image/audio source files.

I don’t see this. I open a video (Automatic) in Shotcut that I have downloaded from TikTok using the downloader you linked to. Shotcut shows it correctly as 9:16 aspect ratio (Portrait). If I then export it it creates a video in Portrait mode. If I watch this using VLC it has black bars at the side, since my tablet is in landscape mode. If I rotate my tablet into Portrait mode there are no black bars, none at the sides, none at the top.

Mediainfo shows that the exported file is in 9:16 aspect ration:

Well, it’s happening for me. I tested videos from a different TikTok user this time, doing a stitch with two of his videos, same result. Tried a non-edit export of his first video, same result.

First video media specs:

Second video media specs:

Stitched video media specs:

(What’s interesting with the stitched video edit is it’s still showing top left orientation on the media specs in vlc, but landscape dimensions.)

Export settings under advanced for the stitched video:

I also did the same tests in Shotcut in Windows 10, same exact result.

I also verified that I’m using Shotcut version 21.03.21 in both Linux Mint and Windows 10, which is the latest version available on the Shotcut download page.

Are you using the Settings choice for vertical cellphone videos?

If not, try it.

Perhaps it will solve your difficulty.

As previously mentioned twice, yes, the Vertical HD 30 fps does seem to work. This is why I marked my first mention of it working as the solution to the thread.

However, that doesn’t change that the automatic setting is taking a portrait video and turning it into a landscape video, which is probably why there’s so many posts about black bars in the forums.

1 Like

I don’t know what to say. I have created 5 projects using the “Automatic” project setting and 5 different Portrait videos (1 from TikTok, 1 from my camera, 1 from an Android phone and 2 others downloaded from various websites. Each time Shotcut detected that they were “Portrait” videos and created a Portrait project. The video that Shotcut exported was in Portrait format. Perhaps @Shotcut has some ideas of what is happening in your case.

It works for me in Shotcut 21.03.21 on macOS, Windows, and Linux AppImage, portable, Snap, and Flatpak. I test dragging to Source, Playlist, and Timeline which are all different drop targets. They all work for me. In your latest test, I suspect you did not start with Automatic Video Mode and a new project or session. Simply removing all the files does not reset the project. You need either to choose New, Close, or restart and then check if Video Mode is Automatic. If you say you are using Linux it is not clear what build or package you are using. Getting something from a package or software manager is very uncertain what you are getting including possibly a build not made or supported by us.

I did, indeed, start with setting the test projects to Automatic Video mode (and verifying the setting after project start, and restarting Shotcut and creating a new project for each test) before adding any files for all of the tests I’ve performed. I just redid the test with a single-video, no-edit export today, under a new project, it did the same exact thing.

For both Linux Mint (Cinnamon 19.1 version 4.0.10) and Windows 10, I downloaded the package(GitHub source)/file via the link from/directly from this website under “downloads.” Here is the “about Shotcut” screen on the Linux side:

(I also have Openshot, Lightworks and Kdenlive installed, because in the five days I was trying to create my TikTok video, I was trying various editors. I know one of them was installed via the package installer, but I can’t remember which one. I will say, Shotcut beats all the others. I also have Audacity installed.)

Here is my Linux system info, I have a Dell Inspiron 15 3000 laptop (3 years old) dual-booted with both Linux Mint and Windows 10 (but I usually boot into Linux because Win 10 is such a PITA, but I’m dual-booted for the few things I can’t do in Linux) with one 8GB RAM stick that came with the laptop, and one aftermarket 8GB stick (Crucial brand) that I installed myself late 2020 (the installation of which killed my optic drive, but that’s a common problem due to Dell’s poor design of the Inspiron 15 3000, and I don’t think that’s related to the issue with Shotcut):

I also did the previous tests with files stored on a 1TB WD passport external hard drive that I keep plugged into one of my USB ports; I just redid the no-edit export test (with a new project) after copying the source file to my laptop’s hard drive in Linux though, still the same result.

It may be that something else I have installed is interfering, either with the install of Shotcut (seems more likely to me), or the operation of it; I have quite a few other programs installed in both Linux and Windows though, so it may take some doing tracking down which one. Or it could be some OS graphics setting I’m unaware of, although it would be weird that it’s happening in both Linux and Windows. Perhaps the graphics card itself? Or some other glitch with my particular system, although there’s enough posts on the forums that it would be weird we’re all having the same system glitch.

I’m not a professional programmer, but I do have a bachelor’s degree in computers, so I’m not an ignorant newbie either, but my focus was in networking and security, not programming (but did have a few classes in it).

I will repeat, though, setting the video mode to “Vertical HD 30 fps” under “non-Broadcast,” which is the solution Elusien offered in another thread (also about the black bars) that he linked to in this thread, fixes the black bars/dimensions/orientation, and is a good work-around.

I should note as well that when I went back to my original project (after seeing that work-around succeed in one of my tests), which had been started in the Automatic Video Mode, and changed the video mode to Vertical HD 30fps, not only did it reset the project/change the output dimensions to the dimensions of the source files (from 1920X1080 to 1080X1920), but I could see the reset in action in the timeline as it got adjusted, it was like a ripple effect.

I also made a different video edit yesterday (after I finally got my TikTok video exported with the correct settings) under a new project with source files that are in landscape orientation, and Automatic Video Mode successfully detected the correct dimensions/orientation. It’s very bizarre.

But again, there is a workaround for portrait videos, which I will be using from now on for my TikTok videos (thanks Elusien!). Just wanted to make sure y’all were aware of the issue with Automatic Video mode.

This topic was automatically closed after 90 days. New replies are no longer allowed.