Can anyone please help me with why shotcut is constantly crashing

Dan said to use an SDK version or something because that’s the only way to get proper crash reports but I have no idea what that means or how to do it, or how to then get the crash reports.
Can anyone help? I’m the least technical person in my chair.

Shotcut is crashing on pretty much every 5th time I try to drag something on the timeline so it’s pretty annoying and kind of urgent :confused:

I have a great computer, radeon 7900x with 64 gigs of ram and windows 11.
I use almost only sped-up clips in my videos which might be an issue, I don’t know.

Having the same issue sadly, you should be able to find more information here about the log: Shortcut keeps crashing where can I get the crash log? - #4 by brian

1 Like

Sorry, looked, not useful or helpful whatsoever.

There’s nothing there about the kind of crashes I have, and the reply there just says what I said - there’s no way to get crash reports without going through some weird loops that nobody seems to know how to do or wants to help with.

So I wonder if they ever even get crash reports lol :stuck_out_tongue:

I know you are asking for a “crash report”. But would you be willing to upload the “application log”? Maybe there is a hint in there that we can work from. It would be better than nothing, I think.

Yessir!!! I’d do anything!

ALSO, for the first time ever with one of the same type of crash, I got this:

Hopefully it’s meaningful!
shotcut-log.txt (41.6 KB)

Also attached is the application log,

And ALSO, I found a directory full of “shot cut crash dumps”, whatever that might be.
Would that help? (Usually it just stalls, white-outs, then terminates with no message)

I’m at my wits end trying to figure this out, and shotcut is, as I said, crashing about every 5th time I drag something on the timeline.

EDIT: HERE’S A LOG FROM RIGHT AFTER A CRASH (I didn’t restart shotcut, got the log straight away)

shotcut-log.txt (126.8 KB)

That indicates that a null pointer was dereferenced. So that actually is a small clue.

I would suggest this:

  1. Delete all the files in that directory
  2. Cause a fresh crash
  3. upload the shotcut.exe.dmp and shotcut-log.txt files

Nice. From the log, it looks like the last action was a “lift” on the timeline. and they maybe you started playing again and it crashed? I know it can be hard to remember when you are “in the flow” of editing. But if you can, try to remember exactly the steps that led to the crash.

The crashes happen when dragging and placing a clip on the timeline. Immediately upon placing the clip. There’s no time to perform further actions.

I unfortunately can’t upload the crash dump because it is 52MB which crosses the maximum for this forum

This is a fairly common operation that is working well for me and many other users. There must be something unique about either your computer or your source clips. If your computer is unique to this problem, it would be hard for me to recreate. If your source clips are unique to this problem, we may be able to narrow it down.

As a test, could you find some clips from a completely different source and try to test your common operations? Does it still crash with files from a different source?

If we think the source files might be unique to the problem, maybe you can make a bare minimum project that demonstrates the problem. For example, make a project file that uses on small source clip and then demonstrate an operation that causes the crash. Zip up the small project and share it with me privately using google drive or some other file sharing service.

I tried replicating it at this scale, and it just never happens
(using all sped up clips, and the same filters I use in every project)

But when my projects start looking like this:

Shotcut crashes every 2 to 5 operations.

I can upload this pretty fast with my new internet but I can’t think of anywhere I can upload 50 gigs worth of project files to.

Would sending the crash dumps be of any use?

Also, I have to add that it never used to be like this. This is as of maybe 4-5 versions of shortcut ago. I never even had a crash before that. Same computer, same everything.

Yes. PM a link where I can download it.

Maybe you want to keep using an older version.

I’ve sent the appropriate files privately.

I would not like to revert to older versions if this is at all possible to fix :slight_smile:
Definitely not in the middle of a large project.
But after that, well, still, hope it can be isolated and fixed.

Thanks for sending the files. The data indicates that a null pointer exception occurred in the Qt6Core library. That is the library Shotcut uses for the user interface. Unfortunately, it does not provide a trace of what function calls lead to the crash. So this is a dead end.

I think your best options are to use an older version that previously worked for you, or breaky your project down into smaller projects and then combined them when you are done.

Well then…
If I find some way to show the logs to the ppl who make QT6 do you think they could fix it?
I mean, is it something in QT6 or something in the implementation that you guys could fix for the next version of shotcut?

Also, do, er, remember at which version of shotcut you switched to the version of QT6 that causes the crash?

And also thank you! :slight_smile:

The crash is in the QT library, but that does not mean QT caused the crash. Maybe the crash is caused by some way that Shotcut is using QT. I do not think it would be helpful to report the problem to QT.

Here is the last version that used QT5:

Can I post in someone else’s topic, to not create additional?

My shotcut is crashing while encoding video for some reason. I can’t determine, what is the reason. This is the last lines from shotcut-log.txt:

[Debug  ] <Util::warnIfLowDiskSpace> 17786180050944 bytes available on "share" 
[Debug  ] <MeltJob::start> "C:/Program Files/Shotcut/melt -verbose -progress2 -abort xml:C%3A%2FUsers%2Fnazza%2FAppData%2FLocal%2FTemp%2Fshotcut-JzBdcd.mlt" 
[Info   ] <Util::isMemoryLow> available RAM =  12324776 KB 
[Info   ] <Util::isMemoryLow> available RAM =  11472988 KB 
[Info   ] <Util::isMemoryLow> available RAM =  10738624 KB 
[Info   ] <Util::isMemoryLow> available RAM =  9887304 KB 
[Info   ] <Util::isMemoryLow> available RAM =  9149684 KB 
[Info   ] <Util::isMemoryLow> available RAM =  8345308 KB 
[Info   ] <Util::isMemoryLow> available RAM =  7630464 KB 
[Info   ] <Util::isMemoryLow> available RAM =  6952876 KB 
[Info   ] <Util::isMemoryLow> available RAM =  6279608 KB 
[Info   ] <Util::isMemoryLow> available RAM =  5598564 KB 
[Info   ] <Util::isMemoryLow> available RAM =  4899808 KB 
[Info   ] <Util::isMemoryLow> available RAM =  4128636 KB 
[Info   ] <Util::isMemoryLow> available RAM =  3463912 KB 
[Info   ] <Util::isMemoryLow> available RAM =  4066284 KB 
[Info   ] <Util::isMemoryLow> available RAM =  3287676 KB 
[Info   ] <Util::isMemoryLow> available RAM =  2490884 KB 
[Info   ] <Util::isMemoryLow> available RAM =  1721464 KB 
[Info   ] <Util::isMemoryLow> available RAM =  968936 KB 
[Info   ] <Util::isMemoryLow> available RAM =  628392 KB 
[Info   ] <Util::isMemoryLow> available RAM =  592600 KB 
[Info   ] <Util::isMemoryLow> available RAM =  693968 KB 
[Info   ] <Util::isMemoryLow> available RAM =  663900 KB 
[Info   ] <Util::isMemoryLow> available RAM =  641616 KB 
[Info   ] <Util::isMemoryLow> available RAM =  556000 KB 
[Info   ] <Util::isMemoryLow> available RAM =  583528 KB 
[Info   ] <Util::isMemoryLow> available RAM =  543748 KB 
[Info   ] <Util::isMemoryLow> available RAM =  660496 KB 
[Info   ] <EncodeJob::onFinished> job failed with -1073741819 
[Info   ] <AbstractJob::onFinished> job failed with -1073741819 
[Info   ] <Util::isMemoryLow> available RAM =  763012 KB 

That is really tight on RAM. This project is likely asking more of your hardware than it is able to do.

This is a very common problem that is unrelated to the problem in this thread. It can be caused by many things. More information about that specific exit code can be found here:

I’ve got 32GB, and it is not even the biggest project I’ve done. Strange.

  1. Download SDK from Shotcut - How To Use the Windows SDK
  2. After extracting, find shotcut.exe and double-click to run it.
  3. Use Shotcut until it crashes.
  4. Find shotcut.RPT in the same folder as shotcut.exe and upload it here as an attachment in a reply.



1 Like

Turns out one of videos in this project was corrupted. I have cut non-corrupted pieces of it separately, and put them back into project, works fine.

Thank you!

Just to know, is this being looked at in any way for the next release or is it something that you aren’t intending to look at for now?
Not what nazzar wrote, but the original issue.

Because if you’re looking into it I can share more specific information probably on when it happens or not and help test

I will work on an old version but you know, the new features are great too.

1 Like