Bug report with transparency


#1

I’m pointing out what I believe could be a bug with transparency.

Sometimes, transparent images are displayed with a black instead of transparent background.
This is happens with both .png and .svg created with Inkscape and/or Gimp.
I tested images posted by users on this forum in similar topics, but same results.
The problem doesn’t happen on all projects though as the very same image is displayed as trasparent on a new project but not on the one I am working - and where I need it.
It looks like at some point a given project starts acting up and forgets about transparency. Not sure it may have to do with size of project, number of clips in it, filters etc.
It doesn’t seem to be a problem on new small test projects, but I edited some large ones (larger than the one I am working on) without incurring in the problem.

Rebuilding the project from scratch is out of the question when this involves several hours work.
A viable workaround, although time consuming and certainly not the best as far as final quality of the video, consists in exporting the project into a video file (such as an MP4) and then reingesting it in a new project in order to add the trasparent image (which happens to be nothing but a watermark).
It’s frustrating having to render a whole project just to add a watermark but that seems to be the only thing I can think of.

I’m on an I3 6, gig Ram running Ubuntu 14:04 and Xubuntu 14.04. Switching between the two desktop managers doesn’t solve the problem, so the Unity Desktop Manager is not the culprit.

Hope this helps improve the software.


#2

Have you checked the status of composite buttons (on each video track)? These buttons disable compositing and afterwards transparency doesnt work.


#3

I’ve been having this issue myself. In fact, I’m having it at this moment, while working on a video. I’m having to export part, so that I can try and re-insert it where needed and place it in the right space (video in video). But I could have one (video) track appear, the transparent png layer wouldn’t appear, nor would the video that goes inside the background video.


#4

Thank you! The only real solution to this problem.


#5

the composite button does nothing


#6

Click on “Project”.
You’re only viewing the Source “transparent.png”.
source%201 source%202 source%203


#7

The problem is that V1 has compositing enabled but it should not be. I tried to coerce this to off for old projects, but maybe there is a problem there. Open your .mlt in a text editor. Search for “transition1” with a child element <property name="disable">0</property>. Change the 0 value to a 1. save and reopen in shotcut. Verify the state of the composite button on V1; it should look like multiple stacked layers.