Bug? Or user error? Still Frames Not Keeping Their Filter Settings

Windows 10

Shotcut version: 22.01.30

The problem is random so I cannot repeat it.
(I have downloaded the latest version. Things are better but I still have problems.)

(1) I have a frame that jumps right after a dissolve. I’ve fixed it 14 times at least (no really) and while it is gone in the editor, it returns somehow in the exporting process. I have been working 10 to 14 hour days for four days on one 3 minute chapter and every time I fix something in the editor I find it’s back or a similar problem has ocurred in the exported MP4.

(2) Also, I am working with some still frames. They have movement effects, either position movements or scale changes. If I blend them together (simple dissolve) one or both still frame’s filters will change, sometimes drastically. No matter how many times I fix it it comes back in one form or another. In desperation I’ve gotten rid of the the dissolves but now one of the still frames is scaling wrong. The resolution in this MLT is set at 1280 x 720 by default even though the first clip is a 1920 x 1080 video. I’ve been changing it to 1920 x 1080. Is this the cause of my messed up still frames? If so, how do I keep my 1920 x 1080 resolution without messing up the still frames?

App Log.txt (36.3 KB)

Step 1 with any project is to set the Video Mode before opening up any files in Shotcut.

After you have filters set in one video mode then change your video mode the filters do not auto-adjust. You have to adjust each filter/keyframe to the new video mode.

Example: Started with a 720p video mode.
Applied 1 filter for size/position of the 640x640 image.

Changed video mode to 1080p.

This is what happens when you change video modes after you set filters.
This is not a bug.

If the frame rate happened to change from the default of 25 to something else like 29.97, then it’s possible to get gaps between clips too. Changing the Video Mode halfway into a project can cause some very unpredictable and unpleasant problems.

1 Like

I’ve changed the messed up filters and other things dozens of times. They still keep moving. But I will remember to make sure that I set the right video mode at the beginning and not to change it. Thanks.

I wonder if your clip could be variable frame rate. Can you provide a screenshot of your Shotcut window with the Properties panel showing for one of your video clips?

My screen doesn’t show all of properties at once. There is a scroll bar. Can you tell me what you are looking for? Thanks.

Can you show this with video?

Maybe just screenshot as much as you can.

Here is everything that you would see if you were sitting here looking at my properties.

Codec: H.264 / AVC / MPEG-4 AVC / MPEG-4 part 10

Resolution: 1920x1080

Frame rate: 59.940060

Format yuvj420p

Color space: ITU-R BT.709

Color transfer: ITU-R BT.709

16:9 Scan mode = progressive

Those properties look normal. Sometimes when we see a screenshot, we notice something that we did not think to ask about. Your description of still frames and dissolves is not perfectly clear. So we have to use our imagination to guess what your project might be doing. Nobody else is reporting this problem and we don’t have much to go on. You have not reported back what you have set your video mode set to. And you have not explained if experience the problem if you disable preview scaling and proxies. Unfortunately, I am out of ideas.

To keep moving, I suggest to post some screenshots or screen recordings and some videos to demonstrate the problem you are having.

I’m new to editing and to Shotcut, but from what I can tell from comments here and my own experiences, all of this was due to me inadvertently changing Video Mode mid-stream. I have four chapters, two of them giving me problems while the other two did not. After eight days and a combined total of 60+ hours of work I have finally managed to export my 3 minute chapter without any errors. I will definitely be choosing my Video Mode at the start of each project and not changing it from now on. :slight_smile:

I do not know if you have done this already, but my advice to all new users is to spend some time with the tutorial videos:


1 hour of watching tutorials could save a new user hours of frustration by learning from “trial and error”.

I’m glad you were able to successfully complete your project!