Blur disappears when exported

Hey guys, I need some help as I’m not able to figure it out myself. I am editing a lecture and I’m supposed to split it into several individual clips. More or less in every clip there are some parts I need to blur out. I export the clips using the export each playlist item feature. I use the Blur: box filter ( I’m using key frames to blur out the whole screen).
I apply the filter for the first clip and add it to the playlist, then I split the video and make clip no. 2. I add the second blur filter, but when exported only the firs clip has the blur… While I’m in Shotcut everything looks fine, but when exported it just disappears. If I have more then one blur in the first clip it also works fine, but just for the first clip. Sometimes I have as much as 10 clips per lecture and it can get time consuming to load and export the clips separately just to add the blur again. I haven’t seen that anyone had this problem so I’m thinking I’m doing something wrong. Please help. Thank you!

What’s the version of Shotcut?

Thanks for replying! It is Shotcut version 21.10.31

It’s working fine on my side (Win10). Did you select the 2nd clip?

From what i understand, you have a long clip and cut it into several clips is that so? If yes, can you split it first then apply the filter individually, will it save properly?

Yes, also using Win10.

Yes that’s right. I tried that, it’s the same, it just blurs the first one…

Here is the link to my screen recording so you can see what I am doing…

I’ve tried with several of my clips and all 4 clips exported as blury. When you insstalled SC, do you have an older version of SC? If yes, did you tick the box about removing the registry setting (cant remember the right instruction)? Have you restarted your PC? Other than that, it’s beyond my knowledge.

No, I didn’t have an older version, my PC was freshly reinstalled and wiped… Yeah ofc, one of the first things I tried… Thank you very much for your support and your time invested, I really appreciate it!

Can you try this for me. Click at V1 and add the filter. That will apply the filter to the whole track without applying it individualy.

I wonder if the issue is that you are applying the filter to the timeline, but exporting from the playlist. Let me hasten to say I have never tried anything like that, so I don’t know if the filters should carry over from the timeline to the playlist … but that was the first thought I had.

No, the clips in Timeline and Playlist are not linked or related in any way. When you add a clip from Playlist to Timeline, a copy is made. Any changes to filters or properties of one does not affect the other. Same thing goes for multiple clips from the same source in the timeline: they are copies, each with their own filters and properties.

1 Like

This topic was automatically closed after 90 days. New replies are no longer allowed.