Beta version 23.04 now available to test

You can try out the BETA test version for next big release including: Qt 6, GPU Effects, Motion Tracker, Glaxnimate 0.5.3, Speed filters, filter sets, Mask: Simple Shape VUI! Shotcut - Beta Version 23.04

Make sure you read the notes under Drawbacks and Limitations to understand which comments will be ignored/rejected.


Bravo for the motion tracker filter. I have not yet seen such a convenient implementation of this function anywhere, everything is done literally in a couple of mouse clicks.

After the motion tracker is analyzed by the filter, if you start cutting the clip, the tracker gets lost. Will it be fixed or can’t the clip be cut after analysis?

1 Like

@shotcut, the new version (both portable and exe) isn’t loading for me on my W10 desktop but is OK on my W11 laptop.

On the desktop, I get the SC logo with “Loading plugins…”, then after about 8 seconds it disappears and … nothing.

I remember I had the same issue 2 years ago - then it was down to a music .dll file - I think jack.dll or something? I searched and found the forum post I sent.

After that you solved it with several PMs between us, which I can’t seem to locate…

To recap, in case this is again the problem, I have Cubase, Sibelius and MuseScore 3 (music apps) installed on my desktop but only Musescore on my laptop.
Hope this helps. I’d like to help if I can, if you need specific info on my files etc, but note I only have limited time available today on my desktop - tied up with a few other things… Please try though, you could hit lucky…

PS Thank you so much for the Mask:simple shape VUI!! Much appreciated!

@shotcut, just in case this helps, I also have MuseScore 4 (major upgrade from v.3.6, completely redesigned) and also SINE player on my desktop machine which are not installed on my laptop. No idea if this is relevant but thought I’d mention it.

You need to redo manually.
To all, the motion tracker will be simple for release with no immediate plans to make improvements except to integrate with some more filters.

Yesterday, I found and fixed a bug where it would crash on startup if there was a custom app data directory set. I am planning to update the downloads.


Great, thanks.
PS I found a small typo in the docs:

Win11 - 22H2

After doing the analysis on the object (using Name as Tracker 0), Motion Tracker dropdown is empty, not showing Tracker 0 as a selectable item. This initially worked but created a new project and repeated the process but the dropdown still not picking up the Motion Tracker Name variable.

I will reinstall to see if it resolves


Reinstalling won’t help, but saving and reloading the project probably will. Maybe the problem occurs when the analysis job completes while you no longer have Motion Tracker selected.

You’re right, reinstalling didn’t help. Did save and reload but it seems to be unrecoverable. Deleted the analyse job, removed the tracker and mask simple shape, saved project so just a single timeline clip. Added tracker and mask simple shape, analysed then loaded keyframes and the dropdown is now populated.

So tracking is working at this point but when I’ve reloaded the project, tracking seems to no longer track, not seeing it visually tracking the object (maybe my workflow is wrong)

Added a second tracker but again the dropdown of mask simple seems to only display the first tracker not both.

After playing with the project a bit, mask simple shape keyframes are clearly visible (image) but if you click on each one I’d of expected the size position variables to have changed as we click sequentially through the keyframes, that doesn’t seem to happen. The mask simple shape at this point is visually static.

How to choose the presets for export a video?

click one

Very often, for some reason I don’t understand, keyframes don’t load.

Very humorous.
No Export and no profiles were displayed.
Not until I clicked 1x on export at the very top of the menu was the normal export mode displayed again.
These steps were not necessary in previous SC versions.

I have the same problem.
Windows 10.
In case it is relevant, GPU Effects is disabled.

Everything worked fine yesterday. I used the Tracker on a transparent clip with SP&R and Text: Simple filters.

Today, I tried again using the same steps, but when I hit the Load Keyframes from Motion Tracker button, the drop down menu is empty

I save, relaunch Shotcut and reload the project as suggested, no effect.
I thought that rebooting the computer might help. But it didn’t.

Question: Where are the analyse jobs saved? Maybe deleting them manually would help?

I was going to ask that question too

In the XML, there is a path in Users folder, AppData/Local/Meltytech/Shotcut/opencvmodels but opencvmodels doesn’t exist,

I think you are saying that the Export panel is not open even though it was/is when you run the older version. That is intended because in this version your UI/panels layout is ignored to reduce the risk of failure upon startup with this major new version of the UI library (Qt 6). The new version loads with a default window size and panel layout that one gets upon the first install. That does not show Export panel by default; you must open it by clicking Export. The old UI layout is saved in View > Layout > Old (before v23) Layout.


In the “results” property of an opencv.tracker filter in the project MLT XML. The opencvmodels property and folder are not used yet. I will remove them for release.

At this time, you must not deselect the Motion Tracker filter while the analysis job is running. A Motion Tracker must display “Analysis complete” for it to appear in the Load Keyframes dialog. I made a change for the next version to be less brittle and still update things even after the filter is deselected. But it will always require the filter to show “Analysis complete” in order for it to appear in the load dialog.

1 Like