Audio Works on Computer but not Phones or YouTube


#1

Exactly as the title says, I put together a short video with separate, edited audio tracks. Once I was finished, I exported using mp4 format. The video worked great on my computer, looked and sounded as it did previewing it on Shotcut. I then sent it to my phone and my wife’s phone to test it. The video looks just fine but the audio is extremely muffled to the point that it is almost non-existent. I tried screwing with the advanced settings for export but to no prevail.

I then tried uploading it from my computer to YouTube, since that’s where my videos will ultimately end up. I could play the video just fine on YouTube from my computer but once again, the audio was basically gone on the phone.

If anyone has a fix for this, I will be forever grateful.


#2

Share the YouTube link. Your videos volume is probably low, but you compensate for it on the computer by using it’s or the speaker’s volume control.


#3

Here is the link to the video on YouTube. The only reason I feel it’s not that, is because even with the volume level all the way up in the phone, it’s still not able to be heard. But on YouTube from my computer at what I thought was a moderate volume level, it was fine.

The audio I put on to the video was in WAV format, should that be mp3, OGG, or something else instead?


#4

I can confirm with you @djcorus, I get the same on my end as well. I’ve got a Samsung S6.
Excellent on the computer, but can’t make anything on the phone through YouTube. But the audio does sound like it’s a bit off on the left & right side with the computer. It’s clear. I don’t have a 5.1 speaker set up, but it sounds like you my have some audio issues with the source video possibly.

Do you have just 2 audio channels selected in Shotcut?
2019-01-10_07-36-20

Going to your source file in Shotcut, click on the 3 lines button, “More Information…”.
Click “Save” (keep the .txt extension), upload here. I may not be able to figure out the audio portion, but someone else may have an insight after reviewing your source file information.

2019-01-10_07-32-06

You could also try “Convert to Edit-friendly”shotcut_2019-01-10_07-40-14
shotcut_2019-01-10_07-38-26


#5

@Hudson555x I appreciate your input! I will have to try your suggestion once I get home from work. As far as the audio being off from left to right, it may be the placement of my mic. I am new to this stuff and the mic is on a boom above my wife but not centered, I should probably center it lol.


#6

Not the placement of the mic. It has to do with how the audio is formatted/recorded. YouTube recommends AAC-LC for an audio format at 96khz, or 48khz. To me it sounds like there is a slight desync between the right and left channels. There is also audio bit rates that’s recommended. https://support.google.com/youtube/answer/1722171?hl=en

Perhaps try selecting the YouTube preset before exporting, and don’t go into advanced.


#7

@djcorus

Willing to bet that your audio codec (or sample rate) is wrong for mobile devices or you have something else other than stereo audio selected.
Computers can handle many more codecs than mobile devices.
It’s OK that your source audio is in wav but it must be exported as AAC.

  1. Make sure your project is set to 2 audio tracks (stereo).
  2. Export video as h264 and audio as AAC (at round about 160Kb/s with a 44.1KHz sample rate) in a mp4 container.

Try it out and let us know.

BTW, iphones will also handle h264 video with mp3 audio, again wrapped in a mp4 container.

If you stick to the above settings, your video will work on computers, mobile devices and Youtube.


#8

audio info.txt (1.1 KB)
This is my audio information from my audio files that I have added with the video. I hope this helps someone with my issue.

@Paul2 I made sure to have it set to 2 audio tracks, which it already was set to that. As for the h264, there are 3 different choices to choose from: h264_amf, h264_nvenc, and h264_qsv. Do you think it makes a difference which one I choose? I did try exporting with those settings but had no luck, I had just set the video codec to h264_amf.


#9

Don’t know any of them and what the details are.
I normally go to “Advanced” and use the h264 Baseline profile, has never let me down on any device.


#10

So I just did a test and threw one of my original clips (a .MOV file, if it matters) into YouTube and the same thing happened. The audio works on the computer but not on the phone. I am just out of ideas as to why this is happening. I had even put the video file into Audacity to extract the audio to clean it up but after reformatting it to both WAV and mp3, audio still isn’t working. About ready to pull my hair out!


#11

Sorry, but I do not hear a problem when I play the YouTube video on my iPhone through speakers or headphone. Maybe the problem you are describing is subtle, and I am not sure what to be looking for; however, the sound between the computer and iPhone are very similar for me. It does not matter much the source audio format, but if it is compressed (mp3, ogg, aac, etc.) then lower bitrates or quality levels are obviously not good.

These are hardware encoders for H.264 that depends on your system. For software H.264 encoding use libx264, which is what the presets always choose when the Hardware Encoder checkbox is not checked. Video codec choice does not typically affect the audio.


#12

My wife and I both have Androids, must be something with them that is part of the problem. Whatever it is though is being started with the original video file if I can’t even get the unaltered video/audio to work. And thank you for the information on the H.264!


#13

I concur with @shotcut
There is nothing wrong (that I can tell) with your audio.
Below, two screen shots, the first is the stats for your video on Youtube and the second the audio extracted directly from the Youtube video.
It sounds fine, good level and no clipping.

Another screenshot with more details about the audio:

2019-01-11-012720_584x377_scrot


#14

@Paul2 now play it on your phone and see how it sounds.


#15

@Paul2 I seriously appreciate you trying to help me figure this out. Unfortunately, because me, my wife, and @Hudson555x can’t get it working with our Android phones, we are going to have to continue trying to figure this out. I may try Adobe Premier Pro to see if it continues to not show up. Again, thank you to everyone for the help, let me know if there are anymore ideas.


#16

@djcorus, have you tried converting the source footage to Edit Friendly and then export with the YouTube preset? Don’t worry about hardware encoding. Leave that unchecked.


#17

@Hudson555x I just tried and unfortunately, it didn’t work.

I am starting to believe it has something to do with my microphone. I had some footage from a few days ago and I tried uploading that to YouTube. In the footage I had some audio recorded with the stock mic on the camera, then it switched to the condenser mic we’re using. The stock mic sounds fine with my phone, but as soon as it cuts to the scene with the condenser mic, the audio cuts out and is just like the video I posted.

This doesn’t make any sense to me, why the audio from the condenser mic would become inaudible on a phone. What could be happening with the mic that could cause this?


#18

@djcorus, I looked over your text file, and I’m not sure what I’m looking at.

When you recorded this initial footage, was the audio recorded with the video at the same time in the same file? This would be your Source video. Or did you record audio on a different device then import the audio on it’s own audio track?

What I’m wanting to look at is the Source video file that you recorded, if it is with audio, on that one file, when that is loaded into Shotcut, then perform the More Info.

The exported file, right now, is not relevant as we know that’s not a good file. For right now ignore it. So just upload that source video file information.

Could you also upload your mlt project save file?

My examples, click here to expand

I made a source video just yesterday, and here is the “More Info” text from that file.
SourceMoreInfoFull.txt (4.0 KB)
My file is on the left, yours is on the right.
2019-01-11_02-19-16

And for the my exported file that I loaded on YouTube yesterday: MoreInfoFull.txt (2.3 KB)
I exported at default (No presets selected), No hardware encoder selected.
2019-01-11_02-30-21
2019-01-11_02-31-06
2019-01-11_02-31-36
https://youtu.be/CoDxG4UIy80 (my video uploaded from yesterday)
Not much editing on my video, but is my video clear on your mobile device? I’m sure it is as I have not heard any complaints yet, and the majority of the views are probably from mobile devices. I use a Blue Yeti, USB connected to my computer, no interface. Recorded with OBS.


#19

sourcefile.txt (3.3 KB)
@Hudson555x Here is my source file ‘more info’. It looks like it has the same issue as you pointed out in your examples.

StudioTest02.mlt (15.6 KB)
@Hudson555x and here is my .mlt.

Your audio from the video you have sounds just fine. This seems to be a problem that no one has had. Between both my wife and I, we cannot find anything on google that is similar to this problem. I will run you through my setup…
We have a Canon 5D Mark III for our video, with an MXL DRK (this is battery powered and is suppose to not need phantom power) condenser mic, and that is just an XLR cable with an adapter going to a 3.5mm jack. I do not have any other source that I am recording my audio to, so it is going straight into the video file also. What I originally did was put the source file into Audacity and extract the audio, so I could clean it up, then sync it back up with the video file. But from what I am seeing, is that whether I use the original source file or the synced version, I still get the lost audio. Not sure if this info helped but I figured it wouldn’t hurt to explain. I also have another mic from a friend we are going to try but waiting on a phantom power supply, as that one is not self-powered.


#20

For your camera, here is the PDF manual link:

Where do you have your audio settings at? You might want them in Manual for Sound-Recording Level, and Disable for Wind Filter.

It appears your camera can only record with a memory card. I don’t see any instructions to connect it to your computer via it’s USB cable and yet still record. While this is a very nice DSLR, it appears the Movie side of the camera was an add-on feature because they could.

It appears to only record in variable bit rates, which you might try to Convert with Edit Friendly, in Shotcut.

It also might be worth a try to extract the audio with Shotcut, WAV preset, export. Then use that WAV file in Audacity, then bring that wav edited file back into Shotcut.

Camera Details

Page 236
2019-01-11_07-02-20

Page 233
firefox_2019-01-11_07-22-03

Page 382
firefox_2019-01-11_07-13-12

firefox_2019-01-11_07-14-24