Audio Works on Computer but not Phones or YouTube


#21

I may have found something! Now just have to wait until after work to try it. These are screenshots from a YouTube help post, can’t believe I finally found a similar problem.


#22

I’m posting the issue that person posted… Being new it only allowed one picture upload in a post.


#23

@djcorus

The video and audio lengths in your mp4 are different.
I recall reading somewhere about Android not liking it as the audio is always trying to be synched up with the video.
Could this be your problem?


#24

I thought I heard something funny on the computer.
It just didn’t sound right to me anyway.
But my video, if you watched it, is in Stereo. All of my videos are in stereo. And I have many people that just watch on their mobile devices.


#25

@Paul2 being so new to this I’m not sure what you mean by the video and audio lengths being different.

@Hudson555x perhaps because my camera is not meant for video, it might be a good idea to get an external audio recorder. This was an original idea we had, but my wife wanted to try to keep the audio in the video, without the need for syncing (just extra work for us rookie video creators lol).


#26

The video track and the audio track in the mp4 are not of the same length.
Check the “Duration” under Video and Audio below:

2019-01-11-150215_571x394_scrot


#27

Another hunch that I have is that the “Reference Frames” for the video should be one, it’s three on yours.
Not 100% sure about this though.


#28

On Page 233, I would try setting the Compression method to ALL-I for another trial clip.
Sadly enough, I would agree this camera is not meant for what you really want to use it for, as far as YouTube videos. Maybe there is a great Canon forum group out there that has some workarounds for allowing connection to your computer to use it as a webcam, then you could record with OBS.


#29

Being a new member, I had to wait to respond. “You’ve reached the maximum number of replies a new user can create on their first day.” Lol

@Paul2 But even when I tried uploading one of the source files (which included the original, unedited, audio) to YouTube, I still got the same result of no audio. Unless the camera is recording the audio unsynced or not with the correct timing?

@Hudson555x you’re absolutely right, I think I will have to join a Canon forum. Considering this is definitely starting to sound like a hardware issue and not a a Shotcut issue anymore.

I can’t tell you guys how much I appreciate your assistance trying to get to the bottom of this. Thank you!


#30

Could very well be.

You are very welcome, it’s something that has me perplexed as well.
Went to the studio and asked a couple of guys there with Android phones to check out the vid, sure enough, no audio.


#31

You using an EOS 5D is that correct?
Please see the link below.
The fact that the audio is out of synch is not a huge problem, just more work to manually synch it up.
The problem comes in due to the fact that the camera is possibly recording the video and audio tracks with different lengths/timings.

https://forums.creativecow.net/docs/forums/post.php?forumid=325&postid=172&univpostid=172&pview=t


#32

@Paul2 The camera we are using is the EOS 5D Mark 3, not the 2.

I had to wait 8 hours from my previous post to post again.

So I had posted this earlier
243789bc3470b85a62737a00e40caeb4996a1a12_1_662x500

I followed it this, by taking my audio files I had put into Audacity, removed the right channel, and duplicated the left. I then exported the file same as I did previously and added it to the video. Long story short… IT WORKED!

I truly appreciate everything you guys did to try to help me! I don’t understand what that guy means in the pic I posted, how “the left channel is 180 degrees out of phase with the right channel.” I’m gonna be doing more testing with a different mic and wiring setup to see if I can eliminate having to edit my audio like that. If anyone has an idea for how to stop my left and right being outta phase, please let me know. I think it might just be the cheapo mic we picked up.


#33

I would try the “ALL-I” compression method in your camera.
In Shotcut, you can set your audio to Mono in the settings.
And you have a few audio filters to try in Shotcut as well.
shotcut_2019-01-11_17-57-41

And it might sound odd, but perhaps try a different brand of memory card, same class, same speed. Even do a format of the memory card from : https://www.sdcard.org/downloads/formatter_4/ . Many tips across the internet about this formatter. And not all memory cards are the same speeds either. Make sure your memory card is fast enough for your camera.


#34

You should be able to do this in Shotcut by using the Pan and Copy audio filters.


#35

FWIW - I only just read this thread and played your video example om a few devices. The audio is clear but panned left on 2 Android tablets and and Android phone, but on my PC it’s a little weird. My living room PC is hooked up to a 5:1 surround system, and the sound came out exclusively from the rear left speaker and nothing at all from the other 4.
I see you’ve solved the problem now, but it was quite unexpected and interested me.


#36

I knew I heard something weird with my 2.1 set up.
I wonder if the OP has the audio on 5.1 instead of Stereo.
2019-01-12_06-40-22


#37

It interested me too as I normally have to deal with problems relating to broadcast media so something “consumer” makes for a nice distraction.

One of the guys at work saw my interest and donated an old Android Hi Sense F20 phone he picked up on one of his travels abroad so I can play, thanks Stan.

What I have done is set up a web server on the LAN so I can test by connecting to the server and playing clips on the phone via wifi.

What I have found so far as follows:
The AAC codec uses 1024 samples of silence at the begining called “priming samples” which the decoder uses to synchronise the audio stream.
Now these 1024 samples take up about 21mS (@48KHz sample rate) which is added to the duration of the audio stream.
So the first sample starts at -0.021 seconds and the 1024th sample is at time 0.
However the video starts at time 0.
Therefore if we analyse the clip (use the “more info” option in Shotcut) we see that the audio is 0.021 seconds longer than the video.
When wrapped in a MP4 container (and presumably mov too), there are pointers to indicate to the player where the actual audio data starts, the 1024 samples before as said before, are to “initialise” the decoder.

This is where the problems start, if we create a movie (with audio) in Shotcut and try play it on an Android phone (at least on mine) and there is that 0.021s descrepency, there is no audio playback.
It plays fine on computers and iphones which I assume compensate for the “priming samples”.

If however I take an existing Prores movie clip, load it into Shotcut and convert to h264 (baseline profile), 1280X720 with AAC audio, it plays perfectly on the phone as the audio and video durations line up.

All very weird.
I must add that the donated phone I’m using is a few years old and running Android 5.1.1 (lollipop I think).
Perhaps things have improved since?

If anyone has a newer Android phone and some time to create some clips from scratch and test then post here that would be great.


#38

The Android versions I played the clip on were: 5.1, 6.0 & 8.0, all with the same results.


#39

I’m suspecting that somewhere along the way of the OP using Audacity to clean up the audio, something with Audacity went wrong, or it got exported incorrectly. Been learning more and and more about DAW’s and many videos I run across talk about how destructive Audacity can be in editing.


#40

Interesting, care to share some links?