Audio popping sound

Howdy!

I am currently working on a football editing project. There’s a certain clip that when the audio comes in, it’s creating a very audible popping sound. There is no audio clip right before it (except a music mp3 that is over the entire video) so its on a different track and there’s no transition. I already added a “fade in audio” as well. I don’t hear the popping sound while I’m editing, It only is a problem with the exported mp4. Any help or suggestions would be much appreciated. Thanks.

Can you share the audio file, possibly in a private message if needed?

What is the best way to do this? It doesn’t let me upload mp3 when replying.

I am using the 3:54 - 4:05 mark of the file I uploaded to that link.

There are a couple other places where I’m getting subtle popping sounds in the exported video where I wouldn’t normally expect them. I’m wondering if I’m just doing something wrong when exporting?

Two things:

  1. There are some reported and fixed-but-not-yet-released bugs in this category.
  2. Change export to not use AAC based on this thread. Consider changing to ac3 or mp3 in MP4.

appreciate the help!

I tried using ac3 codec and I’m unfortunately still getting the same thing. This didn’t happen the last time I used shotcut to make a similar Youtube video, so I’m pretty lost. Like you said, maybe just a bug.

I was unable to reproduce the problem. I started with a simple one video track at 29.97 fps project; what fps are you using? I added an audio track and put a sine wav on it to simulate your “music mp3 that is over the entire video.” A sine wav makes it easier to hear and see artifacts. Then, using the mp3 file you provided I set in at 3:45:00 and out at 4:05:00 (I assume you were using MM:SS). I added this to a second audio track at 5 seconds from start

Next, I exported using defaults without hardware encoder and with parallel processing turned on. Finally, I loaded the resulting MP4 into Audacity to listen and inspect. I did not hear it, and when I zoom in at the 5 second point, I did not see any unexpected spikes or dropouts.

Followup suggestions:

  1. Try turning off parallel processing in Export > Video
  2. move the audio clip by one frame to the left or right
  3. trim the audio clip by one frame

I believe it was set to 25.000 fps by default. I’ve been trying to use the “Youtube” default settings. I’m pretty new to editing so I’m not super knowledgeable with all these things.

With your project open, click Master in the top left corner of the timeline and view Properties to see. You should match the Video Mode to the main/majority of your video footage.

I changed my project used for this problem report to 25 fps but still did not reproduce it with similar result in Audacity review. Sorry

This may be a suggestion that might help you. What happens with my holiday movies that sometimes when the new clip starts there is a popping or clicking sound. I use a Canon SX280IS. My solution for that is as follows: Cut a slight bit (0.5 to 2 seconds) of the beginning of the video clips and do an audio fade in on every clip of 00:00:00;02, as low as the setting will go, sometimes a 00:00:00;05 is needed.
That is my solution to remove the irritating pops, clicks or other noises.

We recently made a few fixes for audio pop and clicks in the engine. These will be in the next version 20.06 due in June.

I suffered with the same issues and by the suggestion of Dan I changed my audio files to wav. This significantly improved the situation, if not entirely.

I have been using Shotcut for awhile and encountered this a lot, but particularly with my current project which is an animation with lots of sound files. Almost all the sound files are wav format and I have tried adding in fades and removing the start of the sound files (though this doesn’t make a lot of sense as some of these files are sound files that have been split into smaller clips inside Shotcut). I tried updating to the latest version (20.07.11) but it crashes as soon as it loads. As such I downloaded a portable version (19.12.31) that runs the project fine.

I’ve also tried using a number of audio codecs in the exported video, but that hasn’t helped. Any other potential solutions?

The popping sounds are quite frustrating for this particular project, but also, I did some of the animating inside Shotcut and syncing the audio to the animation also took a lot of time so I really don’t want to start it again inside the newest version.

Shotcut 20.07.11 has a fix for this particular issue. Try to reinstall it and let’s see if we can figure out why it does not load for you.

I am currently trying out a workaround of exporting tracks of audio without overlapping any sections and then editing out any pops in audacity, that way I will reduce the number of sound clips and if I have any pops in the final version it should only be at the beginning or end rather than before each section of dialog/sound effect.

Thanks for your quick reply and assistance! I have installed it twice, but I will download it again and then try once more, perhaps the build is an older one as I downloaded it a few weeks ago.

Thanks again for your help. I am a teacher and I have also asked to have Shotcut installed on the computers in the computer room for next year. I try to teach my students about open source software as it can be more empowering than software they cannot afford to buy or understand the inside workings of. We have often used Blender’s VSE before, but Shotcut has a lot of advantages too.