Audio Fade Out within project doesn't work


#1

While working fine at the end of the project, the Audio Fade Out filter doesn’t work properly within the project. To do so I splitted the video track and inserted the filter for the first part. I’m using Version 17.12 right now and even the shaded slope is not showing up at the end of the part. It was doing so in version 17.10 (I skipped version 17.11) but the audio was not fading out there either. Since a fade in for this part works properly and also is doing in the second part, I believe this must be a bug.

I’m using Win7 Home. The video is in H.264 yuv420p in a resolution of 1920x1080, framerate 25 and the audio is AAC fltp sample rate 48000 on 2 channels.

If I shall provide different specific information, please let me know!


#2

Have you tried using the Throbber to drag the fade?


#3

To clarify first: It is not a question of the duration of the fade. It all works properly in the last part of the clip. Here the fade starts where the slope is shown up. Thats fine. But at the end of the first part, the slope is shown in ver. 17.10 but not in 17.12 (same .mlt file loaded), and there simply is no fade out at all in both cases.

BUT: (and this doesn’t work for ver. 17.10 as the slope does not disappear when the filter is removed (another bug?)) When I clear up the filters pane and only use the throbber for the fade out and afterwards remove the fade out for the video (because it appears for both, video and audio), I come to the result I want. So, thanks for your tip so far! I can use it as a workaround.

But I still believe there is a bug at that point as it should also work the way I described first!


#4

Same thing here, but it happens to me when i try to fade out an audio clip within a track. In fact the audio fades out when i add the audio fadeout filter, but the slope isn’t shown at the timeline. It looks like the fadeout control of an audio clip doesn’t get the change/update events of the fade out filter at the filter pane, because if i change the fadeout filter duration (and then nothing happens at the timeline), but then i add or remove the fadein filter, the fadeout slope magically appears at the timeline, but keeps unresponsive to fadeout filter changes, until i remove or add the audio fadein filter again. It looks like the audio fadein filter sends the update event to the fade controls of the timeline, but the audio fadeout filter doesn’t. I’ve searched throught the qml files, and i understand how some things are programmed, but because of my lack of undertanding of qt5 language (yesterday i was aware that it exists) i can’t figure out the connection between the audio fadeout filter plugin and the timeline code.


#5

The Grey fade ramp is only shown when you manually drag a fade using the throbber as shown in my video clip above.


#6

I am experiencing the reverse problem.
I have a timeline with two sequential audio clips on it. I can fade the audio on the first clip with no problem. But Shotcut ignores my audio fade for the second clip. (I made sure to select the second clip before trying to apply the audio fade to it.)
The first clip shows the gray wedge and the audio fades. The second clip does not show the gray wedge and the audio does not fade.
I have tried removing the applied filter and reapplying it. I have tried changing the duration of the fade. Nothing has any effect.
This is the first time I’ve encountered this.
I noticed there is a post from Jan 2017 describing the same problem. Fade Audio/Video Filters Work Intermittently (17.01.02)
As suggested there, I tried manually fading the audio. The gray wedge appeared, but the audio still did not fade. (I used 5 second fade to be sure it was evident if it was working. I also used the peak meter for visual verification,)
My project is in limbo unless and until I can figure out how to make this happen.
Looks like a bug.


#7

The original problem reported is fixed for the next release v18.04.
I have not reproduced the problem described by @BGDavis


#8

Thank you for the response and update.
As noted this seems to be an intermittent problem.
I’ve had a similar problem with video from time to time. The dark wedge appears but there is no fade in the video. I’ve found that this can be remedied by using the “throbber” to drag the starting point of the fade back and forth before leaving in the desired position.
As a footnote, sometimes the throbber will appear when the mouse/pointer is nowhere near the upper R corner of the item in which the throbber appears.