Audio Crackling from MP3 Recording

What is your operating system? Windows (I believe it’s 10)

What is your Shotcut version (see Help > About Shotcut)? Is it 32-bit? Shotcut version 22.04.25

Can you repeat the problem? If so, what are the steps?

I record voice over tutorials and use the microphone feature. It is fantastic most of the time, but there are crackling sounds. I use a Blue Yeti. It doesn’t have the crackling issue when I use it in OBS, but just in case I did reseed my microphone several times & played around with the gain.

The other issue is that it’s NOT there when I film the audio first, but when I add something on top of it segments become crackly.

Yesterday I tried to film the same audio 3 times. I finally went to the end of the tvideo & recorded one to see what it sounded like by itself. It sounded perfect. I added the limiter setting I use and it still sounded perfect. I moved it under the OBS screen recording that I used for the visuals and massive crackling happened.

I’ve tried moving the crackling clips to a lower audio track, but that didn’t fix the problem either.

I really want my audio to be the best it can be because I am a voice over tutorial instructor and my audio needs to be clear without crackles. Am I doing something wrong? Help. Thanks so much.

Are you using the microphone icon on the timeline toolbar? If so, that records in Opus, not MP3.
You might be experiencing the normal, typical crackling that can appear in preview due to the overhead of realtime video processing on the CPU. Did you export and check the result? The remedy is to use less things that add processing, use preview scaling and proxy, or overlook the preview flaw. The problem is more pronounced as the frame rate increases above 30 fps because the computer has more work to do in less time. These things are in #FAQ

Yes. The microphone icon on the timeline tool bar. I hear it in the preview, but it’s also in the export. And that’s even if I just put a straight up OBS screen recording with no filters not even size filter to see if was still an issue. I use 30fps (because it’s a YouTube Video I need it to be 1920 x 1080 at 30fps). I honestly thought it was preview crackling until I exported. Listened and heard some crackling in it.

Do you think it might improve if I export as a mp3 file after recording the audio only? Then add it to the video instead of downloading it as a mp4?

It seems to be the same as this, which is not resolved:

I listened to the clip from that bug report and it’s audio distortion. I didn’t hear clicks. Mine thankfully isn’t distorting the audio. It just has pops & crackling off & on through varying clips. I had hoped to use the microphone icon because that is MUCH faster for me when I create videos especially when I need to re-film the audio a few times. It does this in the editor, in the player I have on my computer & of course when it’s uploaded to YouTube.

Are you sure the OBS screen recording is not variable frame rate? Variable frame rate is not supported for editing.
What does Shotcut say is the frame rate in Properties when the video clip is selected?
Also, what does Properties show for the frame rate when you select Output in the top, left corner of the timeline? You should report the exact numbers and not approximate or rounded.

My OBS screen recording is set to 60fps. The OPUS clips are set to 30fps. The Output is set to 30fs and is the same rate we use for the exports.

I’ll definitely change my OBS settings to 30fps to see if that helps the problem. I’ll be testing it out on Monday when I film for my next lesson.

I switched out the frame rate on OBS, but before I could even try screen recording I noticed there was crackling in the audio today by itself. I tried exporting it as a mp4 and as a separate mp3. I know it’s not my Blue Yeti because it works when I’m filming audio in other devices (if I record the audio directly with OBS it works just fine, but I prefer the ease of adding the audio with Shotcut). I do have the latest version of ShotCut. Any other suggestions?