Audio and Video Go Out of Sync After Export


I’ve already edited and finished a project and while the audio and video sync perfectly in the editor (this happens across all the tracks, by the way), it goes out of sync after I export it. I’m even running the latest version of Shotcut, as of July 1st, 2018. I’m also using Windows 10. I’ve used both .mov and .mp4 video clips, and I’ve used both .wav and .mp3 audio files.

I export my video using the ‘H.264 High Profile’ option, and the only things I changed are the quality to 100% and the frame rate, which varies. I’ve read about exporting the video with the same frame rate as the clips used in the editor, but the clips can vary from 29.97 fps to 30 fps. In one of the clips, it even dips down to 25 fps. I don’t know if this adds to anything, but I’ve also noted that only .mov clips are 30 fps and that any clip below 30 fps is of an .mp4 format.

Additionally, I’ve heard about ffmpeg, but it doesn’t apply to my situation, or at least I don’t know how to apply that solution to my situation. I’ve tried using it upon both the exported video (.mp4) and even the project itself (.mlt), but error messages appeared both times even though I typed the commands correctly. I’ve noticed that instead of “Open command window here”, it says “Open Powershell window here”. I don’t know if this changes anything, but I thought that maybe it’d be helpful to put out there.

Any help on this would be much appreciated, thank you!

PS: I’m not very well-versed with much editing vocabulary, so please be patient with me if I do not understand something.

1 Like

Which media player are you using to view the exported project?

I’m using Windows 10’s Movies and TV app to watch the finished video.

OK, I suggest you try another player such as VLC or my favourite, PotPlayer.
Also, if you open the final exported file (not the project) into Shotcut, does it play correctly?

I tried watching the video on both VLC and PotPlayer, but it still does not play correctly. Watching it on Shotcut does not play it correctly either.

OK, well we’re going to need MUCH more information than you’ve given so far…

See this post:

Shotcut Version number
I used Version 18.06 when I exported the video and encountered the problem (but as of posting this I’ve now updated to Version 18.07).

Shotcut Settings
GPU Effects (Experimental): not enabled
Video Mode: Automatic
Display Method: Automatic

Operating System
I’m running a 64-bit version of Windows 10 Home Version 1803.

Computer Specifications
Processor: Intel® Core™ i7-3610QM CPU @ 2.30GHz
Installed Physical Memory: 8.00 GB
Available Physical Memory: 7.90 GB

Screenshot of Shotcut
(for example, each of the clips are supposed to align with a beat in the song but the beat is delayed by a few milliseconds in the exported video)

Source Files Specifications
Codec/Extension types: varies from PNG, MOV, & MP4
Resolution: varies from 1280x720, 4160x2340, 360x360 1920x1080, 1092x614, 568x320, 224x128, & 568x320
Frame rate: varies from 30fps, 30.0247fps, 29.97fps, 30.025fps, 29.9834fps, 29.9829fps, 29.9803fps, 15fps, 25fps, 29.892fps, 29.7fps, 29.9818fps, 29.7993fps, 29.9856fps, 29.951fps, & 30.025fps
Bit rate: varies from 2263kbps, 2246kbps, 53014kbps, 43430kbps, 56033kbps, 57115kbps, 1952kbps, 1797kbps, 2199kbps, 2211kbps, 49417kbps, 1925kbps, 2160kbps, 2340kbps, 2256kbps, 2191kbps, 2198kbps, 2273kbps, 2173kbps, 2241kbps, 2156kbps, 15390kbps, 2353kbps, 14526kbps, 12886kbps, 50172kbps, 14966kbps, 29755kbps, 37886kbps, 29449kbps, 25637kbps, 32476kbps, 28607kbps, 28728kbps, 50029kbps, 4406kbps, 14426kbps, 698kbps, 628kbps, 4377kbps, 4364kbps, 4372kbps, 67381kbps, 705kbps, 2404kbps, 12948kbps, 13795kbps, 14640kbps, 14031kbps, 15251kbps, 13619kbps, 13728kbps, 2368kbps, 2386kbps, 4477kbps, 35785kbps, 2137kbps, 705kbps, 675kbps, 650kbps, 4600kbps, 12686kbps, 14738kbps, 13749kbps, 14081kbps, 13551kbps, 1983kbps, 1836kbps, 1944kbps, 1893kbps, 1485kbps, 2200kbps, 2202kbps, 148kbps, 13243kbps, 14438kbps, 12410kbps, 14123kbps, 13568kbps, 14077kbps, 45710kbps, 4452kbps, 14665kbps, 4374kbps, 13849kbps, 404kbps, 2421kbps, 705kbps, 2037kbps, 4616kbps, 2295kbps, 1926kbps, 13908kbps, 1549kbps, 2391kbps, 4471kbps, 4489kbps, 2259kbps, 13882kbps, 2112kbps, 2319kbps, 14245kbps, 2147kbps, 7587kbps, 14120kbps, 4072kbps, 2329kbps, 14389kbps, 2459kbps, 348kbps, 2490kbps, 607kbps, 402kbps, 1301kbps, 14237kbps, 2225kbps, 9027kbps, 5115kbps, 5018kbps, 5151kbps, & 5182kbps

Export File Specifications
Export preset selected: H.264 High Profile
Resolution: 1280x720
Frames/Sec: 30
Codec: libx264
Rate control: Quailty-based VBR
Quality: 100%

So to be perfectly clear, are you saying that your project plays perfectly in-sync during the edit but is out of sync once exported?

Yes, it plays perfectly in Shotcut but not in the exported video.

1 Like

was this ever solved? i have the EXACT same problem

1 Like

It worked once I used VLC player instead of Windows Media, don’t know if it will still be synced once I upload it to Youtube, though. :confused:

Update: Even in VLC, it is still slightly off. I realized that it was because my video was not synced, but since I muted it, it did not show. I unmuted the video(shot from my iphone) and I could tell that the audio did not line up with my other audio(shot from my microphone). I think you just have to move the video a few frames back.