A bug developer won't fix


#1

How shotcut has managed to update 30 times and still not fixed the random crash is beyond me.

Happens completely random when messing with anything in the timeline, regardless of what function is being performed it’s just a roll of the dice.

NO experimental features or GPU acceleration everything setup default, no variable framerates ETC. I’ve searched this entire forum and no solution has been made and only received “yeah it happens” from others on the web.

When are you going to fix this issue?
Currently searching for a new video editor because I just lost 2 hours of work and OH… by the way…
The recovery feature is bugged for this version so usually when reopen the project and it brings me “somewhat” close to where I had been working no longer works.
It loads into a completely blank everything and when I go to reopen (a forced closed project) the file again it says “modifications have been made would you like to save?”.

Of course I don’t want to overwrite what’s left of my broken project with a blank everything .

Finishing this project then I’m moving on since its apparent the developer doesn’t give a crap.
Shame.

Specs: Laptop - Helios 500
i7-8750H
GTX 1070
16gb RAM


#2

If you have been experiencing this bug for a couple of years now then you should be able to describe exactly what triggers this specific bug to cause this specific crash. The bug can’t be fixed if you don’t say what the steps are to reproduce it.


#3

Apparently you didn’t read my post because like I said it’s completely random.

Adding text, cutting clip, pasting clip, undo, you name it.
Anything in the time line as a function can trigger it.

Eager to hear a reply from someone who reads what I type out.


#4

I did read it and there’s no such thing as it happening completely at random. Something always triggers a bug. So either you haven’t cared to notice what that is or you have come across separate issues that are triggering crashes but haven’t taken the time to single any of them out and figure how to reproduce them.

Attitudes like that are not going to help you.


#5

Never because the issue you mention is lack of perfection, software is very rarely perfect, and neither am I (or all the other projects and developers on which this project relies). Of course, we will continue to work on improving stability.

I heard about this during the beta period, but I could not reproduce it. I just tested it again, and it worked for me. I will continue to look into it. Maybe it depends on some setting.


#6

The purpose of the term “random” was invented to describe things that happen in a way we cannot predict. And as an avid software user, I can tell you that some programs do indeed appear to crash at “random”, this is not a new concept. UE4’s Blueprint system for the longest time, was a valid target for this accusation.

I noticed OP hasn’t specified what OS & build he/she was using, that’s a pretty important piece of information!


#7

As you yourself just said, it appears that it’s “random”. That doesn’t mean it is random. Also, the person here has said that this has happened for a couple of years. Supposing that this is one specific kind of crash and not different issues he is experiencing, then he should’ve been able to notice what is triggering this. Most likely, these are separate issues that he is coming across and hasn’t bothered to figure out what is triggering any of them.


#8

You are correct, and we must raise to new levels of knowledge, rigor, quality control, tools, techniques, etc. Often, the seemingly random problems happen due to multi-threading and lack of safety around shared data. For most of those, steps to reproduce can often be found to make it easier to fix. In the other, more random cases, we continue to raise our level as exhibited in this bug (esp. the linked Intel article):


#9

“No such thing as random”
It’s apparent you’ve never written code.

“Attitudes like that are not going to help you”
Feel free to move along, your not a help anyway.


#10

Agreed that software is never perfect I’m not disputing this.
My initial post was made immediately after my crash so I apologize for sounding rude.
Probably should have cooled off first.

You mentioned not being able to reproduce it, are you able to produce a crash? The crash I had today was unlike others where before Windows would notify me that shotcut had froze and needed to close, that did not happen this time, it just went straight to desktop.

Is there anything you need from me to help you determine the cause?


#11

I’m running Windows 1809 at the latest to this date.
Sorry for not specifying.


#12

Funny how you ask this question now. I told you that you should try to specify what is triggering this crash in my very first reply to you but all you decided to do was snap back and be rude. And you did it again to me right before asking Dan this question.


#13

Are you a developer of shotcut?
Or are you just here to troll my post?


#14

You’re asking me if I’m a troll yet you’re the one with the name “Make_More_Enemies” and with the lousy attitude.


#15

It’s the name of a website in development and was generated from the Gmail I signed up with.
Like I said before, feel free to go away. :grinning:


#16

I’ll come and go as I please. Thanks. :wink:


#17

Ah the truth is revealed.

As you please and not as your needed. :ok_hand:


#18

“Finishing this project then I’m moving on since its apparent the developer doesn’t give a crap.”

That’s pretty harsh.

Have you seen the list of all the other bits of software that are used to build Shotcut ? Without specifics, as others have said above, it’s impossible to locate in which of the dependencies the errors are occurring, let alone fix.

The very first thing that shows on the Shotcut home page is “Shotcut is a free, open source, cross-platform video editor.” So if you want to fix it, and help others, you (or you could pay someone) to clone the code, add some debugs and find the problem yourself, in which case I’m sure the developer would welcome the contribution.


#19

Just registered to reply in this thread.

First of all, thanks a lot to the devs: I use shotcut for almost two years now, and it provides a whole lot of amazing functionality for free.

BUT. Man, these random freezes are really annoying. Like the OP, I’ve just lost a good hour of work because of that, and it happened several times before as well.
I think all of those crushes, or most of them anyway happen after several undos in a row.

It tries to undo and then ends up in some inconsistent state where you can’t select fragments on timeline, and when I launched the export, thinking that I might later save at least part of my work, it just crushed after several minutes.

Hope you guys can fix it one day.

Cheers! :slight_smile:


#20

Yeah it is harsh, and like I said in a following comment I make this thread while still pretty heated I had lost a ton of work. I also apologized.

Also yeah thanks for parroting the others saying I should be helping diagnose the issue, I understood that the first time. I also asked what is needed from me to diagnose the issue and haven’t heard a response from the developer or the troll since… Are you going to break the trend and tell me whats needed submission-wise to figure out what the problem is?