4K Video Not Worth The Trouble?


#22

Can you take everything and throw it in a google drive folder or similar so we can take a look at it?


#23

I’ll do it tonight and post a link.

Must say that this is one of the most helpful forums I’ve come across. Appreciate all the help I’ve been getting (especially you, D_S)!

And Shotcut is amazing! Much props to Dan for working so hard to make something free and open source that rivals the ‘professional’ subscription editing programs. I have not encountered anything I wanted to do that Shotcut could not handle (other than my current issue which is probably caused by slow hardware or user error).


#24

OK, I couldn’t upload the 4K files because they’re too large for my DropBox.

So I converted all the source files to 1080p and redirected the .MLT file to the directory with those 1080p source files (like a proxy edit).

The edit is how I want it to export. But when I render the file it comes out like I described above:
twice the length of the timeline with minute long video fades and showing video and sound from the source files that were cut out in the edit.

This Dropbox link contains all of the following files.

All my 1080p source files used in the edit (1080p constant 30 fps):
20180929_131650.mp4
20180929_132416.mp4
20180929_133323.mp4
20180929_134331.mp4
20180929_135538.mp4
20180929_140155.mp4
20180929_141032.mp4
20180929_142624.mp4
20181004_103451.mp4
20181004_104006.mp4
20181004_104901.mp4
End Text Wipe v2.mp4

The .MLT file:
F36 v8 - 1080.mlt

And the (incorrectly) rendered export video:
F36 v8 - 1080.mp4

A few notes:
End Text Wipe v2.mp4 - I had trouble getting the final text effect to appear (horizontal wipe) so I created a separate project, encoded it and appended it to the end of the timeline as a source file.

Fade In/Out Duration - I originally had different durations for the Video Fade In and Out transitions as I was trying to find the best one. When I finally decided on 0:20 seconds I wanted to change them all quickly so I set the default value to 0:20 seconds for each transition and reset each application to the default duration. Not sure if this triggered the problem but I noticed that some of these durations changed in different versions of my .MLT files.

Shotcut Version - I’m using Shotcut version 18.09.16 on a Windows 7 PC.

Export Settings - I used the Video Mode HD 1080p 30 fps export setting because using Automatic would have rendered with 60 fps, which doesn’t match the source file frame rate.

Let me know if you see anything I might be doing wrong to cause the export mismatch.


#25

@shotcut - Hey Dan. I expect your pretty busy but wanted to give you a shout-out to see if you could take a look at the issues I mention in my post above and maybe check-out the files I uploaded to Dropbox (you do not need to have a Dropbox account to download the files). Thanks!


#26

I actually downloaded them, try upgrading to 18.10 it’s what I’m using and it came out fine both at 60fps on an h264 and 30fps on an h265 file, I’ll link them when they’re done updloading

https://drive.google.com/file/d/1UwbxU-N_1czp-p9rJSJWtNQZQs1ht6Kp/view?usp=sharing
https://drive.google.com/file/d/1uOnUikpYNQnLedVhMoFD–eLrlfAq6cC/view?usp=sharing

There they are(the mkv isn’t playing in google drive but can still be downloaded)


#27

There is no Export setting called that. If you change the Video Mode of an opened project, your are changing the project. Notice that there are categories in the Settings menu, and Video Mode falls under “Project.” If you change the project video mode, you need to review everything because not everything converts perfectly. It is fairly safe, on the other hand, to leave the project at its Automatic 60 fps Video Mode and then in Export simply change the Frames/sec field to what you desire. However, if you never intend to export at 60 fps, then you should set the Video Mode prior to starting a new project to make the preview faster and more continuous audio. I hope that helps.


#28

Dan, you are absolutely right. I am totally confused about the Project’s Video Mode and how it relates to the Export video settings.

I changed the Project’s Video Mode because my editing playback crashes, stops, loses video and garbles the audio. I blame my slow PC, not Shotcut for all this. So I thought dumbing down the Video Mode would fix the editing playback issues. This was based on my understanding that the video attributes of the Project were independent of the final export file attributes.

Looks like I was very wrong.

Time to do some reading…

Video messed up after changing video mode

After changing video mode, exported video is half length

Video mode what will happen if I change it after well into a project?

Export file doesn’t match timeline

OK, so moral of the story is NEVER use AUTOMATIC Video Mode. When you do, the entire Project’s Video Mode is based upon the attributes of the first source video you import. And if you first import an audio clip still image, you’re toast. So don’t leave it up to chance, pick a mode that matches the attributes of the video you want to export/render.

Specifically, if your project is using 30 fps and you change to 60 fps then the video playback will be twice as fast. And if your project is 4K and you change it to 1080p, then some of the effects that key off pixel location (like Text) will be shifted around.

But I still don’t understand why changing the Project’s Video Mode resolution but leaving the same FPS (which also matches the FPS of the source videos) is causing the encoding (also at 30 fps) to be so screwy. And my first video source file was the same as my project so changing it to something else and changing it back should have been OK.


#29

The automatic update in Shotcut wasn’t working.

So I uninstalled the old version through the Windows Control Panel and did a clean install of the new version.

Then I loaded the .MLT file, changed the Project Video Mode to "UHD 2160 30 fps" and exited Shotcut. I then edited my .MLT file in Notetab Lite to point to my 4K 30 fps video source files (oddly some of the file address references used forward slashes and some used backward slashes for the same location).

Re-opened the Project in Shotcut and exported to 1080p 30 fps.

IT WORKED!

Must have been a bug in the old version or my install was messed up.

Either way, I’m back in the saddle and completing my edit.

THANK YOU!